Jump to content

Tekkit Lite with Windows 8


Recommended Posts

Hello everyone-


I've looked around a little and didn't find an answer to this, but tekkit lite seems to crash with Windows 8. It will launch from the technic launcher, go through every screen, and even connect to servers (most of the time). After connecting, things get weird, run slowly, and eventually crash with an OutOfMemory exception. I have allocated 1536MB of RAM through the technic launcher menu. According to task manager, it never even reaches 1GB.


I have tried Windows 7 compatibility mode, clearing the cache, re-installing JAVA, reducing settings in minecraft to minimum, tried two servers, running as administrator. My GPU is an NVidia GeForce GT230M, and has the latest drivers from NVidia. I can play other DirectX 9,10,and 11 games. Also, since I'm getting a memory error, I'm thinking it's more of a memory management issue or something along those lines between tekkit/minecraft/JAVA/Windows 8. I have not tried Tekkit classic, but have tried normal, unmodded minecraft.

At this point I'm pretty stumped, it *SHOULD* work with Windows 8. I also SHOULD be able to allocated more than 1536MB (which technic launcher won't allow me to) as I could in Windows 7.

I'm sorry if this question has been posted elsewhere, but I have found zero answers to it, and pretty much users trying to get help, but only being harassed.... I made this post to be productive and solve this issue. So please, try to post productive things, keep Windows 8 debates, power trips, and user flaming in your pants.

Thank you for any help you can provide.

Link to comment
Share on other sites

Can you confirm java version? (run java -version) Current is 7u13. Also, did you manually install the x64 version, install both, or only install x86? (You can see this by if there is a Java directory in Program Files and/or Program Files (x86))

For reference, my versions are showing:

C:Program FilesJavajre7bin>java -version

java version "1.7.0_13"

Java SE Runtime Environment (build 1.7.0_13-b20)

Java HotSpot 64-Bit Server VM (build 23.7-b01, mixed mode)


C:Program Files (x86)Javajre7bin>java -version

java version "1.7.0_13"

Java SE Runtime Environment (build 1.7.0_13-b20)

Java HotSpot Client VM (build 23.7-b01, mixed mode, sharing)

Thank you for the help!

Link to comment
Share on other sites

You have the 32bit version of Java set as default which is why you can only allocate 1.5GB and are running out of RAM. Tekkit needs more RAM at least 2GB preferably 4GB. The easiest thing to do is remove the 32bit version. If you need both, (say if you use it in a web browser though fewer things do now) then remove both and reinstall them in order of 32bit first then 64bit second. The 64bit will set itself as the default then.

When you run java -version it should say 64-Bit in the bottom line imasonaz's first line

Link to comment
Share on other sites


After a bit of tinkering, I removed java (COMPLETELY) and re-installed both x86 and x64, in that order, from here: http://www.java.com/en/download/manual.jsp

Restarted, launched technic launcher, and it worked.

Thank you for those of you who read my request for help.

Honestly, this forum needs a 'karma' feature for the people who post useful, helpful things, and not just post the first thing that comes to their mind.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...