Jump to content

I just figured out how to overcome modder stubbornness/laziness.


Recommended Posts

I've been holding onto 1.5.1 because too many good mods haven't updated for 1.5.2 (which for most of them is just a recompilation) and won't recompile with the "srg" names either. Feeling sympathetic?


Because y'know what I just did?

I just deobfuscated the 1.5.1 Ars Magica using Immibis's "Bearded Octo Nemesis" in 1.5.1 MCP/Forge. Then I reobfuscated it with the srg names. Then loaded it in 1.5.2 without even a single error.

Minus the time spent figuring out how to do it, and just counting the time actually doing it, this was roughly five minutes of work for one mod. Yeah. A whole five.

Before anyone says "They're doing this for free out of the goodness of their hearts! Stop bitching or they might stop wanting to do it for ungrateful people.", I get it. I do. But this was five minutes, which obviously would have been a bit less without the added step of having to deobfuscate in the first place.

You want to know how easy it is to do this? I'll tell you.

Normally, the last step in making a Minecraft mod ready to publish is running a file called "reobfuscate.bat" (or .sh): This changes all the names into the alphabet soup that is Minecraft's primary anti-piracy measure.

To recompile with srg names, you run a file called "reobfuscate_srg.bat" (or .sh).

That's it.

No, really: That's it. Thanks to the magic of by-default alphabetic ordering in most operating systems' file browsers, they're even one above the other!

1) Deobfuscate with BON.

2) Copy contents of mod into mcp/bin/minecraft.

3) reobfuscate_srg.bin/.sh

4) Copy contents of mcp/reobf/minecraft into mod.


If anyone has any 1.5.0/1.5.1 mod that won't work in 1.5.2 that they want ported, give me a link and I'll see if I can't get it working just as easily as this one.

Link to comment
Share on other sites

Can I be the first to say this: Welcome back from the dead :D

Heh...thanks. Now hopefully I don't end up immediately Keller'd for misposting when I've been around long enough to know better.

Link to comment
Share on other sites

Neowulf is blue now? Neat. And it actually is that easy for every mod, as it turns out, though *most* have updated so it turns out I didn't have to do many. The roundup:

Ars Magica I reobfuscated with no issues at all: Bam, done.

DartCraft used a few API files from NEI, so I deobfuscated NEI, put those files in, reobfuscated, then took them back out again, and it worked perfectly.

ComputerCraft I was not able to reobfuscate because it uses RedPower API files. I didn't bother to try seeing if they're actually files from 1.4 RedPower or if he has some secret beta access, because quite honestly, fuck RedPower. I used to love it, but she's the third-most hypocritical Minecraft modder on the planet, and I've already replaced everything from her mod I cared about. (Immibis does microblocks that even work better than hers, multiple mods have sickle replacements, marble/basalt were just cosmetic, and some of the redstone stuff is even in vanilla now. Only frames are still RP-specific.) If anybody is really desperately hurting for ComputerCraft, I could try the old RedPower files to see if they work, but right now, meh.

Mystcraft I was not able to do because it's actually broken by version 665 of Forge that rewrote a bunch of event stuff, so the only way to upgrade that would be to decompile and try to rewrite the thing. I think I'll just do without it for now.

Everything else is either already 1.5.2 or is correctly compiled with the srg names or otherwise doesn't actually reference vanilla classes so there's nothing to reobfuscate anyway.

If anybody finds a mod that doesn't work on 1.5.2 that I didn't mention above, let me know and I can try. So far, it's even easier to reobfuscate a mod than it is to decompile it.

Link to comment
Share on other sites


You weren't horribly murdered and stuffed into a dumpster! Welcome back!

Haha, no. I was just too sick-to-death of the state of the modding "scene" and didn't come back to Minecraft until just before 1.5.1 came out. I'm trying to limit my contact with certain people's personalities so I don't go back to spitting nails.

By the way, come to the Kitty Jail! (Thread)

I looked in there a couple times. It smells like my dumpster out back, and has roughly the same content.

Link to comment
Share on other sites

I looked in there a couple times. It smells like my dumpster out back, and has roughly the same content.

And yet, after the first time you post in there, you find yourself coming back to it to post again and again... It's almost hypnotic in it gigantic state.

In fact, we encourage people to read ALL of it as an endurance test. Used to be a special title that noted your induction into that little club, the Super Trolls. Now it's just an invite to the Kitty Jail server.

Link to comment
Share on other sites

I looked in there a couple times. It smells like my dumpster out back, and has roughly the same content.

Eh there's the daily spam by our favorite kellers, but there's also the occasional interesting discussion when mods get on. Also, I doubt your dumpster is nearly as big.

Link to comment
Share on other sites

Well, Dartcraft and Ars Magica both updated to 1.5.2 within a day of me making this thread, so oh well for that, but I still learned.

However, I did just grab the 1.4.6 RedPower to try to reobfuscate ComputerCraft 1.5.1->1.5.2 and it worked, and that mod *still* has not updated for 1.5.2, so I'll go ahead and upload it. I'll make a new thread for that.

Since nobody's mentioned any other mods, I guess you're all good, or else you're all just using the Technic Launcher and nothing else. :P

Link to comment
Share on other sites

No, that's back in the 1.4 line. I can't just reobfuscate that: I'd have to completely decompile and rewrite the thing. Forge and Minecraft both have changed too much.

If you can find me a 1.5.0 or 1.5.1 dev/beta version or something, I can give it a shot.

Link to comment
Share on other sites

  • 2 weeks later...

According to the creator of Essentia Everything, he managed to get Mystcraft working on 1.5.2.


According to him, all he did was reobfuscate with _srg and didn't actually change the code, which is exactly what I did and found it's broken by Forge changes in newer versions. I haven't tested so I don't know if new Forge still breaks it: Just posting it here for completeness.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...