Jump to content

Tekkit 1.1.0


Cr4zy_M0nk3y
 Share

Recommended Posts

I know its still in its testing phase. But just out of curiosity. Would anyone know a rough estimated time for when they would release a server version? I'm eager to run a 1.5.2. Tekkit server lol. And yes, I have searched around a little bit trying to find the answer before posting. I haven't been able to find anything :\

Link to comment
Share on other sites

This is probably a very stupid question.. But, where could I get the server download? I go to technic's main page and all I see is 1.0.6. I can't find builds or anything on it. And thank you so much for the response! A week ago I was pulling hair out downloading false files to get one to run and ultimately had to redo my server while losing a ton of stuff. My own fault for not backing it up though.

I should also add, that this isn't a huge server or major server. Its only running for 2 of us. I have it running through the tekkit download for a server. Not sure if that will make a difference or not.

Link to comment
Share on other sites

The server version 1.1.0 seems to have an incorrect version of minecraft_server.jar packaged with it, getting a severe FML error on launch. Is part of running mcpc+ replacing this file? I was able to start a server after downloading the correct server jar from minecraft.net

Link to comment
Share on other sites

Glad to know this now. I won't be doing any server setup's till hopefully Thursday if I have off. I'm eager to get a 1.5.2 running. And hopefully getting some working mods also. Does anyone know if the Aether Super + pack works with 1.5.2? I'm curious with that one.

Link to comment
Share on other sites

Well this is weird... Now it seems like it's mostly just fine...

I was getting many errors like "[iNFO] [buildCraft] This world was saved with mod CompactSolars version 3.2.0.21 and it is now at version 3.2.3.23, things may not work well"

(That error is just made up but there seemed to be several dozen of them for all different mods) along with a huge wall of text I didn't even bother to read.

I restarted the server several times and eventually gave up. Now I restarted to copy the errors for you guys and the errors aren't there. I still get flashes of see-through chunks sometimes but it's a lot better then it was.

Link to comment
Share on other sites

Well now I have new problems...

I get home and go through these steps on my home computer and Minecraft crashes...

java.lang.IllegalArgumentException: Slot 700 is already occupied by [email protected]80 when adding [email protected]

at net.minecraft.block.Block.<init>(Block.java:340)

....

No idea what's up - I just can't install 1.1.0.

I started with no .technic folder and right off the bat installed 1.1.0 - crash

I started with no .technic folder and installed 1.0.6 - works fine

I upgraded 1.0.6 to 1.1.0 and I get the crash again.

Both computers running Win 8 x64 with 64 bit Java.

I tried again at work (remote desktop) fresh install straight to 1.1.0 and I get the crash or a dialog "Error retrieving information for selected pack: Tekkit"

So I try 1.0.6 from a fresh install and it works.

Upgrade 1.0.6 to 1.1.0 and I get a crash again.

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

java.lang.IllegalArgumentException: Slot 700 is already occupied by [email protected]7c when adding [email protected]

No idea where to go from here

Link to comment
Share on other sites

We updated to 1.1.0 and ran into a slew of issues aswell.

I played with it for 5 minutes then decided to scratch install.

I ended up backing up the server.properties file and world folder and then scrapped everything else before installing the new version (this is on linux mind you).

Also the client needed to be completely deleted and then reinstalled as everyone was getting the same white screen startup hang.

Just my experience, may not resolve or relate to your own issues.

Link to comment
Share on other sites

Well now I have new problems...

I get home and go through these steps on my home computer and Minecraft crashes...

java.lang.IllegalArgumentException: Slot 700 is already occupied by [email protected]80 when adding [email protected]

at net.minecraft.block.Block.<init>(Block.java:340)

....

No idea what's up - I just can't install 1.1.0.

I started with no .technic folder and right off the bat installed 1.1.0 - crash

I started with no .technic folder and installed 1.0.6 - works fine

I upgraded 1.0.6 to 1.1.0 and I get the crash again.

Both computers running Win 8 x64 with 64 bit Java.

I tried again at work (remote desktop) fresh install straight to 1.1.0 and I get the crash or a dialog "Error retrieving information for selected pack: Tekkit"

So I try 1.0.6 from a fresh install and it works.

Upgrade 1.0.6 to 1.1.0 and I get a crash again.

Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

java.lang.IllegalArgumentException: Slot 700 is already occupied by [email protected]7c when adding [email protected]

No idea where to go from here

We are getting the same thing! =/... did you ever figure out how to get the client to work? we have tried completely deleting ALL technic files in the /roaming folder even...

Link to comment
Share on other sites

We are getting the same thing! =/... did you ever figure out how to get the client to work? we have tried completely deleting ALL technic files in the /roaming folder even...

I ended up fixing the block ID error by going to C:Users(username)AppDataRoaming.tekkittekkitmainconfigbau5_ProjectBench.cfg and changing the block ID to something crazy high like 3333 so it wouldnt conflict with any other blocks in other mods. 1.1.0 opens just fine after that.

We also had to update the server mystcraft mod and bspkrscore to match the new client mods. and had to disable the project bench mod on the client to get everything to work.. MESSY!

Link to comment
Share on other sites

So I just downloaded 1.1.0 for the server and like the earlier post mentioned, the minecraft-server.jar file isn't the right version or something or another. I have an idea of what the MCPC+ thing is, however I don't quite understand what I need to download from there to set up my server. I apologize as I am fairly new to this and am probably doing a very newb thing anyway.

Link to comment
Share on other sites

EDIT: This seems to no longer work. As Dash mentioned below, it seems they are actively changing the 1.1.0 pack. I followed the same steps I used successfully below hours later and got new errors. Sorry.

I think I got it... finally.

Disclaimer: I've had a few beers trying to get this to work so... keep that in mind ;)

Server:

Download the 1.1.0 server from http://mirror.technicpack.net/Technic/servers/tekkitmain/Tekkit_Server_v1.1.0.zip and get it all extracted somewhere

Replace the minecraft_server.jar with the minecraft_server.jar from here https://s3.amazonaws.com/MinecraftDownload/launcher/minecraft_server.jar

I think that's all that's needed for the server.

Client:

Delete the .technic folder and .minecraft folders in AppData\Roaming

Open the Tekkit launcher and click the gear in the top right and change the memory to 4GB (optional step?)

Save and restart the launcher

Click the gear under Tekkit and change the version to 1.1.0

Login and download everything. When Minecraft crashes, close it.

open the .technic folder and go to the "coremods" folder - delete CustomPortForge.jar

go to .technic\tekkitmain\config and open bau5_ProjectBench.cfg and change the

block {

I:"Project Bench"=700

}

to

block {

I:"Project Bench"=3333

}

Open the "mods" folder and delete the the 'bspkrsCore', 'EnderStorage', 'mystcraft' and 'OmniTools' mods. These are out of date from the 1.1.0 server.

Replace those mods with the versions that came with the server, found in the server's 'mods' folder.

I just got myself and a friend running on my 1.5.2 server so I think this works.

Good luck!

If you want to enable optifine/shaders mods, delete the EnderStorage,jar from the server and clients 'mods' folder. Something about it makes those other mods unhappy.

Link to comment
Share on other sites

Uh, they are clearly adding new stuff to the 1.1.0 build, I now see Mekanism and Atomic Science modpacks in /mods. Those weren't in there a few days ago. Thanks for the tips, might need to update my 1.1.0 server.

Link to comment
Share on other sites

chjade84, to get the client working, all I had to do was change

block {

I:"Project Bench"=4094

}

to

block {

I:"Project Bench"=3333

}

Also, unless I'm very much mistaken, .minecraft has absolutely nothing to do with a default Tekkit install. So deleting it will change nothing.

Link to comment
Share on other sites

chjade84,

I think we'd better wait.

I really need to update only galacticraft because in the tekkit 1.0.6 version does not work the sealant.

I use google translator, sorry my English.

I think they are constantly updating the client, because I've done what you said and get a sign that says other mods have not been updated on the client.

- NetherOres, minefactory. I've solved by copying them from the server.

- Ee3:

The client version: EE3-pre1h-TechnicFix.zip

The server versión: ee3-universal-pre1h-16.jar

- It also came two more mods have not been updated, in the 2 put the word power. I do not remember now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...