Jump to content

Let's Test Big Dig 1.3.11!


Recommended Posts

Hey, everyone,

I've just promoted Big Dig 1.3.11 to Latest. There are a ton of key mod updates, along with the addition of a new mod: Simple Power Storage, by Technic's sct! SPS adds a "Makeshift Energy Cell" which can be used as an early-game alternative to the Redstone Energy Cell!

If you're interested in helping test, back up your worlds (SSP or server) and set your launcher up to use the "Latest" build, or manually select version 1.3.11. Play with us and report issues in this thread!

This is a clean slate, so even if you've already reported an issue elsewhere (including the 1.3.10 thread!), if it's present in 1.3.11, be sure to report it in this thread.

The 1.3.11 server can be downloaded here: http://mirror.technicpack.net/Technic/servers/bigdig/BigDigServer-v1.3.11.zip

Link to comment
Share on other sites

Changelog for Big Dig 1.3.11- this is a list of all changes since 1.3.9:

- Updated to Minecraft Forge build 723

- Added Mekanism support to Treecapitator configuration.

- Corrected a rare crash bug in the Forge transparency fix

- Added Simple Power Storage version 1.0.10

- Updated bspkrsCore to version 2.07

- Updated Immibis Core to version 55.1.2

- Updated Chococraft to version 2.8.5

- Updated ComputerCraft: Immibis' Peripherals to version 55.0.1

- Updated Forestry to version

- Updated Forestry: Extra Bees to version 1.6 pre 13

- Updated MineChem to version

- Updated Pam's Wee! Flowers to version 1.5.2 1.01

- Updated MineFactory Reloaded to version

- Updated Secret Rooms to version

- Updated Soul Shards to version 1.34

- Updated Nether Ores to version

- Updated Galacticraft to version a0.1.35.291

- Updated MFFS to version

- Updated Magical Crops to version 2.1.0

- Updated Tinkers Construct to version

- Updated Natura to version 2.1 RC 1

- Updated Natura to version 1.0.74

- Updated Atomic Science to version

- Updated ICBM to version

- Updated Mekanism to version

- Updated Open Peripheral to version 0.1.2

- Updated Not Enough Items: Plugins to version

- Updated Buildcraft: Logistic Pipes to version

- Updated Mystcraft to version

Link to comment
Share on other sites

Forestry has also been updated to on the changelog on the forestry website.. Adds in several more butterflies and fixes some crashes.

It's actually updated to in .11 too, I just screwed up the changelog is all!

Link to comment
Share on other sites

Does SCT have a post somewhere for Simple Power Storage? It's only that I noticed I couldn't craft the upgrades module thingys using the recipes in NEI, and I was wondering if I had just derped up...

I didn't have any problems with the NEI recipes just now, so if you could provide more info I'll try to help you out.

Link to comment
Share on other sites

Getting Texture errors when opening the indexer from Extra bees(?). Big white block Missing textures. May be the mod itself not conflicts.

Many of the NEI recipes for Mekanism machines are messed up, and I was unable to craft both the Energized Smelter, and Osmium Compressors, even though my crafting shapes were correct.

Confirmed both of these- trying to figure out what's causing the former and gonna harrass aidancbrady about the latter.

Link to comment
Share on other sites

I'm curious what the problem specifically is or how it is being caused? I like hearing explanations of the problems. Helps me understand the code a little.

Edit: Thanks for the Hotfix mate.

When you register a block in forge, it'll generate an ItemBlock (the item representation of a block that goes into your inventory) automatically with the same item ID as the block ID. But there are ways to register blocks that don't auto-generate an item with the same ID. But the mouseover and transmute code assumed that all blocks in the world had an item with the same ID and anytime it didn't find it, the game would crash.

hi checked this out but the file wasnt in config/forestry/base.conf but found it in config/forestry/common.conf and its already set to true

Hm, okay, I'll check it out a little deeper, then.

Link to comment
Share on other sites

Hey all. After doing the update to Big Dig and trying to play, my minecraft goes from the Mojang screen to white then nothing, it stays that way. I do have the most recent version of the game. I even tried to reinstall Big Dig to no avail. I don't even get a error crash nothing, nothing from a change log or a crash report. I have no idea as to what the heck is going on. Has any person possibly heard of this happening? Gimmie a few and Iwill try a diffrent mod pack. . . . . trying the crafting dead pack. . . . . .works. . . . . . trying volts. . . . that works to (yes I actually tried them both (-: ) Okay so it isn't the launcher. Ihave no idea. Big Dig is so far my favorite mod pack. Imade sure that I have a back up of the world file so Ican polay it when things are fixed. I just have no idea what else to do.

Good night.

Friday June 7, 2013 @ 10:38 pm Arizona time

Tried to start Big Dig today. On a plus side it no longer goes to a white window. It just stays at the Mojang screen. I can copy the logs and zip them for some one to review if they like starting with last night when I started to encounter this problem.

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...