Jump to content

Id Mismatches for friends' but not mine


ares0027
 Share

Recommended Posts

"id 20349 is mismatched between world and game

 

forge mod loader has found id mismatches"

 

this is the error my friends get when i create a server (open to lan), or i use the official server files(dedicated). i have found that some mods are changing the id of ingame items in order to prevent conflicting ids, and somehow those mods are giving randomised numbers depending on the host os (which made sense, in a way, since i had win 8.1, and one of my friend had win8, other had win7) then i tried the dedicated server, we rented a server, uploaded jar, created a whole new world, i could connect and again, all my friends received this error (and if i am not wrong, that id number is changing from time to time, but i am not sure atm)

 

i made them create a server, and i could join, but when i create a server, or when we use our dedicated server, it is impossible for them to join. i tried both recommended(1.3.9) and latest beta (1.3.13) and still no luck.

 

though while writing this something came to my mind, which i cannot try without my friend; since i am the one setting the server up and testing it, i am the first person ever connects to the server. when my friends create the server, they are the first ones to connect to server. so i assume that server is getting ids from that person's client therefore, when i set it, it gets ids from me, and they are different from theirs, but when they set it up, my pc "shomehow" adapts my ids to theirs (it sounds stupid when i read it :D) so for this theory, i will delete all the files from my dedicated server, set it up, and make them connect first.

 

anyway, does anyone have a real solution for this? i can connect to any server (including mine and theirs) they cannot connect anyone but their own. and since we are going to use a dedicated one, we need to connect that server

my pc (incase it is necessary)

intel i7 2600k extreme edition (stock)

16gb (4x4) ddr3 1600 MHz ram

240 gb Kingston SSD, 16 TB HDD (tried installing the server to all my 5 internal drives)

windows 8.1 pro x64

Java 7 (Update 9) (x64)

Java 7 (update 51)

Link to comment
Share on other sites

Here, as an update, i managed to install different virtual machines on my pc. As you can see i am running 32bit Windows XP Pro, 64bit Vista Ultimate, 64bit Windows 7 Ultimate, 64bitWindows 8 Pro (and of course my main pc, host, as 64bit Windows 8.1 Pro)

 

they all(except main pc) used latest 32 bit java (jre-7u51-windows-i586) and i tried to connect my dedicated server. all connected but windows XP, i received same mismatch error as my friend, and found out that 2 items are pipes from buildcraft, other is sledge (from what is unknown to me)

 

i used same world file for xp, it gave me same error for single player, but i could press "yes" and continue. i could find those items, and could give then through cheat code and through "Cheat Mode" from my inventory. So how could they be mismatching? they are with same id?

anyway, for "ss or didn't happen" here you go;

 

6c8bb4c5.jpg

 

 

 

P.S. Any help is appreciated, please do tell anything if you have any idea.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...