Jump to content

Can't use morph mod on server.


Recommended Posts

A while back, I made a server on Attack of the B-team. To start the server, I ran the file minecraft_server.1.6.4. The server started, but the morph mod didn't work. When I pressed bracket, there was the black box, but it was empty.

So I looked around the internet and found out you need to run the launch.bat file. Here's what came up:

 

C:Users(My computer's user name)DesktopAttack of the B-Team Server>java -Xmx3G -Xmx2G -jar

 Bteam.jar nogui

'java' is not recognized as an internal or external command,

operable program or batch file.

 

C:Users(My computer's user name)DesktopAttack of the B-Team Server>pause

Press any key to continue . . .

 

When I pressed a button, the window closes. I've tried changing the -Xmx3G to -Xmx2G, but still nothing works.

 

I'm new to server making and hosting, so if there is a way to get the .bat file running correctly, please tell me.

Link to comment
Share on other sites

For future searchers, this is caused by the PATH variable not being correctly set (so when the batch file tries to call java.exe it can't find it).  It was fixed in this case by installing java 64 (which reset the PATH variable as part of its installation) but uninstalling and reinstalling java should have the same effect.

Link to comment
Share on other sites

What Loader said, however also keep in mind that installing 64bit java on a 32bit machine (also known as x64 and x86 respectively) is just impossible. So keep in mind that your operating system's bit is important on which of the two versions of java is necessary. This said, using 32bit on a 64bit is generally bad practice and will limit you severely (most noticeable in the limitation of RAM assignable in the launcher) in most things. Always double check which one you have before you go out and download a version of java (also, at the time of this posting, Java 8 has had some issues with this modpack and isn't recommended by myself to use with this modpack until the mods support it or java 8 is stable enough to be backwards compatible - both of which need time)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...