Jump to content

Problems flying with Modular Powersuits


Silmenume
 Share

Recommended Posts

I've been playing for about a month on a private server.  For almost all of that time I've been flying in a Modular Powersuit without any problems.  A couple of time the suit's heat went crazy but cooled off fast enough to forestall death.  The other day I was not so fortunate.  I was flying along when all of a sudden I was taking fire damage many multiple times a second.  I was dead in under a second.  I've read around that the problem might be an issue upgraded solar power generator.  I dealt with that later.

 

I jumped into creative mode when I respawned and rushed over to reclaim my goodies.  When I got there my entire suit was missing as was a number of other items (one was a Large Backpack that was half full - GAH!).  In fact the number of items remaining was just enough to fill my hot bar.  As that is only one data point, I don't know if that is significant or not.

 

I got home, rebuilt my suit and started to try and fly around again.  Note the word, "try."  I can climb straight up and dive straight down at the regular high rate of speed.  I can fly left, right and backward (once up in the air) by just pressing the, "asd," keys - but at a rate that is somewhere between vanilla walking and vanill running.  When I press the forward key, "w," I drop as if the flight motor was cut.  The flight system is not off as I can still manuever out of the fall.  If I keep my fingers on both the space bar - up - and the "w" key - forward - my climb immediately levels off and I just barely creep forward.  Forward at a speed about akin to a "creep".  I do not exagerate.  I've tested it at just above ground level.

 

I rebuilt the suit the same was as it was before I died and that configuration was working fine.  I do have the flight computer and the jet pack. They are keybound so I can see messages on the screen that both are running.

 

I play the world from 2 computers and both are showing the same problem so I am assuming this is on the server side.

 

Any suggestions on how to try and fix this.  Not flying reaaaaaaaaaaaaaly sux!

 

Best,

 

Jay

 

edit - clarified one sentence to make it more readable - I hope!

Edited by Silmenume
Link to comment
Share on other sites

Peculiar. I can think of one non-bug reason, i.e. you forgot to enable one of the components. I usually bind all necessary keys for flight to a single button in the Powersuit key bindings, namely Jetpack, Flight Assist and also the Parachute. Can't remember if that was all, as I have not been using a Powersuit for a while (Simply Jetpacks for the win).

 

And as I hinted, it might just be another bug.

Link to comment
Share on other sites

also check the total weight of your suit, if it is too heavy, the flight control can keep it in place, but flying forward and gaining height is a pain.

Also it gets slower then...

 

weight tip: don't use builtin batteries, just hold an energy cell in your inventory ;) (must be charged)

Link to comment
Share on other sites

Thanks for all the tips guys!

 

I did go with the removal of all the batteries and the keeping of a energy cell in the hot bar.  That fixed the problem with my forward speed.  I am now back to the forward speed I had from my first suit when I did have all 5 built in batteries.  I am not complaining about having my speed back, but I am frustrated that the MMMS insn't acting consistently.  However...

 

While I do have my forward speed back I do fall when going forward if I don't also keep pressing the up button.  The fall is slower, but it is definately there.  So I have to constantly fly in this serpentine path of up and down (falling) when flying forward.  The reason being if I keep pressing the up key while flying forward I continue on an upward arc indefinately - so I have to stop the upward thrust at regular intervals.  Which then starts me on a downward trajectory.

 

I suppose I should be happy that I got my speed back...

 

Does anyone think this might be fixed by reloading the mod pack on the server or is the problem stored in the save file?

 

Thanks!

 

Best,

 

Jay

Link to comment
Share on other sites

did you tinker your flight control module?

if you set this thing any higher than 0, then it reacts a bit strange...

on 100%, it flies in the direction you look, at 0 percent it stays on the same level and you have to manually adjust your height ;)

I didn't know the flight control module was tinkerable!  I'll have to give it a look!  Thanks!

 

Best,

 

Jay

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...