Jump to content

Fixing Computercraft redstone outputs in Ultra Modded Survival [Solved Solution]


Recommended Posts

I just spend an amazing amount of time getting this to work, and I have seen no known solution for it so far. So, here's mine. It may be outdated now, and may not work for you. I haven't tested it well, but my server booted, and I could log in.

Related problems -

https://github.com/MinecraftPortCentral/Cauldron/issues/1657

https://github.com/MinecraftPortCentral/Cauldron/issues/980

 

Poor SW9876 of Github, I can't message you directly. -.-

 

Anyways, this is upgrading Ultra Modded Survival Server v1.4.6

http://www.technicpack.net/modpack/details/ultra-modded-survival-pack.266012

 

 

So, enough linking is enough. How do I get computercraft to properly update redstone outputs with UMSP? Update from MCPC+ to Cauldron. It's harder than it sounds to figure out, but pretty easy to do.

First things first, you need -
1. Your server file for Ultra modded survival.

2. cauldron-1.6.4-1.965.21.197-installer.jar from: http://files.minecraftforge.net/Cauldron/

3. forge-1.6.4-9.11.1.965-installer.jar from: http://files.minecraftforge.net/

4. run.bat from your server file.
5. minecraft_server.1.6.4.jar (I got this from https://mcversions.net/ and it seemed to work)

 

So, create a new folder with 4 things - cauldron-1.6.4-1.965.21.197-installer.jar, forge-1.6.4-9.11.1.965-installer.jar, run.bat, minecraft_server.1.6.4.jar
 

Follow step 5 from here - http://cauldron.minecraftforge.net/wiki/primer-for-cauldron-and-forge/

Or, follow my quick instructions below.

Navigate to your new folder in command prompt. Enter in the command below.

java -jar cauldron-1.6.4-1.965.21.197-installer.jar --installServer

 

('--installServer' does require the S to be a capital.)

Let it run.

 

Then, run forge-1.6.4-9.11.1.965-installer.jar in java (not in a command prompt).

Select "Install server" and navigate to your server base folder (where run.bat resides). Hit OK.

 

It will install forge, but no more dependencies.

 

Now, run your run.bat file, after changing it to reference the new server file.

Your run.bat file should contain something like:

java -Xmx4G -Xms1G -XX:MaxPermSize=256M -jar cauldron-1.6.4-1.965.21.197-server.jar nogui
pause
 
Let it just run, make sure it works.
 
Now, last things last. Lets move over your server files. MAKE SURE YOU BACKUP AND ONLY DO COPIES!
 
MOVE OVER 6 THINGS. DELETE PREVIOUS VERSIONS FOR BEST RESULTS.
1. assets
2. config
3. Flan
4. hats
5. TCPlayerData
6. Your world file data. (For me it's 'world')

 

Run your server, ensure it works. No further modifications were needed for it to work for me.

 

A thanks to the whole Forge team, the technic launcher team, dan200, lyqyd, blood, and everyone else who contributes to the modding community!

 

Sorry for the lack of organization and proper grammar, and clearness of instructions. I sacrificed sleep to get it working, I thought i'd sacrifice a bit more to get you guys a working fix. Also, sorry if this isn't in the right place.

 

Happy Minecrafting!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By BoomiCat
      Hi there, I have made several modpacks before and followed the exact same steps, however when I install and play it on the launcher: it either doesn't even open Minecraft or if it does, then it's just base 1.12.2 Mc without any installed mods from the modpack.
      Here's the link to the Dropbox folder:
      https://www.dropbox.com/s/wrauzcqbt2dbz79/World of Snow.zip?dl=0
       
      Regarding the changes to Dropbox's changes: I followed the forum thread solution of changing the necessary parts of the link (www to dl, dropbox to dropboxusercontent, ?dl=1).
      I updated the modpack several times as I thought the root of the problem may have been the Forge 'modpack.jar' file. I've so far tried the 'Latest' and 'Reccommended' Windows Launcher, Universal and Launcher downloads. No result.
      Maybe it is a specific mod or a combination of mods making the whole modpack unplayable?
       
      Thanks for any help,
       
      Charlie
    • By Cats1337
      Hello, I've been using a modpack I made that's basically the 1.12.2 Pack, just modified for me and my friends to play, and recently it just stopped working for me. It crashes when I load it up and never actually loads.

      Pastebin of Error Logs:
      https://pastebin.com/kEjHF38U
      I thought originally that it was a line 264-265, with ersatz, or something to do with ram, but not exactly sure...
    • By KastenKlicker
      Hey,
      I have a very common problem and read many different topics about it, but nothing helped me.
      So I want to create a little modpack to share it with some friends, but the modpack always starts Vanilla.
      I tried to compress the folders with 7zip and WinRar, but nothing worked.
      The modpack is downloaded correctly.
      Here is the link to the page of my modpack (It's not shown so you have to install it over the url) : https://www.technicpack.net/modpack/stalincrafts-modpack.1717127
      Maybe you find the problem and help me!
      Thank you for your help!
      I think the documentation should be updated, it's wrong.
      So I found this topic from yesterday solving my problem: 
       
    • By GrantTheWizard
      Hello, I am new to LUA but not in programming. I am not understanding why my blockchain is not working.
      It is supposed to go 40 blocks down the row(Hence the for loop for count 40)
      Then when it gets to 40 come back(I need to change the 3 to a 2) but what it does right now is it digs the first wheat then stays there, then executes the turn then stops. Any ideas on how to fix?

    • By ZeZoBeatz
      As you see by the title, I am trying to help a random person on the server I play on with ComputerCraft. He made a program called LockExe and he just sells it on the server. It is very simple program. It just reads for the password and when you input it, the computer outputs a redstone signal for 5 seconds out the left side and then stops, then the computer reboots back up to the startup screen where it asks for the password again. But I just discovered the 'terminate' feature through ComputerCraft and I do not think he knows about it. So I am trying to edit his code so it disables/makes it harder to terminate the program so no-one can just steal his code. But everything that I have tried with the code keeps breaking the program. I keep using the os.pullEventRaw and that can read for the terminate event and can make it do other things besides just terminate but there are issues that I have found with using that. The first and main issue is that the os.pullEventRaw stops the programs entirely, meaning that it no longer allows me to type anything in the computer and it insteads waits for the input of the terminate event. I do the terminate event and whatever I made it do after the input happens, it does. Like if I tell it to type something out after I do ctrl + t, it tells me it. But this means that the password cannot be typed in. The second issue is after I use ctrl + t to do that terminate event, I can just do it again and it will terminate that so it will bypass it anyway. Like I said before, I am trying to help him out with his program just so no-one can steal it. Btw, he did not ask me to do any of this, I am doing it because I wanted to see if I could. But it seems I need help. This is the coding of his program just incase it helps.
×
×
  • Create New...