Jump to content

Considerable lag while playing Tekkit in single player


EarthModule
 Share

Recommended Posts

Hello!

I'm experiencing lag while playing Tekkit in single player survival to the point its unplayable for me. I'm using latest Tekkit recommended build with Minecraft Java Version 1.80.31 (64 bit). No additional mods are used. From Launcher Options I've allocated 5 GB of ram limit for java to use. I tried to change Minecraft-video settings to minimun, but the problem persists. Vanilla Minecraft works smoothly. Any help with this problem is greatly appreciated, I would really want to play Tekkit and conquer the moon!

 

Minecraft video-options I use:

Graphics: Fast

Render Distance: Tiny

Smooth Lighting: Off

Performance: Max FPS

3D Anaglyph: Off

View Bobbing: On

Advanced OpenGL: Off

Clouds: Off

Particles: Decreased

Server Textures: On

Use Vsynch: On

 

My computer specifics:

OS: Win 8.1 (64 bit)

Processor: Intel Core i5-2430M  

Processor speed: 2.40GHz

Number of Cores: 4

RAM: 8.1 GB

Video Card: Intel HD Graphics 3000

Video Card Dedicated Memory: 32 MB
Video Card Total Memory: 1.6 GB
Java Version: 7.0.670
 
EDIT1:
Found Tekkit-Launcher logs for today, they seem to include lots of "GL errors". here are couple of first lines from the log: http://pastebin.com/ECHgrx6Q
Edited by EarthModule
Link to comment
Share on other sites

This log fragment indeed looks like a promising lead. Unfortunately, I have no idea what may be causing this.

Standard cause for fps drops and lag in singelplayer is usually security software (Anti-Virus and such) holding Tekkit files hostage or constantly re-checking them. You might also have an unfavourable graphics driver setting, so maybe check with default settings.

 

Apart from that, you are supposed to take all issues to the tracker. But I honestly can't say if anybody following it will be able to help you.

Link to comment
Share on other sites

I was having crazy lag issues as well after playing Tekkit a bit and building some of the more advanced items. So i installed Optifine and that seemed to have cleared everything up.

 

Didn't check my error log though, so that could be completely different.

 

Just my 2 cents.

Link to comment
Share on other sites

Optifine may still help some people for some reason, but most of the time it will break more than it fixes. If you try it, be prepared to remove it again if the game starts acting strangely or crashing.

 

I much rather recommend Fastcraft.

Link to comment
Share on other sites

Thanks for your quick responses to my issue!

 

Curunir: I don't know if IssueTracker is right place, as this has probably more to do with my machine than code. I tried turning my antivirus software off, then ran Tekkit-launcher as administrator and re-installed Tekkit, but problem persists. I'm going to try out Fastcraft and another re-install to produce clean errorlog. I'll let you know if I find something worthy.

Link to comment
Share on other sites

disconsented: Ok, I did the following steps:

I started Tekkit from the tekkit launcher, took some debug screenshots while playing, then quit and uninstalled the Tekkit-modpack. I relaunched Tekkit-launcher with administrator rights and re-installed Tekkit-Modpack. When I started playing the first time after install, minecraft crashed (this has actually happened everytime after installing Tekkit-Mod, just forgot to mention).

 

What I figured so far:

 

While playing statistics:

FPS is constantly between values 0-9 but average is 0-5. Java is taking around 1.4 GB of RAM while playing Tekkit-Mod. It also takes around 30-60 % of my processing power. 

Debug Screens while playing first time: 1, 2, 3 (Sorry for the quality, full screen print screens did not work. If you want I can take full screen debug-screenshots after I get some software that takes screenshots while fullscreen is on)

 

While re-installing log (nothing interesting here, I guess)

 

First launch-log after installing (that crashed):

according to log it tried to do something with forgeMod before encountering javaException (same one as below). The Log also has numerous warnings and severe warnings like "[WARNING] [Forge Microblocks] Mod Forge Microblocks is missing a pack.mcmeta file, things may not work well" and "[sEVERE] [Minecraft-Client] Using missing texture, unable to load: calclavia:textures/blocks/multiPart.png"

 

Crash-report when first launching after install:

Reason of the crash seems to be Java Exception (java.util.MissingFormatArgumentException). On the end of the crash report I found another error: Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

 

Second time launching the game after installing log  (Just for comparison with the first one, if someone wants to do that :P)

 

Generating new wold -log (Lots of warnings)

 

I guess I can conclude it has something to with installation-process, just can't pinpoint the exact reason.

 

 

Link to comment
Share on other sites

1. Allocate less (yes, less, yes, I'm not kidding) RAM to Minecraft. The current setting is too high (-Xmx5120m). Bring it down to 2-3GB.

2. Your GPU is... um... not the best (Intel® HD Graphics 3000)

3. Try adding -Dforge.forceNoStencil=true to your starting parameters. If any graphic issues occur revert it.

4. The only way to really hard-reinstall a modpack is to delete it in the launcher and then manually delete all files from ./technic/modpacks/tekkitmain and then to install it again using the launcher.

5. Be sure your antivirus software is set not to scan the .technic directory. The same applies to any anti-spam/firewall software.

Edited by bochen415
Link to comment
Share on other sites

About the Intel graphics, modded Minecraft should at least run decently on those chips. I tried it once and while it was not great, it ran smoothly with settings toned down. What the OP describes cannot be attributed to anaemic Intel graphics alone.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...