Jump to content

Custom modpack. Fails to extract zip file.

Recommended Posts

I've put together a small custom modpack for use by a few friends of mine.  The mod pack it's self works just fine if manually installed, but if I try installing it through the technic launcher, it downloads just fine, but when it gets to 44% mod installation, it freezes and throws an unable to extract file error.  I've followed the "how to make a modpack" and "how to make your pack available through technic launcher" tutorials and don't see anywhere I've gone in error.


I've gone through and tested the zip file it's self, I can find no errors with the zip file or the files contained in it.  I can manually extract the files into the install folder it is trying to place them into and play the pack just fine as well.  The launcher just can't extract all the files from the zip file...


compressed using 7-zip in .zip format

file hosted on dropbox with arguments set to allow direct download.


The modpack: http://api.technicpack.net/modpack/jakpack-villager-edition  it's still basicly a beta but is fully playable, if it will actually install...

Edited by jakalth
added pack link
Link to post
Share on other sites

ok...  ran the test, got unhandled exception error, and malformed.  That's it.  no idea what I'm supposed to do with this info or how i'm supposed to fix the problem when the zip file opens just fine, just not through the launcher.

Edited by jakalth
Link to post
Share on other sites

Tried making a new zip file.  same issue.  tried redownloading and installing every mod in the pack, pulling out the config files, mod files, and forge, then repacking them into a zip file again.  same issue.  tried changing the zip file compression ratio and settings for 7-zip.  once again  same issue...


Edit: found the issue.  Both the technic launcher and your checker file do not like the Millenaire mod.  If I remove the mod and it's associated files, the zip checks out clean,  when I add them back in, it throws an error...  without millenaire, the modpack is basicly useless...


Any ideas how to get Millenaire to play nice with the technic launcher?

Edited by jakalth
Link to post
Share on other sites
  • Discord Moderator

Yes, Millenaire. Years of development and they still haven't figured out how to properly package a mod.

Try removing and re-extracting the Millenaire mod. I did that and was able to get your pack working by replacing the modpack archive downloaded by the Launcher. The issue is that the Launcher doesn't like one of the file name characters inside the /mods/millenaire/languages/ folder.

Link to post
Share on other sites
  • 1 year later...
  • 2 weeks later...
On 9.10.2015 at 2:18 PM, kylfederer123 said:

While using zip files it may become corrupt due virus infection, software conflict crc error and many more. I too had faced the same problem and my zip file got corrupted. I tried many ways to repair the zip file as it contained many important documents. At last I was able to extract zip file with the help of Zip File Repair Tool. I was able to recover all the documents in it. Most importantly this software is very user friendly


Sounds fishy advertising to me please remove this post.

On 16.7.2016 at 5:12 AM, Sulsakan said:

Interesting post...I've ran into a similar issue trying to download Steve's Galaxy...it gets stuck at 85%.

Anyone have a similar issue?  Any recommendations?


thanks much

Mm can you post link to that file?

Link to post
Share on other sites

If it has an error that says that it can't download and says that it can't extract .zip, do this

1. Take your link from dropbox https://www.dropbox.com/s/anch3l08tnvsisu/FaiconcraftI%26W1.2.zip?dl=0  (don't try this I've changed it)

2. Change the www. to dl.

3. Change the dl=0 to dl=1

4. Use that link

5. Check out Faicon Craft I&W 

Edited by Mordecai171
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...