Jump to content
  • 0

There is a new common problems thread


Zebrin
 Share

Question

Mod edit: This thread is being retired in favor of a new one. Thank you Zabrin for creating this one.

Please look at this thread for current information.

http://forums.technicpack.net/index.php/topic,4191.0.html

IF THE LAUNCHER ACTUALLY LAUNCHES POST YOUR NEWEST LOG (the one called launcher_0.log) ON www.pastebin.com THEN THE LINK HERE. LOGS ARE FOUND IN .techniclauncher/logs

Ok, there have been a lot of people opening threads asking the same damn questions that have already been answered several times before. This thread is for the hotfixes and work arounds that have already been found. Do NOT ask questions here. They will only shit up the thread. If you do not see a fix here, and have one feel free to post it and PM me so that I can update the op. Anyone who does ask a question in this thread will be ignored at best.

Windows users: The Technic Pack is downloaded to C:\Users\<User Name>\AppData\Roaming\.techniclauncher

It is a hidden file, so go to your Control Panel, select Folder Options, and in the view tab turn view hidden folders on.

Mac users. The Technic Pack is downloaded to ~/Library/Application Support/techniclauncher

Problem: When using the launcher, It opens, says "Checking Launcher Version" And then shuts down. Spout does not open afterwards.

Reason: Unknown.

Solution: Go to AppData\Roaming\.techniclauncher and open the techniclauncher.jar file in java. It will open the launcher, and will let you play technic through spout.

Problem: Unable to change mods Using the Mod Select function.

Reason: Likely you don't have .cfg files set to be read yet.

Solution: go to AppData\Roaming\.techniclauncher\technicssp\config and right click on any of the .cfg files there. click open with and set it to always run with notepad.(Macs use textedit) Now you can change mods within the launcher.

If the option is greyed out just click on the big technic logo and it should become active again.

Problem: 'Can't find java directory'

Reason: Likely using an old version of java. Or the wrong type.

Solution: Try downloading the Java 7 version here http://www.oracle.com/technetwork/java/javase/downloads/jre-7u2-download-1377135.html

Also if you are using 64 bit windows try installing the 64 bit version then setting it as the default Java used in your controlpanel.

Problem: Norton deletes the file when I download it. citing "WS.Reputation.1

Reason: The program is new, without a large company behind it.

Solution: Get a new Virus scan Right click on the Norton security suite icon in the lower right hand corner near your clock, and disable the antivirus auto protect. just set it to turn on again in 15 minutes if you feel uncomfortable about it being off.

Problem: NEI won't let me cheat!

Reason: It is locked into recipe mode.

Solution: Well if you really want to cheat so badly you go into AppData\Roaming\.techniclauncher\technicssp\config and find the NEI.cfg file(Note, NOT the mod_notenoughitems.cfg file) In there find a line that says

"lock_recipe_mode=true" and change it to

"lock_recipe_mode=false"

Problem: I can't turn off NEI(And a couple other mods) through modloader.cfg!

Reason: Those mods are not in the mods folder, so modloader doesn't have anything to do with them.

Solution: Sorry but, looks like you are going file hunting. If they are not in the mods folder that means they were hard added to the .jar meaning you will have to find out what classes they added and changed and revert them the hard way.

Problem: Ok, I tried everything, and the .exe still wont work!

Reason: Varies.

Solution: Well, if you can't get the technic-launcher.exe to work, download the .jar itself and run that through java. You can find it easily under the mac version of the technic pack. (Which is not mac specific, just a .jar.)

Problem: I am running the launcher, but every time I select Login it freezes at a white screen!

Reason: The "Latest Light Weight Java Games Library Binaries" option doesn't work for everyone.

Solution: Turn off advanced lwjgl.

Problem: The latest LWJGL binaries option wasn't on and I am still getting a white screen.

Reason: Varies.

Solution: First, try going to AppData\Roaming\.techniclauncher\technicssp\bin and open the jinput.jar in 7zip. Delete Meta-INF. If that doesn't work nuke the .techniclauncher folder and re-download it.

More to come as more solutions are found.

Link to comment
Share on other sites

  • Answers 129
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0

Re: Common Problems (And their solutions)

Still, I can't use the "Select Mods" option. I've defined the .cfg default program as notepad, opened the launcher and the option wasn't greyed out, I clicked it but nothing happened. I tried setting notepad++ as the default program, still the same thing.

I'm on a Windows 7 64Bits.

just open your modloader.cfg manually. That's all the mod select button does.

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

I can't seem to get the launcher to completely start. I get the bar where it looks for updates and it gets to 100% before it closes. Nothing happens afterwards. I have tried launching the jar by itself but CMD just opens and closes instantly and I am using Java 64 bit (64bit Win 7 PC). I'm confused why this is happening, my friend just did it and it worked perfectly fine. I also cleared out the roaming folder and re downloaded the Launcher but that isn't working either.

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

Is there any way to get it set up without an internet connection? For instance, I download the launcher on my mobile, and tranfer it over to my computer which currently has a fried network card. Could I instead get a zipped form of it, as in previous iterations?

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

I've discovered that those ridiculous lag spikes I was getting can be resolved by turning dynamic updates on. It took 10 years and the support of an entire nation, but the end result of all the fiddling was a lag free SSP game.

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

i seem to be having a problem that when i go into tecknic pack i cant see any of the recipes

You gave us a worthwhile total information of none. We can't help you like this.

What exactly were you trying to see the recipes in?

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

the bit at the side of the screen when you go into invventory

was you press the 'R' key for the recipe for the item? Or the 'U' key for uses?

I dont seem to have zeppelin mod?

Zeppelin mod wasn't installed in technic 6/tekkit 2!

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

My tekkit says this:Mods loaded: 41

ModLoader 1.1

mod_ModLoaderMp 1.1v4

mod_MinecraftForge 1.3.3.12

mod_NotEnoughItems 1.1.1

mod_CCTurtle 1.3

mod_ComputerCraft 1.3

mod_EE EE2 v1.0.0

mod_InvTweaks 1.38 (1.1)

mod_MAtmos_forModLoader r10 for 1.1.x

mod_NetherOres 1.1.0R1.1.2

mod_RailcraftAutomation 3.3.1

mod_RailcraftBuildcraft 3.3.1

mod_RailcraftCore 3.3.1

mod_RailcraftExtras 3.3.1

mod_RailcraftFactory 3.3.1

mod_RailcraftIC2 3.3.1

mod_RailcraftInfrastructure 3.3.1

mod_RailcraftRails 3.3.1

Balkon's WeaponMod 1.1.0 v8.4.0 SMP Edition

mod_WirelessRedstone 1.5

mod_WirelessRedstoneClient 1.5

mod_ReiMinimap v3.0_01 [1.1]

mod_RedPowerArray 2.0pr4d

mod_RedPowerCore 2.0pr4d

mod_RedPowerLighting 2.0pr4d

mod_RedPowerLogic 2.0pr4d

mod_RedPowerMachine 2.0pr4d

mod_RedPowerWiring 2.0pr4d

mod_RedPowerWorld 2.0pr4d

mod_BuildCraftCore 2.2.12

mod_BuildCraftBuilders 2.2.12

mod_BuildCraftEnergy 2.2.12

mod_BuildCraftFactory 2.2.12

mod_BuildCraftTransport 2.2.12

mod_IC2 v1.71

mod_PowerConverters 1.1.0R1.3.1

mod_Clevercraft 1.6.2

mod_ItemDescriptions 1.3

mod_EnderChest 1.0.1

mod_Forestry 1.2.6.4

mod_zAdditionalPipes Rev32.3

Minecraft has crashed!

----------------------

Minecraft has stopped running because it encountered a problem.

If you wish to report this, please copy this entire text and email it to [email protected].

Please include a description of what you did when the error occured.

--- BEGIN ERROR REPORT b693b70d --------

Generated 3/2/12 3:33 PM

Minecraft: Minecraft 1.1

OS: Mac OS X (x86_64) version 10.6.6

Java: 1.6.0_22, Apple Inc.

VM: Java HotSpot 64-Bit Server VM (mixed mode), Apple Inc.

LWJGL: 2.4.2

OpenGL: NVIDIA GeForce 9400M OpenGL Engine version 2.1 NVIDIA-1.6.26, NVIDIA Corporation

java.lang.IllegalArgumentException: Slot 235 is already occupied by [email protected] when adding [email protected]

at oe.<init>(Block.java:176)

at oe.<init>(Block.java:204)

at ic2.platform.BlockCommon.<init>(BlockCommon.java:12)

at ic2.common.BlockTex.<init>(BlockTex.java:30)

at ic2.common.BlockDynamite.<init>(BlockDynamite.java:31)

at mod_IC2.initialize(mod_IC2.java:265)

at ic2.platform.Ic2.load(Ic2.java:65)

at ModLoader.init(ModLoader.java:824)

at ModLoader.AddAllRenderers(ModLoader.java:189)

at afq.<init>(afq.java:80)

at afq.<clinit>(afq.java:9)

at net.minecraft.client.Minecraft.a(Minecraft.java:316)

at net.minecraft.client.Minecraft.run(Minecraft.java:624)

at java.lang.Thread.run(Thread.java:680)

--- END ERROR REPORT fb79f5d8 ----------

PLEASE HELP :)

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

Hey guys. I don't really know what my problem is. But I've downloaded both the LAUNCHER JAR and LAUNCHER EXE and put them on my desktop. So what I did was to choose the mod "Technic", write my login+password and then pressed login. Then it started loading something in a bar (right under the mod selection box) and when it finished it gave me a message saying "Update Failed!"

Please help me as soon as possible

-Alasadi

MOD EDIT: Don't do this

Link to comment
Share on other sites

  • 0

Re: Common Problems (And their solutions)

Yea alasadi, a lot of people have this problem. Multiple threads open now because of it. We need to wait for a fix or try this : http://forums.technicpack.net/index.php/topic,2563.0.html He says it works..

Same goes for ShadowOmar, niavmai meant well and said clear cache but in fact...that brings you to the new update problem:)

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

Announcements




×
×
  • Create New...