Raghar

Can't setup plugins for Tekkit Lite Server

Recommended Posts

Hello there,

firstly, before you burn me like a witch I will say this:

I've been trying to install it for last 3 hours, I've tried the method listed here. I've tried sponge/mcpc/bukkitforge. I've tried whole loads of things I do not understand. I've read pinned topics for it here and there, honestly I am just tired and about to give up.

So now that's our of the way.

Yesterday I've decided to setup server (for me and some friends, nothing big) of Tekkit Lite. Surprisingly I've managed that!
After a short while we realised that we need some commands available to everyone, but we do not want everyone to be op. That would be too dangerous.
Basically we figured that we want everyone to have teleport commands plus maybe like /home /spawn, some real real basics.
In my search for granting ability of using commands I have found that what I need are plugins (am I wrong here? Is there simpler way)

And so now I am completely stuck trying to install those plugins. I propably just need someone to point out my mistake, or just send me correct way.

So, this is what I have been doing to install plugins:

1. Extract tekkit lite server zip
2. Run server for the first time.
3. Stop server after it is completely done loading and creating.
4. Copy and paste bukkitforge1.4.7.jar to coremods folder.
5. Create plugins folger
6. Try running server>
7. This shit appears =[  <Here is a pastebin of serverlog of when I tried to run with bukkitforge>

And basically I've tried that with many other forms of forge like mcpc or sponge.
I also tried the other way around (extract server, add bukkitforge, then run for the first time - didn't work either, had similar texts in log appear)


Thx in advance for help, I would really love to play some tekkit lite with my friendos =]

Cheers, Raghar

P.S.: Sorry for my English, I am not a native speaker
P.S.2: I would gladly accept files of working server with plugins (in case helping me install those won't work)

Share this post


Link to post
Share on other sites

Here's my steps to getting a Tekkit Lite server with plugins.

Download a fresh copy of the server from the modpack page: http://www.technicpack.net/modpack/tekkitlite
Download mcpc-plus-1.4.7-R1.1-SNAPSHOT-f534-authfix1.jar from tcpr.ca: https://tcpr.ca/downloads/mcpc

Put the file in the same folder as the server download, edit the launch.bat file to use the mcpc-plus jar.

Should it say you need to run it with Java 7 you can get that from here assuming you have 64-bit windows: http://cdn.lemonmc.com/jre-7u80-windows-x64.exe

 

If you get an error similar to

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32

edit the launch.bat file again and add --nojline after the mcpc-plus jar filename.

Share this post


Link to post
Share on other sites

Thx for answer!

Sadly the problems ain't over.

I followed your steps and these are the results:


I did get the error:

1 hour ago, zaza7 said:

If you get an error similar to

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32

edit the launch.bat file again and add --nojline after the mcpc-plus jar filename.

and after I using the fix this is what I end up with this:  As far as I, a total noob, understand the mcpc caused a problem with loading buildcraft?

Thanks for helping me!

Cheers,
Raghar

 

EDIT1: Do you want me to run launch.bat and mcpc.jar with server files in zip form? Or with unpacked form, cause I have been running it with the unpacked files.

EDIT2: Maybe it will help, I've zipped and uploaded for screening the server files that show the problem with builcraft. Zipped broken server

 

Edited by Raghar
Didn't want to make 2 replies in a row

Share this post


Link to post
Share on other sites

Ok, nvm.

Your way does make the server work with the plugins. Thx a lot <3
You just gotta ignore the fact that GUI doesn't pop out and that buildcraft fails to check version.

Cheers,
Raghar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Fred__Ex
      I'm new to Technic, and I'm trying to join a server with a modpack that runs on 1.12.2, but when I open the modpack through the Technic launcher it says that I need Forge to open some of the mods.
      I downloaded Forge for 1.12.2, but you have to open it through the Minecraft launcher. Which means I can't use the modpack through Forge or Technic.
      I've tried looking through launcher settings to see if I could tell Technic to open the modpack with the Forge version that I downloaded. Doesn't work. Other people seem to get on the server fine. Is this a problem with me, or the modpack?
      Edit: I've attached a photo showing the messages I get when I try to use both launchers. The photo was too large to attach, so I decided to use the URL, but it's on TinyPic, so if you don't see it, it's probably because they're shutting down.
      http://tinypic.com/r/2vdp9br/9
    • By Nyrab
      When i put the mods in the server don't crash because of that, when i try to open I don't even receive a crash log, then i go to the last try log and it says that my port is already in use
      I used the default server port
    • By Nyrab
      I recently created a modpack, but i can't connect to my friends via Hamachi, so i tried to make a server but it gaves an error that i don't understand
      But in this topic i prefer start of the beggining, i need help to make a server or just a way that i can play with my friends via Hamachi
       
      PS:I want a free way to make it, i tried Aternos but i didn't find some mods that was in my modpack
    • By Majere
      I am trying to set up a cauldron Tekkit Server so I can install plugins to the server however I keep running into this error.
      I am using cauldron-1.6.4-1.965.21.204-installer.jar and cauldron-1.6.4-1/965.21.204.jar
      Server>java -Xmx3G -Xms2G -jar Custom.jar nogui Mar 25, 2019 10:54:31 PM net.minecraft.launchwrapper.LogWrapper log INFO: Loading tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker Mar 25, 2019 10:54:31 PM net.minecraft.launchwrapper.LogWrapper log INFO: Using primary tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker Mar 25, 2019 10:54:31 PM net.minecraft.launchwrapper.LogWrapper log INFO: Calling tweak class cpw.mods.fml.common.launcher.FMLServerTweaker 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Forge Mod Loader version 6.4.49.965 for Minecraft 1.6.4 loading 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_172, running on Windows 10:amd64:10.0, installed at C:\Program Files\Java\jre1.8.0_172 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod appeng.transformer.AppEngCore does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [AppEng] Core Init 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod calclavia.lib.CalclaviaPluginLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft Warning: version of ForgeMultipart-universal-1.6.4-, 1.0.0.250 is newer than request 1.0.0.244 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod cofh.asm.LoadingPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod mods.immibis.microblocks.coremod.MicroblocksCoreMod does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod invtweaks.forge.asm.FMLPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Loading tweaker net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer from legacyjavafixer-1.0.jar 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod logisticspipes.asm.LogisticsPipesCoreLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod micdoodle8.mods.miccore.MicdoodlePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod codechicken.nei.asm.NEICorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod openmods.OpenModsCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod mrtjp.projectred.compatibility.CompatibilityCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod universalelectricity.core.UELoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [WARNING] [ForgeModLoader] The coremod codechicken.core.launch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Loading tweak class name net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: [email protected]3b1 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Replacing tweaker [email protected]3b1 with net.min[email protected]69ea3742 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: FMLCorePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: FMLForgePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: DepLoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: AppEngCore {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: CalclaviaPluginLoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: CodeChickenCorePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: LoadingPlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: MicroblocksCoreMod {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: FMLPlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: LogisticsPipesCoreLoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: MicdoodlePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: NEICorePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: OpenModsCorePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: CoreLoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: DepLoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: CompatibilityCorePlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: QCFMLLoadingPlugin {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: UELoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: DepLoader {[]} 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Tweaker: [email protected]3b1 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Replacing tweaker [email protected]3b1 with net.min[email protected]69ea3742 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Calling tweak class net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer$SortReplacement 2019-03-25 22:54:31 [INFO] [ForgeModLoader] [LegacyJavaFixer] Replacing sort 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Calling tweak class net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer$SortReplacement 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Calling tweak class net.minecraftforge.lex.legacyjavafixer.LegacyJavaFixer 2019-03-25 22:54:31 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper Loaded 40 rules from AccessTransformer config file fml_at.cfg 2019-03-25 22:54:33 [WARNING] [ForgeModLoader] Patcher expecting empty class data file for net.minecraft.client.gui.inventory.GuiContainer, but received non-empty 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper Loaded 110 rules from AccessTransformer config file forge_at.cfg 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper Loaded 40 rules from AccessTransformer config file fml_at.cfg Adding AccessTransformer: chickenchunks_at.cfg Adding Accesstransformer map: temp.dat Loaded 44 rules from AccessTransformer config file temp.dat Adding AccessTransformer: nei_at.cfg Adding Accesstransformer map: temp.dat Loaded 55 rules from AccessTransformer config file temp.dat Adding AccessTransformer: wrcbe_at.cfg Adding Accesstransformer map: temp.dat Loaded 57 rules from AccessTransformer config file temp.dat 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper Loaded 17 rules from AccessTransformer config file lp_at_1.6.4.cfg 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper Successfully Registered Transformer [Micdoodle8Core]: Patching game... [Micdoodle8Core]: Patching game... 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper Loaded 40 rules from AccessTransformer config file fml_at.cfg Adding Accesstransformer map: pcc_at.cfg Loaded 57 rules from AccessTransformer config file pcc_at.cfg 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper 2019-03-25 22:54:33 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:43) at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12) Caused by: java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/v1_6_R3/util/ServerShutdownThread at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Unknown Source) at java.lang.Class.privateGetMethodRecursive(Unknown Source) at java.lang.Class.getMethod0(Unknown Source) at java.lang.Class.getMethod(Unknown Source) at net.minecraft.launchwrapper.Launch.launch(Launch.java:128) at net.minecraft.launchwrapper.Launch.main(Launch.java:27) ... 6 more Caused by: java.lang.ClassNotFoundException: org.bukkit.craftbukkit.v1_6_R3.util.ServerShutdownThread at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:186) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) ... 13 more Caused by: java.lang.NullPointerException at org.objectweb.asm.ClassReader.<init>(Unknown Source) at universalelectricity.core.asm.ASMHelper.createClassNode(ASMHelper.java:118) at universalelectricity.core.asm.ASMHelper.createClassNode(ASMHelper.java:112) at calclavia.lib.config.ConfigTransformer.transform(ConfigTransformer.java:27) at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:274) at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:172) ... 15 more  
    • By tirodokter
      I have downloaded cofhcore-1.12.2-4.6.2.25-universal.jar and codechickenlib-1.12.2-3.2.2.353-universal.jar and it seems i don''t have the correct version of forge installed. i then download it and put it in the mods folder but i still get the same error is there a specific map i need to place it in? or is it just the mod does not work anymore. i am playing in 1.12.2. and it says i need forge 14.23.4.2718 or above. i have put the latest log as a download
      Thx in advance  
      2019-03-20-7.log.gz