Raghar

Can't setup plugins for Tekkit Lite Server

Recommended Posts

Hello there,

firstly, before you burn me like a witch I will say this:

I've been trying to install it for last 3 hours, I've tried the method listed here. I've tried sponge/mcpc/bukkitforge. I've tried whole loads of things I do not understand. I've read pinned topics for it here and there, honestly I am just tired and about to give up.

So now that's our of the way.

Yesterday I've decided to setup server (for me and some friends, nothing big) of Tekkit Lite. Surprisingly I've managed that!
After a short while we realised that we need some commands available to everyone, but we do not want everyone to be op. That would be too dangerous.
Basically we figured that we want everyone to have teleport commands plus maybe like /home /spawn, some real real basics.
In my search for granting ability of using commands I have found that what I need are plugins (am I wrong here? Is there simpler way)

And so now I am completely stuck trying to install those plugins. I propably just need someone to point out my mistake, or just send me correct way.

So, this is what I have been doing to install plugins:

1. Extract tekkit lite server zip
2. Run server for the first time.
3. Stop server after it is completely done loading and creating.
4. Copy and paste bukkitforge1.4.7.jar to coremods folder.
5. Create plugins folger
6. Try running server>
7. This shit appears =[  <Here is a pastebin of serverlog of when I tried to run with bukkitforge>

And basically I've tried that with many other forms of forge like mcpc or sponge.
I also tried the other way around (extract server, add bukkitforge, then run for the first time - didn't work either, had similar texts in log appear)


Thx in advance for help, I would really love to play some tekkit lite with my friendos =]

Cheers, Raghar

P.S.: Sorry for my English, I am not a native speaker
P.S.2: I would gladly accept files of working server with plugins (in case helping me install those won't work)

Share this post


Link to post
Share on other sites

Here's my steps to getting a Tekkit Lite server with plugins.

Download a fresh copy of the server from the modpack page: http://www.technicpack.net/modpack/tekkitlite
Download mcpc-plus-1.4.7-R1.1-SNAPSHOT-f534-authfix1.jar from tcpr.ca: https://tcpr.ca/downloads/mcpc

Put the file in the same folder as the server download, edit the launch.bat file to use the mcpc-plus jar.

Should it say you need to run it with Java 7 you can get that from here assuming you have 64-bit windows: http://cdn.lemonmc.com/jre-7u80-windows-x64.exe

 

If you get an error similar to

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32

edit the launch.bat file again and add --nojline after the mcpc-plus jar filename.

Share this post


Link to post
Share on other sites

Thx for answer!

Sadly the problems ain't over.

I followed your steps and these are the results:


I did get the error:

1 hour ago, zaza7 said:

If you get an error similar to

Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.fusesource.jansi.internal.Kernel32

edit the launch.bat file again and add --nojline after the mcpc-plus jar filename.

and after I using the fix this is what I end up with this:  As far as I, a total noob, understand the mcpc caused a problem with loading buildcraft?

Thanks for helping me!

Cheers,
Raghar

 

EDIT1: Do you want me to run launch.bat and mcpc.jar with server files in zip form? Or with unpacked form, cause I have been running it with the unpacked files.

EDIT2: Maybe it will help, I've zipped and uploaded for screening the server files that show the problem with builcraft. Zipped broken server

 

Edited by Raghar
Didn't want to make 2 replies in a row

Share this post


Link to post
Share on other sites

Ok, nvm.

Your way does make the server work with the plugins. Thx a lot <3
You just gotta ignore the fact that GUI doesn't pop out and that buildcraft fails to check version.

Cheers,
Raghar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By xS1las
      Hello, me and my friend really want a private server with mods. Can you please help us?
       
      - xS1las
    • By xS1las
      Hello there..
      Me and my friends really want a private server, where we can do what we want, because the servers we have seen now doesn't have the mods that we want. 
       
      But my question is:
      How do i make one
      does it cost money
      and how do i edit that server
       
      Thank you i you want to reply.
       
      - xS1las
    • By Gamen4Bros
      The launcher Console said this: 
       
      [B#456] SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
      [B#456] SLF4J: Defaulting to no-operation (NOP) logger implementation
      [B#456] SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
      [B#456] Starting download of https://www.dropbox.com/s/ic0nnif50zxe7f1/MangoCraft.zip?dl=1, with 3 tries remaining
      [B#456] File version.json not found in C:\Users\djtri\AppData\Roaming\.technic\modpacks\mangocraftpack\bin\modpack.jar
       
      Link to modpack: https://www.dropbox.com/s/ic0nnif50zxe7f1/MangoCraft.zip?dl=1
      modpack name: mangocraftpack
    • By Fred__Ex
      I'm new to Technic, and I'm trying to join a server with a modpack that runs on 1.12.2, but when I open the modpack through the Technic launcher it says that I need Forge to open some of the mods.
      I downloaded Forge for 1.12.2, but you have to open it through the Minecraft launcher. Which means I can't use the modpack through Forge or Technic.
      I've tried looking through launcher settings to see if I could tell Technic to open the modpack with the Forge version that I downloaded. Doesn't work. Other people seem to get on the server fine. Is this a problem with me, or the modpack?
      Edit: I've attached a photo showing the messages I get when I try to use both launchers. The photo was too large to attach, so I decided to use the URL, but it's on TinyPic, so if you don't see it, it's probably because they're shutting down.
      http://tinypic.com/r/2vdp9br/9
    • By Nyrab
      When i put the mods in the server don't crash because of that, when i try to open I don't even receive a crash log, then i go to the last try log and it says that my port is already in use
      I used the default server port