Jump to content

Server lags and crashes after a few minuets.


ShrillBear
 Share

Recommended Posts

So as the title says, i had a lot of problem with this server over the past weeks. There were many problems

First of all, lags. Lots of them. I thought it might be because of Recurrent Komplex (because a lot of times the log said that the mod causes cascading worldgen lag).

So i removed it. Than i also removed mystcraft because some times it also had the same messages in the log.

 

But the server still lags and crashes.

I often get kicked with the message fatal error, the connection was terminated or something like that.

It also takes way long the modpack to load. (1.12.2, custom modpack with around  115 mods)

 

My specs:

i5-4440

750-TI

16 Gb DDR3 (6 Gb for server, and 6 for the launcher, ridiculous.)

 

 

 

https://pastebin.com/5kA748PK

 

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Firstly, I have the same "errors" on my server.  They do not actually cause lag, at least not on my server.  So just don't worry about that as much.

Some things that I would try:  use your same setup with forge and no mods and see if you get lag.  That's big because if you are getting lag, it is not the mods.  If it works, go through and add mods 1by1.

Other questions...  How many players do you have?  How are you connecting to your server from your client?  Do you have a bunch of background processes?  Running both is tough for a computer.  When you have em both running look at your system processes in task manager and see if you are destroying your computer... CPU usage, ram, disk..etc.

Edited by m1dude
Link to comment
Share on other sites

16 hours ago, m1dude said:

Firstly, I have the same "errors" on my server.  They do not actually cause lag, at least not on my server.  So just don't worry about that as much.

Some things that I would try:  use your same setup with forge and no mods and see if you get lag.  That's big because if you are getting lag, it is not the mods.  If it works, go through and add mods 1by1.

Other questions...  How many players do you have?  How are you connecting to your server from your client?  Do you have a bunch of background processes?  Running both is tough for a computer.  When you have em both running look at your system processes in task manager and see if you are destroying your computer... CPU usage, ram, disk..etc.

well it turned out to be issue with the mods. I had a bad version of hwyla and forgot to remove quark from my mods folder of the launcher. 

That resolved a lot of issue. 

 

Thanks.

The server has 3 players (including me) so everything works just fine.

 

My friend recently came across an issue with entering portals. He always gets stuck. What i mean by this is that, when he enters the portal and arrives to the nether he always teleport back to the overworld and than back to the nether (or aether, it happened with both portal so far). So the is in a constant loop of teleporting  and can't get out. He can move but even if he does, he still get teleported back to the place he came from.

 

How am supposed to solve this?

Link to comment
Share on other sites

Is it only a problem with him?  Have you tried it?  Im assuming you are OP and he is not....  That might mean that there is a permission somewhere letting him travel to different worlds.  If you don't have a plugin for permissions, making him op will solve the problem if you are able to go through.

Link to comment
Share on other sites

On 4/9/2020 at 5:47 PM, m1dude said:

Is it only a problem with him?  Have you tried it?  Im assuming you are OP and he is not....  That might mean that there is a permission somewhere letting him travel to different worlds.  If you don't have a plugin for permissions, making him op will solve the problem if you are able to go through.

I host the server, but none of us has op. We also don't use any plugins. He is the only one who has this issue while going trough portals. (my other friend hasn't been on the server for a while).

Edited by ShrillBear
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...