Jump to content

Constant roadblocks while making a modpack

Recommended Posts

I've been working on a mod pack for a couple days now and every time it came to test it through Technic it has failed. After countless times of showing up as a generic 1.12.2 vanilla game, I finally managed to get it to read as modded (lack of .jar suffix and wrong forge version) and after getting all the duplicate mods out and getting the rest of them compatible, it finally starts to load longer than any time I've tried. But of course the pack crashes at the 2/7 loading mark. Spending a good deal of hours trying to get this to work just for it to stop abruptly as usual when I think it's going to work is kind of a let down. So I figured it was time to get some outside help. Sorry for the long read, first time posting in a forum. But I came here to ask some of you guys if you got any helpful advice that'll help me out of this standstill.

Here's the Dropbox link: https://www.dropbox.com/s/hm1higc4zwo4n1g/cosmicconquest14.jar?dl=1

and here's the pack link: http://api.technicpack.net/modpack/the-space-bound-conquest-pack

Any help whatsoever will be greatly appreciated. Thank you.

Share this post

Link to post
Share on other sites

Why is your modpack a .jar and not a zip? Why is it close to 1 GB in size? Oh, you seem to have a lot of duplicate Train content packs in your modpack. That seems to be the bulk of the size bloat. It would probably also cause it to abort at 2/7 due to "duplicate mod found" errors.

Share this post

Link to post
Share on other sites
Posted (edited)

For the .jar part, a lot of the tutorials were a bit confusing and I just thought that's what i was supposed to use (seeing it worked after making a few tweaks as well as the .jar suffix swap. So I'm guessing the pack being a .jar had no relation to the function.) I'll swap it back over to .zip and root around and delete the duplicates and try it again. (Edit>) I changed it over to .zip and looked around for the duplicate train stuff but I only found the one folder (IRLegacy) and most of the stuff in it didn't seem like duplicates. also I tried booting it up again and it was crashing as soon as it was reaching 3/7 (This might have also been the case for the version I Initially posted for, instead of at the 2/7 mark.)   

Edited by TheFancyShotgun

Share this post

Link to post
Share on other sites
Posted (edited)

There's an Immersive vehicles folder in your mods folder. It contains all kinds of large content packs that are also included in the mods folder itself.

[B#510]  java.lang.RuntimeException: Invalid id 4096 - maximum id range exceeded.
[B#510]      at net.minecraftforge.registries.ForgeRegistry.add(ForgeRegistry.java:295)
[B#510]      at net.minecraftforge.registries.ForgeRegistry.add(ForgeRegistry.java:281)
[B#510]      at net.minecraftforge.registries.ForgeRegistry.register(ForgeRegistry.java:113)
[B#510]      at net.minecraftforge.registries.ForgeRegistry.registerAll(ForgeRegistry.java:154)
[B#510]      at net.mcreator.wrd.wrd.registerBlocks(wrd.java:87)
[B#510]      at net.minecraftforge.fml.common.eventhandler.ASMEventHandler_2187_wrd_registerBlocks_Register.invoke(.dynamic)
[B#510]      at net.minecraftforge.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:90)
[B#510]      at net.minecraftforge.fml.common.eventhandler.EventBus$1.invoke(EventBus.java:144)
[B#510]      at net.minecraftforge.fml.common.eventhandler.EventBus.post(EventBus.java:182)
[B#510]      at net.minecraftforge.registries.GameData.fireRegistryEvents(GameData.java:845)
[B#510]      at net.minecraftforge.fml.common.Loader.preinitializeMods(Loader.java:630)
[B#510]      at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:252)
[B#510]      at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467)
[B#510]      at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
[B#510]      at net.minecraft.client.main.Main.main(SourceFile:123)
[B#510]      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[B#510]      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
[B#510]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
[B#510]      at java.lang.reflect.Method.invoke(Unknown Source)
[B#510]      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
[B#510]      at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

Add this mod: https://www.curseforge.com/minecraft/mc-mods/notenoughids/files

Edited by JaariAtmc

Share this post

Link to post
Share on other sites
11 hours ago, TheFancyShotgun said:

I completely removed (to my knowledge) all of the stuff for Immersive vehicles and it's still not wanting to work properly. Should I try getting rid of the railroading too?

Did you even read the second part of my comment?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By terminatorztc
      So I'm not really sure what even happened all I know is that I tired to run Tekxit 3 LE Official. When it didn't run a tested multiple other packs including Attack of the B-Team, Blightfall, Tekkit, ect. None have been able to even open. The launcher flickers then almost resets like it never was launching in the first place. I tried reinstalling the pack and launcher, even a complete check on my PC. Specs have nothing to do with it I have 12gb of RAM also nothing should be conflicting with the program. I'm honestly at a loss for words as this is nothing like I've ever seen. I've tried just about everything reinstalling Java was something I tested but to no avail. I tried researching my problems hoping someone had the same issues but I only find outdated sources and after updates I dont trust their solutions. It may also be well to inform everyone that the modpack did initially work but i tired downloading another modpack which was RLCraft but that didnt open and now im here(I now only have Tekxit installed and still wont run).
      Edit: Almost forgot crashes when "installing minecraft assets"
    • By Verhunqert
      hi see i recently made a modpack and everytime i start is is says installing assets, does that, then just doesnt start, no minecraft nothing, please help, i already made the 0 of the dropbox into a 1 and stuff like that
      dropbox: https://www.dropbox.com/s/oulmzhezhfw976b/Minecolonies.zip?dl=0
      modpack: https://www.technicpack.net/modpack/modpack12-341.1703589
    • By IcarusUK
      Hey, so I've made a modpack for my gaming group and have followed all the steps closely that were provided on the guide. However, whenever I open the modpack on Technic it does not load forge, only vanilla minecraft. The forge version is: and works perfectly fine in the normal minecraft launcher (yes I used the universal version for the modpack and renamed it correctly). Furthermore all of the mods work and I'm able to connect to the server I host which also has the same version of forge which works there (and of course all of the mods). When I check the .technic folder and go to the pack folder everything appears to have installed correctly however forge does not load even though it's in the bin folder with minecraft.jar (this is automatically put there by technic). The modpack link is below, please can someone help me to get this to work...
      The bin folder:

      This is the full contents of the modpack

      This is the config folder (it has 1 required customised file under CustomMainMenu - this works in the standard minecraft launcher):

      If you can help me with this I would really appreciate it.
      (edit) here's the direct download of the pack... https://www.dropbox.com/s/kkfbn4gfahx8ul3/rg1.zip?dl=0
    • By AlexKoyomi
      When I click in install, it does something for a second and then just appear the options to "Delete modpack" and "install".
    • By PyroSweets
      My friends and I made a custom modpack with all our favorite mods in 1.12.2. I was having some issues with the modpack.jar that made it run vanilla and I fixed it, but now the modpack doesn't even show a java client or loading screen before crashing. I posted a day or two ago on reddit and was told to delete some iffy modpacks, but that only makes it run vanilla again. Any ideas why this is happening?
      Crash Log: http://dl.dropboxusercontent.com/s/wkv06mn3wna9hbv/techniclauncher_2020-05-31.log
      Modpack: http://dl.dropboxusercontent.com/s/ndyuw1g8t38xkde/POGWORK.zip
      Technic Page: https://www.technicpack.net/modpack/dillons-cult-pack.1697994
  • Create New...