Jump to content

Let's Test Tekkit 1.1.2!


CanVox
 Share

Recommended Posts

Hey, everyone,

I've just promoted Tekkit 1.1.2 to Latest. There are a ton of key mod updates, the update to Minecraft 1.5.2, along with several new mods! We've got Project Bench, a direct drop-in replacement for the RP2 project bench, a couple new generators, Logistics Pipes, and Simple Power Storage, by Technic's sct! SPS adds a "Makeshift Energy Cell" which can be used as an early-game alternative to the Redstone Energy Cell!

If you're interested in helping test, back up your worlds (SSP or server) and set your launcher up to use the "Latest" build, or manually select version 1.1.2. Play with us and report issues in this thread!

This is a clean slate, so even if you've already reported an issue elsewhere (including the 1.1.1 thread), if it's present in 1.1.2, be sure to report it in this thread. There's one exception to this rule: I know that the basic components issues (mainly centered around Hazmat suits being uncraftable and copper wires being missing) are still present, and I'm working on those.

The 1.1.2 server can be downloaded here: http://mirror.technicpack.net/Technic/servers/tekkitmain/Tekkit_Server_v1.1.2.zip

Changelog for Tekkit 1.1.2- this is a list of all changes since 1.0.6:

- Update Forge to build 734.

- Corrected a rare crash bug in the Forge transparency fix

- Some redundant APIs were removed from the jars of the following mods, in order to reduce PermGen size: MFFS, MineFactory Reloaded, Atomic Science, and Modular Powersuits.

- Added Project Bench version 1.7.5

- Added Atomic Science version 0.5.3.51

- Added MFFS version 3.0.2.124

- Added Open Peripheral version 0.1.5

- Added Buildcraft: Logistic Pipes version 0.7.3.6

- Added Simple Power Storage version 1.0.10

- Equivalent Exchange 3 version pre1h has had a crash bug removed

- Balkon's Weapon Mod updated to version 1.12

- bspkrsCore updated to version 2.07

- Buildcraft updated to version 3.5.3

- Chicken Chunks updated to version 1.3.2.12

- Code Chicken Core updated to version 0.8.7

- Computer Craft updated to version 1.53

- CoFH Core updated to version 1.5.2.2

- Custom LAN Ports updated to version 1.5.2

- Dimensional Anchors updated to version 55.0.1

- Equivalent Exchange 3 updated to version pre1h

- Ender Storage updated to version 1.4.2.12

- Immibis Core updated to version 55.1.2

- Iron Chests updated to version 5.2.6.412

- MineFactory Reloaded updated to version 2.6.2.924

- Mystcraft updated to version 0.10.4.00

- Not Enough Items updated to version 1.5.2.28

- Nether Ores updated to version 2.1.5.75

- Omni Tools updated to version 3.1.4.0

- OpenCCSensors updated to version 1.5.2.0

- PowerCrystals Core updated to version 1.1.6.107

- Rei's Minimap updated to version 3.3_06

- Thermal Expansion updated to version 2.4.3.0

- Applied Energistics updated to version 10.n

- Steve's Carts updated to version 2.0.0.a117

- Dimensional Doors updated to version 1.3.6.73

- Modular Powersuits updated to version 0.7.0.534

- MPS Addons updated to version 0.2.3.144

- Immibis Microblocks updated to version 55.0.1

- Backpacks updated to version 1.9.11

- Treecapitator updated to version 1.5.2.r01

- Trade Booth updated to version 0.4

- Buildcraft: Additional Pipes updated to version 2.3.0

- Galacticraft updated to version a0.1.35.309

- NEI Plugins updated to version 1.0.9.3

Link to comment
Share on other sites

  • Replies 52
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Hello,

If you've played in the past with tekkit set to 1 Gb, with the permgen checkbox unchecked, could you do me a favor? Could you return to those settings for this test? I believe my changes have reduced the permgen size sufficiently that you should be able to play with those settings, and I'd like to make sure Tekkit remains accessible for those with terrible computers.

Link to comment
Share on other sites

Ill stick with 1.1.1 until the latest doesn't crash my server

Saying that is kinda pointless unless you give crash logs. How do you expect them to get it fixed without telling them what's wrong?

Link to comment
Share on other sites

Ill stick with 1.1.1 until the latest doesn't crash my server

Okay, well, that's a good reminder to remove the server and launcher build for old test builds in the future. If you're not interested in testing, you should stick with the recommended build.

EDIT: Your problem appears to be that you didn't update your server correctly. Code Chicken Core requires a new build of Minecraft Forge, which is provided by the Tekkit.jar in the 1.1.2 server.

Link to comment
Share on other sites

Again, we need logs. It's hard to fix problems when you don't know what they are or what causes them.

Ah, the problem is when the game crashes, it doesn't display the logs; it just gets stuck at "shutting down internal server". Is there some .txt file of the logs I can access in the tekkit folder?

Link to comment
Share on other sites

Okay, well, that's a good reminder to remove the server and launcher build for old test builds in the future. If you're not interested in testing, you should stick with the recommended build.

EDIT: Your problem appears to be that you didn't update your server correctly. Code Chicken Core requires a new build of Minecraft Forge, which is provided by the Tekkit.jar in the 1.1.2 server.

ahhhh makes sense

Link to comment
Share on other sites

1.1.2 is very slow, even when I tone the graphics down to "View Distance: Tiny", Then I get "shutting down internal server" then a white screen, I tried rebooting tekkit, but the same thing happened...

Link to comment
Share on other sites

What's the latest recommended build, 1.0.6 still? I'm waiting for a recommended build to come out so my game will stop crashing constantly to known bugs that are fixed in updates 1.0.6 doesn't have. I can't report these bugs as they are already fixed "ages ago" according to the makers of those mods.

Does 1.1.2 seem stable enough to run a server on or is it less stable than 1.0.6? Does it include the correct version of minecraft_server.jar? One of your previous versions did not.

Link to comment
Share on other sites

Chances are that it did have the correct version of minecraft, but you messed up when updating the server. People would notice if a problem as obvious as that was there.

Link to comment
Share on other sites

Chances are that it did have the correct version of minecraft, but you messed up when updating the server. People would notice if a problem as obvious as that was there.

invalid.

I created the server entirely using no files whatsoever on the new version and it still errored out with incorrect minecraft_server.jar.

Link to comment
Share on other sites

Chances are that it did have the correct version of minecraft, but you messed up when updating the server. People would notice if a problem as obvious as that was there.

It did have the wrong version in 1.1.0. Downloading it from minecraft.net fixed it. I used a clean install of Tekkit and didn't update anything. Also other people in the forum had same problem of course.

1.1.2 seems to work perfectly. Even with latest build of MCPC+.

Link to comment
Share on other sites

1.1.2 is very slow, even when I tone the graphics down to "View Distance: Tiny", Then I get "shutting down internal server" then a white screen, I tried rebooting tekkit, but the same thing happened...

Incrase allocation, increase permgen size, lemme know if it's still a problem.

It did have the wrong version in 1.1.0. Downloading it from minecraft.net fixed it. I used a clean install of Tekkit and didn't update anything. Also other people in the forum had same problem of course.

1.1.2 seems to work perfectly. Even with latest build of MCPC+.

1.1.0 was never marked latest or recommended, so if you were ever playing it, you were making a mistake. It was not SUPPOSED to work.

Link to comment
Share on other sites

Incrase allocation, increase permgen size, lemme know if it's still a problem.

1.1.0 was never marked latest or recommended, so if you were ever playing it, you were making a mistake. It was not SUPPOSED to work.

I know but I played it anyway. It worked very good for me. :) Better than 1.0.6 in fact.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

Announcements

  • Anything claiming to be official Technic servers are not allowed here, for obvious reasons



×
×
  • Create New...