Jump to content

Having trouble starting Tekkit


Recommended Posts

So i tried to load up Tekkit yesterday after a friend invited me to a server he was running. I selected Tekkit and hit play. The files loaded for about five or six minutes then the launcher disappeared then popped up again as if nothing had happened. I tried re-installing technic pack, i tried uninstalling my virus protection and i allowed technic pack to work with my firewall and it's still not working can anyone help me please? 

Link to comment
Share on other sites

Those few minutes were likely spent downloading the modpack. If the game then closes immediately after launching, this may be another case of wrong Java version. Java 7 is still recommended to run Tekkit (currently update 67), and there is a known issue that will prevent the game from starting on Java 8 (update 20 and newer).


If that's not it, please take the issue to the tracker, and try to gather >crash logs.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...