Jump to content

Pack works fine on PC, crashes on Mac with ModsNotFound error.


Recommended Posts

...despite the mod it claims it cannot find being present in the mods folder.

 

My pack is located here: http://www.technicpack.net/modpack/blightfall.592618/about

 

This pack has been verified as working multiple times on three different computers. The only time it crashes is when it is used on a mac. It gives the following mysterious error: 

 

http://i.imgur.com/RsOt7WT.png 

 

Please note the presence of CoFH Core in the mods directory.

 

After that, latest.log contains the following:

 

http://pastebin.com/TuUqn8GJ

 

It seems to be a problem afflicting other modpacks, specifically on macs. Google searches reveal two other places where the same issue is reported, both here: http://bitly.com/1DyFcDX and here: http://forums.tekkify.com/threads/1-7-10-mac-issues.4895/

 

I notice in the above log that there are lots of complaints about being unable to open zipfiles, and notably it complains about all the CoFH mods, including thermal foundation, nether ores, and Minefactory Reloaded. What do you make of that? Perhaps macs handle zipping and unzipping files differently, and the CoFH team uses a compression algorithm not recognized by the mac implementation of the JVM?

Edited by Talonos
Link to post
Share on other sites
  • Discord Moderator
[12:08:09] [main/INFO]: [codechicken.core.launch.DepLoader$DepLoadInst:scanDepInfo:510]: Failed to load dependencies.info from CoFHCore-[1.7.10]3.0.0B9-40 (1).jar as JSON
[12:08:09] [main/INFO]: [java.lang.Throwable:printStackTrace:461]: java.util.zip.ZipException: error in opening zip file
  • The mod should not have " (1)" in the file name. I've seen this cause issues before. Remove that. As far as the ZIP libraries differeing, hard to say. Might have to ask one of the admins in the IRC channel.
  • The CoFHLib file is only for use by mod developers and should never be used in a modpack.
  • Your ThaumCraft is out of date (specifically does not match your version of Thaumic Tinkerer).
  • Your Waila version is out of date with known crashes/bugs.
Link to post
Share on other sites
  • Discord Moderator

Heh, I don't know if I'd say encyclopedic, but the changelog in the Jenkins server for TT does indicate when significant version changes happen ( http://jenkins.nekokittygames.com:8080/job/Thaumic%20Tinkerer/ ). I don't really have a program I use, but I do have a process which I recently published in the hopes that others might gain something from it: '?do=embed' frameborder='0' data-embedContent>>

Link to post
Share on other sites

Okay, I got it to work. If anybody else has this problem, please direct them to here.

 

Take all CoFH mods, including Minefactory reloaded, nether ores, etc, and do the following:

 

1: Rename it from a .jar file to a .zip file.

2: Right click it and say "Extract here".

3: Select all the files that were extracted, right click one of them, and select "Send to compressed (zipped) folder"

4: Rename this new zipped file to be the same as your old jar file, including the .jar extension.

 

Why this works:

 

As you probably already know, a jar file is just a renamed zip file. The issue is, not all zip files are the same. There are many different ways to compress folders, and "zip" files might be different internally even though they share the same extension. Windows knows how to handle some types of zip files that Mac doesn't, apparently. Also apparently, the zip file format the CoFH uses for its mods is recognized by Windows, but not by Mac. By unzipping the jar files and rezipping them, you create a new zip file that uses a more "standardized" zip archive format that macs are capable of handling. The contents of the zip files are the same, there's just a difference in how they are compressed. Distribute those rezipped mods, and you will not have any problems with mac compatibility.

 

At least, that's been my experience. Could somebody else who has run into this issue verify it?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By bigherdguy
      I’m installing the launcher for the first time and I open it with the .jar opener application and it downloads like normal but stays on the logo afterward and the launcher does not appear. What am I doing wrong? What should I do?
    • By stringybean
      I have recently updated to macOs Catalina, and i wanted to reinstall technic launcher to play with my friends. I already have java installed, but when i open the .jar file, it pops up on my dock and disappears twice. When i check the logs there is usually one log for each time i open it, along with nothing in the surrounding folders. I have tried to 'reinstall' technic multiple times.
      techniclauncher_2020-02-06.log
    • By s3h
      Hi,
      I have just followed a tutorial on how to set up a modpack, and I followed all of the steps, but when I run it it just runs vanilla. Here is the link to the pack. Any ideas?
      Thanks!
    • By tirodokter
      I have downloaded cofhcore-1.12.2-4.6.2.25-universal.jar and codechickenlib-1.12.2-3.2.2.353-universal.jar and it seems i don''t have the correct version of forge installed. i then download it and put it in the mods folder but i still get the same error is there a specific map i need to place it in? or is it just the mod does not work anymore. i am playing in 1.12.2. and it says i need forge 14.23.4.2718 or above. i have put the latest log as a download
      Thx in advance  
      2019-03-20-7.log.gz
    • By cyndaquilofpower
      I installed the TechnicLauncher.jar file, and I have Java on my Mac, but whenever I go to install it, I believe what happens is it crashes. When I first open the installer it shows me the window to install, and then when I click install, it closes out. Every time I open the file after that, it opens, then closes, then opens again for a bit longer, and then closes. I can't really pinpoint what's wrong, can someone help me out?
×
×
  • Create New...