• 0
Ulincsys

Technic Launcher - zero functionality

Question

EDIT: I just did a fresh install of Ubuntu on one of my other laptops, with the most up-to-date version of Java 8, and the newest Technic Launcher available, and I got the same results, so maybe this isn't on my end?

 

I don't participate in many modpacks, and those I do use, I cherish. I recently fired up Technic launcher on my Ubuntu laptop because I had to update the main modpack I use. The modpack author told me that he had updated it, but I did not see the update in the launcher. I switched to my Windows computer, same thing. I tried deleting the .technic folder on both machines, but afterwards, full functionality was lost. there are no modpacks listed when I search (all api links are broken), no news posts show up under the news tab, and all the fonts are messed up. About the only thing I can do, is log in. As far as I know, everything was working fine last month.

Screenshot_2.thumb.png.602b6f881becd3d34

Things I have tried:

 1. Installing/uninstalling java versions (7_u45, 8_u25, 8_u45 64/32-bit)

 2. multiple OS'es (Ubuntu 15.04, Windows 7, Windows 10 all 64-bit)

 3. Different versions of Technic Launcher

 

 

It is on your end, here's the modpack you tried in my launcher.

Post the contents of the latest log from .technic/logs

use http://paste.ubuntu.com post the link.

 

Here's the latest log from another fresh technic installation I did on my Windows desktop (the error logs from my other two computers are identical).

http://paste.ubuntu.com/12903763/

I should probably also point out that all of my computers are connected to the internet, and all firewall exceptions for java are allowed.

Edited by Ulincsys

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I figured it out!

My ISP was blocking the technic launcher from connecting to the technic file servers. I fixed it by routing Technic launcher's internet activity through a proxy server! But that still begs the question, why was my ISP blocking this in the first place?

Edited by Ulincsys
found an answer

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By ErkSterk
      So basically, I am running into really strange rendering issues such as in the video i linked below
      https://www.youtube.com/watch?v=_0wqhXuOikM
      This is one of many cases I have had of this specific render error, I have had these appear randomly across the map both moving and static. Also many chests render invisible at some times and mobs can become a combination of different textures such as in the photo i attatched with the alchemy chest. The textures also sometimes change while playing, normally when i cross chunks.
      Also typing commands, softlocks the game inside the chatbar only way to make it close is by minimizing the game and maximizing it again or when your player get pushed or teleported..
      I also would like to point out that this issue does not appear in other modpacks than classic.
      Tried both openjdk 7 and openjdk 8, both got the same issues but with jdk7 the effects are not as bad.
      Someone got the fix for this or know where to start looking?
       
      OS Manjaro Linux, latest build with KDE.
       
       
       

    • By Superskillz69
      I've played tekkit for a couple thousand hours now and never once encountered the battle I'm going through now. I haven't played in about 6 months or so.
      Some things to note:
      - I have both java 32 bit and 64 bit  runtime environments and I have experimented with a variety of different versions (many recommended on this forum)
      -I have 16Gb of RAM, a dedicated GPU and my nVidia driver is up to date. I have also rolled back to previous versions and encountered the same issues.
      -With any 64 bit java installed on the PC, Technic Launcher will not launch.
      -When I uninstall 64 bit java, launcher starts (in 32 bit) but obviously ram cannot be changed etc... However whilst running, I can install 64 bit java and then change ram settings.
      -Packs will download in this case however will not launch even when RAM is set below 6GB. I get a little java pop-up window saying "Hello".
      -https://paste.ubuntu.com/p/5MGrYNsP44/
       
      Please please please provide any assistance as I'm not ready to give up just yet!
    • By sanik0010
      I installed the Final Stand modpack and its in my .technic folder but after it downloads there is no open button, it just says install. I tried doing that but nothing changed.
    • By MeowMere333
      I have been trying to play mod packs through the Technic launcher, but whenever I download and play a pack, it opens up Minecraft in the very bottom right of my screen. When the game loads into the title screen, when I fullscreen there is no buttons or words. Also, whenever I enter a world and I try to put it into fullscreen, the screen bugs out and starts going crazy. (almost like if the camera starts spinning in a circle). I have tried looking for fixes but it seems as no one else has this problem. I am in desperate need for help, as I get little to no FPS when not in fullscreen. (Yes, this happens in all the mod packs I've checked so far.)
      Video: https://www.youtube.com/watch?v=IwnCAxhpfB4
       
    • By EllisAkap
      Hello !
      So here's my problem !
      I imagine that it is me, who is made a mistake but good ! When you don't know! You might as well ask for help !
      I tried to create a Modpack for my friends and me. Except that when the Technic launcher installs it, the game launches in Vanilla.
      I attach to you the link of the archive which I use for the Modpack.             https://a-11.1fichier.com/p615904169
      The Modpack is in 1.12.2. It is surely important to specify it !
      Thank you in advance for your help.
      EllisAkap.
       
      Ah ! And ! Sorry for my english, if it is not perfect ! Being French, it is not my main language.