Jupstart

Technic Launcher Won't Work

Recommended Posts

My topic covers this issue. Looks like your java or graphics driver is out of date (you may want to consider trying latest version of java and ignore anyone saying to use java 7)

 

Edited by CreeperNukeBoom

Share this post


Link to post
Share on other sites
11 hours ago, CreeperNukeBoom said:

My topic covers this issue. Looks like your java or graphics driver is out of date (you may want to consider trying latest version of java and ignore anyone saying to use java 7)

 

Which would possibly help them if they can still update their graphics drivers, but now they updated past 8u51, which causes this particular error. Ever wondered why the vanilla minecraft launcher uses a bundled java 8u51?

Share this post


Link to post
Share on other sites
3 hours ago, JaariAtmc said:

Which would possibly help them if they can still update their graphics drivers, but now they updated past 8u51, which causes this particular error. Ever wondered why the vanilla minecraft launcher uses a bundled java 8u51?

That's interesting. Java currently has build 8u231. As does OP.

8u51 seems incredibly old like maybe OP can still update their graphics. They didn't say they couldn't. Neither did they mention any troubleshooting steps. Also java is separate from graphics driver so that statement doesn't make any sense. Eg: updating java is NOT updating graphics driver. Same as updating graphics driver is NOT updating java. Unless you meant to write that differently. just wanted to point that out ;) (it's enough to confuse lesser tech literate people)

Log mentions only up to 1GB RAM. Is that what has been allocated in the launcher or what OP actually has? Although given that the java VM identifies as x64...

Having said that, the minecraft version might have a hand in this (1.12.2). an older version of java for this minecraft version doesn't sound like a good idea...

 

@Jupstart A few questions for you. I noticed you have windows 7:

1. What graphics card do you have and what graphics version is installed? I just noticed the log doesn't actually note this and amd64 is processor architecture.

1a. Press Start> type "device manager". What comes up if you expand "Display Adapters"?

1b. Right clicking on each of the entries under Display Adapters and clicking properties. What Driver Version shows under the Driver tab? 

2. Do you have more than 1GB RAM you can allocate in the launcher settings (top right cog) >  under java settings tab? 1GB is default when setting up the launcher for the first time and can cause modpacks not to load.

2a. Fastest way to find this if unknown is press start > Right click Computer > click Properties. It's listed as Installed Memory.

Edit: 3. If there is an update available for your graphics card from your manufacturer but it won't install. it indicates that there is a problem. One of the following possibilities:

 

1. Virus / malware. Viruses / malware tend to do all kinds of fun stuff, usually unexplainable but its still enough to render your PC as not running %100 efficiently. This includes locking your driver installing portion so no driver updates can be performed. (This happened to me once)

2. Windows files are corrupt requiring a reformat. This is another infamous cause of problems. My system recently had some corrupt files that slowed it down to a crawl.

2a. The following page covers how to diagnose this.

https://support.microsoft.com/en-us/help/947821/fix-windows-update-errors-by-using-the-dism-or-system-update-readiness

2b. if you really do need to reformat + can't back everything up and are sure there are no viruses. using your install CD. go Install>custom (ignore the part where it says it will delete everything)> select your installation but DO NOT CLICK FORMAT! > click next. you will be asked if you want your files moved to windows.old. click yes. This will move your entire install including all files. (even whatever was on desktop) to a folder called Windows.old during installation. You will not be able to use this old install but you will be able to effortlessly recover everything.

This is really good if you have Steam and lots of games. you can literally just cut and paste the Steam directory from windows.old/Program Files(x86)/ to C;/Program Files(x86)/ (if your install is to C: for example) then just run steam.exe. sign in. let it repair your install and done :)

 

I'm only mentioning this because I had a similar problem 3 weeks ago.

Best of luck fixing your problem. It's not fun when computers chuck tempers...

 

Edited by CreeperNukeBoom
adding info and asking for more details from OP

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By ketrab2004
      When i start my modpack it starts vanilla minecraft without any mods
      link to dropbox
      i am using forge 1.14.4  28.2.0
      latest.log
    • By Marller
      I updated a modpack last night and lost everything. Most of the mods that were in the pack I use all the time and they were removed. I tried to reinstall them, got Needs Newest Forge Update, tried to install that and nothing. I've even uninstalled and reinstalled the modpack several times. When I load the game it just loads the vanilla version. I asked for help in their Discord but there was nothing that they could really do. I've tried a few modpacks and they all load just fine. Is there a away to fix this?
    • By Yamiash101
      Howdy, I'm trying to set up a dumb little modpack for me to screw around with using the technic launcher, mostly so I can still use client-side mods on my main client without having to switch the mod folders constantly. Anyways, as the title suggests, it's opening up in vanilla. I understand this is a relatively common issue, and have spent the last 2 or more hours looking at other members' help requests to little avail. As far as I can tell, everything has been done correctly.

      The modpack is unceremoniously called Dat Survivor Boi, since Survivor was taken and I didn't feel like making something serious, as this was supposed to be a relatively private thing at first. Any help would be appreciated. I suspect it might have something to do with "coremods", but I haven't really screwed around with mods later than 1.7.10 before, so I am very unfamiliar with it. It's never been an issue in my past, and I'm doubtful it is now, but that's the only thing I can tell could be wrong.

      Thank you for reading.
    • By aaronthebigdino
      Type of Bug: In Game Bug: Crashes while trying to load mods
      Problem: Technic Launcher/Forge crashes while loading mods, or loads mods but is unable to create or join a world without crashing.
       
      Modpack: Tekxit 3, Version 1.12.2
      Game Log: http://batman.gyptis.org/zerobin/?d721831b40c2244d#tNvBcsEp8AIcpu3DOnAa0pg6y0cmhivU6EihgKUD9gw=
      Crash Log: http://batman.gyptis.org/zerobin/?7716be1e3120b2fc#DpfgKpZVoxIti+naxx3fa2P2ggxwSMQQDheO/UNHf8w=
       
      Attempts to fix:
      -Upped allocated RAM to Minecraft
      -Changed client from Technic Launcher to Forge, problem persisted
      -Deleting mods and reinstalling
      -Removing all mods to see if it was a problem w/ forge; it was not the problem; forge loaded perfectly fine
       
       
       
      Any help would be appreciated!
    • By DefinitelyNotMLG
      Hey I'm having trouble downloading Linux and I'm not sure what to do,
      I have both jre and jdk 8 installed and updated
      it starts and then stops and doesn't download any files
      I'm just not sure what to do, her are the content of the log file
      also I'm running the latest version of pop_os
      [B#505] 2020/03/13 21:43:37 [INFO] Console Mode Activated
      [B#505] 2020/03/13 21:43:37 [SEVERE] java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at net.technicpack.ui.controls.installation.SplashScreen.<init>(SplashScreen.java:84)
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:108)
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:201)
      [B#505] 2020/03/13 21:43:37 [SEVERE] Caused by: java.lang.ClassNotFoundException: com.sun.awt.AWTUtilities
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
      [B#505] 2020/03/13 21:43:37 [SEVERE]     at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
      [B#505] 2020/03/13 21:43:37 [SEVERE]     ... 4 more
      [B#505] 2020/03/13 21:43:37 [SEVERE] Unhandled Exception in Thread[main,5,main]
      java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities
          at net.technicpack.ui.controls.installation.SplashScreen.<init>(SplashScreen.java:84)
          at net.technicpack.launcher.autoupdate.TechnicRelauncher.buildUpdaterTasks(TechnicRelauncher.java:108)
          at net.technicpack.autoupdate.Relauncher.runAutoUpdater(Relauncher.java:97)
          at net.technicpack.launcher.LauncherMain.main(LauncherMain.java:201)
      Caused by: java.lang.ClassNotFoundException: com.sun.awt.AWTUtilities
          at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
          at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
          at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
          ... 4 more