Jump to content

Recommended Posts

Hey, M1r077 asked to see my RIM lift, so I'm making this post


Here is an imgur album of the lift

I use RIM controlled by CC's computers, I commented them in English (I have a bad English). They all work, I just tested them, however, there are constants at the start of the scripts you may need to change according to your setup, like the side of the modem, the controller, or adapt your screen size

If you find a bug, have a question or a suggestion, please go ahead, I'll be happy to help/get helped :)

Edited by Niverton
Link to post
Share on other sites
  • 3 months later...

Dude it work i rebuild the lift form your planes, and it work is a little slow but is awesome, i will change the structure but the caller system is 100% funcional, juts 1 thing, i have trubles with the screen (monitor inside the elevator) i do not know how to add levels on the screen i got this



--Adds level with number, label and corresponding level to the list
                -- Choose short labels if you have more than 5 levels, 8 char max for it to display correctly on screen
        function addLevel(num, label, level)
                local t = getTable()
                t:add(0, Sotano 1, 0)
                t:add(7, PB, 7)
                --We have too many registered levels to display them on the screen
                if #t >= MAX_LEVEL then print("too many levels !") return 1 end --The return is not used




Edited by Mauroalej36
Link to post
Share on other sites

Woops, forgot to explain that, and also forgot to translate the comments in the section that does that. When the script is running, if you press the + key on your numpad it prompts you to add a level

Add a floor:
<number> "label" <level>

<number> is the number that will be displayed on the left of the label on the screen, label is the name of the level and level is the distance from level 0 to your level. If your level 1 is 5 blocks above level 0 then level is 5; if it's 3 blocks below then it's -3. You don't need to write the '<>' and the '"'.


If you press the - key on your numpad, it prompts you to delete a level

Remove a floor:

<level> is the same than when you want to add a level, it's the distance from level 0.


If you press the * key on your numpad, it prompts you the number of a level (the number on the left of the screen) and gives you the distance (useful if you want to delete a level but don't remember the distance).


It's not that easy to understand nor to explain, and i'm sorry about that, could have done it better now that I think about it. I will rewrite everything for CC 1.6 when I'm done with my other projects and create another topic on the forum


EDIT: Also, you can change the keys used, just edit the following lines

if event[2] == keys.numPadAdd then --Add level
elseif event[2] == keys.numPadSubtract then --Remove level
elseif event[2] == keys.multiply then --Get level

with keys from the keys API

Edited by Niverton
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By GrantTheWizard
      Hello, I am new to LUA but not in programming. I am not understanding why my blockchain is not working.
      It is supposed to go 40 blocks down the row(Hence the for loop for count 40)
      Then when it gets to 40 come back(I need to change the 3 to a 2) but what it does right now is it digs the first wheat then stays there, then executes the turn then stops. Any ideas on how to fix?

    • By ZeZoBeatz
      As you see by the title, I am trying to help a random person on the server I play on with ComputerCraft. He made a program called LockExe and he just sells it on the server. It is very simple program. It just reads for the password and when you input it, the computer outputs a redstone signal for 5 seconds out the left side and then stops, then the computer reboots back up to the startup screen where it asks for the password again. But I just discovered the 'terminate' feature through ComputerCraft and I do not think he knows about it. So I am trying to edit his code so it disables/makes it harder to terminate the program so no-one can just steal his code. But everything that I have tried with the code keeps breaking the program. I keep using the os.pullEventRaw and that can read for the terminate event and can make it do other things besides just terminate but there are issues that I have found with using that. The first and main issue is that the os.pullEventRaw stops the programs entirely, meaning that it no longer allows me to type anything in the computer and it insteads waits for the input of the terminate event. I do the terminate event and whatever I made it do after the input happens, it does. Like if I tell it to type something out after I do ctrl + t, it tells me it. But this means that the password cannot be typed in. The second issue is after I use ctrl + t to do that terminate event, I can just do it again and it will terminate that so it will bypass it anyway. Like I said before, I am trying to help him out with his program just so no-one can steal it. Btw, he did not ask me to do any of this, I am doing it because I wanted to see if I could. But it seems I need help. This is the coding of his program just incase it helps.
    • By Nukious
      Hi, I'd like to know how I can change the terminal width and size via the ComputerCraft config for my Tekkit Classic server.
      I've tried changing terminal_width and terminal_height, but they only seem to work on singleplayer and if I edit them on the server's config, nobody is affected.
      Here is my config...
      #MLProperties: name (type:default) min:max -- information #MLProp : computerBlockID (int:207) #MLProp : diskDriveBlockID (int:208) #MLProp : diskItemID (int:4000) #MLProp : diskDriveGUIID (int:100) #MLProp : enableAPI_http (int:0) #MLProp : modem_range (int:64) #MLProp : modem_rangeDuringStorm (int:1) # #Fri Jul 22 00:59:10 CEST 2016 terminal_width=100 terminal_textColour_g=255 modem_rangeDuringStorm=16 computerBlockID=207 diskItemID=4000 diskDriveBlockID=208 enableAPI_http=1 terminal_textColour_b=0 checksum=440 terminal_textColour_r=0 modem_range=64 diskDriveGUIID=100 terminal_height=36 What do I do? As you can see I've set terminal_height and terminal_width to twice the default, however, only the HTTP API setting seems to actually change something in this config file.
      I'm quite stumped here, my singleplayer configuration has no effect on servers too!
      If possible, I'd like to make the default text colour green as well, to make the ComputerCraft terminals on my server look like the RedPower computers.
    • By 0x0
      So I recently started playing Tekkit 1.2.9g and was wondering if I should expect any future updates any time soon?
      It looks like the last update was over a year ago, and I couldn't find any official announcements or posts from the developers if they have stopped updating it.
      I'm asking primarily to see if the computer craft mod will be updated in a future patch.
    • By Tassyr
      So last time I checked out this pack it was just over a year ago. Before that I'd played for several months, then had to take a break. Originally, there was a bundled redstone wire and computercraft combo that worked. It worked great, in fact, and I designed a large amount of stuff around it. 
      When I resumed about a year ago, it was no longer working. I was told to wait a few months for an update that'd fix it and similar on this forum when I asked.
      Well guys, it's been a -year.- I realised I hadn't played in forever so I decided to give it a shot, and lo and behold! ... still no compatibility between computercraft and bundled redstone.
      Is there any way to get that sort of functionality back? Or has it just been flat out abandoned here? 
  • Create New...