Jump to content
Sign in to follow this  
chippewaguy13

how do i make a modpack for 1.2.5?

Recommended Posts

 I want to make a modpack for 1.2.5 I understand how to do it for 1.6.4+. All I really want to do is play tekkit classic with the newer version of nuclear control. I have it running on my desktop by just downloading the 3.1.3 server and swapping out the bugged version and same for the launchers client. But there small group of us (6-ish) and trying to walk them through %appdata% and things would be a pain. is there a pack all ready made or how do I roll togther a 1.2.5 pack (I know I need the right forge version)? Can anyone give step by step directions or point me to a pre-made pack?

Share this post


Link to post
Share on other sites

 Still no luck. I tried just zipping the contents of my tekkitmain folder under %appdata%/technic uploaded it to my drop box it crahes, I tried only doing the bin, coremods, mods, configs from it and crash, I tried using the coremod, config, mods, and then making a new blank bin folder I downloaded the client version of forge 3.3.8.164 and renaming the zip to modpack.jar and puttin only it inside the bin file, crash. I guess I need step by step directions because I'm missing something. I have the server and the client running fine I just want to get a pack together with the newer nuclear control in it so my wife and friends can just download the pack to play on our small server.

Share this post


Link to post
Share on other sites

Tekkit Main =/= Tekkit Classic. Which version are you trying to start with? If the former then Forge/MC 1.6+ does not use a coremods folder in any way. Your modpack should only contain these folders: bin, config, coremods (if Forge/MC <= 1.5.x), and mods. If you have something like Chocolate Quest or Flan's installed you would also need to include those top level folders. The bin folder should ONLY contain modpack.jar which is simply the correct Forge universal jar renamed to "modpack.jar.

Share this post


Link to post
Share on other sites

I gave up on 3.1.3 and went to 3.1.2 version of tekkit. Now though when I ever START AN OLDER VERSION ON MINECRAFT (PRIOR TO 1.6) I can no longer connect to servers online. localhost work fine but no online even if I unplug router and go direct.
 

Ok all fixed I went with version 3.1.2 due to the fact there are MANY errors in 3.1.3 but fun fact minecraft versions 1.3 and OLDER are very picky about ip adress and port. So after entering the ip number WITH port everything works!!

Edited by chippewaguy13

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Verhunqert
      hi see i recently made a modpack and everytime i start is is says installing assets, does that, then just doesnt start, no minecraft nothing, please help, i already made the 0 of the dropbox into a 1 and stuff like that
       
      dropbox: https://www.dropbox.com/s/oulmzhezhfw976b/Minecolonies.zip?dl=0
      modpack: https://www.technicpack.net/modpack/modpack12-341.1703589
    • By IcarusUK
      Hey, so I've made a modpack for my gaming group and have followed all the steps closely that were provided on the guide. However, whenever I open the modpack on Technic it does not load forge, only vanilla minecraft. The forge version is: 14.23.5.2847 and works perfectly fine in the normal minecraft launcher (yes I used the universal version for the modpack and renamed it correctly). Furthermore all of the mods work and I'm able to connect to the server I host which also has the same version of forge which works there (and of course all of the mods). When I check the .technic folder and go to the pack folder everything appears to have installed correctly however forge does not load even though it's in the bin folder with minecraft.jar (this is automatically put there by technic). The modpack link is below, please can someone help me to get this to work...
      http://api.technicpack.net/modpack/resist-gaming
      The bin folder:

      This is the full contents of the modpack

      This is the config folder (it has 1 required customised file under CustomMainMenu - this works in the standard minecraft launcher):

      If you can help me with this I would really appreciate it.
       
      Mark
       
      (edit) here's the direct download of the pack... https://www.dropbox.com/s/kkfbn4gfahx8ul3/rg1.zip?dl=0
    • By AlexKoyomi
      When I click in install, it does something for a second and then just appear the options to "Delete modpack" and "install".
       
      https://pastebin.com/KpRY4efn
    • By PyroSweets
      My friends and I made a custom modpack with all our favorite mods in 1.12.2. I was having some issues with the modpack.jar that made it run vanilla and I fixed it, but now the modpack doesn't even show a java client or loading screen before crashing. I posted a day or two ago on reddit and was told to delete some iffy modpacks, but that only makes it run vanilla again. Any ideas why this is happening?
      Crash Log: http://dl.dropboxusercontent.com/s/wkv06mn3wna9hbv/techniclauncher_2020-05-31.log
      Modpack: http://dl.dropboxusercontent.com/s/ndyuw1g8t38xkde/POGWORK.zip
      Technic Page: https://www.technicpack.net/modpack/dillons-cult-pack.1697994
×
×
  • Create New...