Archived

This topic is now archived and is closed to further replies.

LavaClaw

Constant Freezing and Unfreezing Every Few Seconds

9 posts in this topic

hi!

Upon playing Tekkit MP, my client experiences a bearable but extremely irritating issue: it freezes for half a second every few seconds. I'm running 64 bit java, 16GB DDR3 RAM, intel i7-2600k 3.4GHz processor, AMD HD6970 graphics, 120GB SSD and 3TB HDD, running on win7 64 bit. I'm using two screens and i am enabling vsync in the client options (however, each setting has no effect on the bug) I've tried deleting all my tekkit files and reinstalling, the same with minecraft (deleting bin did not work either) i've fiddled around with my RAM allocations to no avail. The tekkit version is 1.2.6b (the server i play on is only updated to that)

 

Further information:

The freezing is not an fps drop, my window literally just freezes for a split second, it stays at a constant rate regardless of whether it is frozen or not

The java process is not using up all of my computer resources, so it isn't that either.

 

Has anyone else got some ideas as to how i can fix this?

Share this post


Link to post
Share on other sites

On the launcher. Select so it would use more of your computer RAM. It's in the launcher options when choosing modpacks.

Share this post


Link to post
Share on other sites

In the F3 screen see if pauses are associated with momentarily doing hundreds of chunk updates for an instant. I had that issue in Linux until I bumped Java memory use in the launcher from 1 GB to 2 GB.

 

Although, someone else running Windows with similar issue said in another thread that there was some other general setting in Windows limiting Java memory use to 512 MB that he had to change.

Share this post


Link to post
Share on other sites

In the F3 screen see if pauses are associated with momentarily doing hundreds of chunk updates for an instant. I had that issue in Linux until I bumped Java memory use in the launcher from 1 GB to 2 GB.

 

Although, someone else running Windows with similar issue said in another thread that there was some other general setting in Windows limiting Java memory use to 512 MB that he had to change.

 

Tested. Confirmed. Running on a 4gb ram and java 64bit. Limiting it to 512MB does prevent lag. But due to limitation it can have a minor higher chance of crashing. Confirmed while using Memory usage of 512MB preventing lag but crashed after 6 minutes on the performance test map. On 2 GB. Had some FPS drop rates and lasted for 8 minutes. So it's not a big change. I still suggest with 512MB. But if running loads of machinery which require loads of ram (Singleplayer) Then i suggest a slightly higher than 512MB.

Share this post


Link to post
Share on other sites

512MB damn .....my phone uses more then that, set the server is at 4GB and client is at 6GB, and call it a a day. Like trying to tow a 35 foot boat with a 4 cylinder, you can do it but my god why would you

Share this post


Link to post
Share on other sites

Tried changing my memory both in game and in the java settings, i still get the same issue. As for trying to get the information from F3 regarding chunks - it appears that the f3 menu freezes as well. Could this indicate it's something external that is freezing the client? Seeing as it isn't simply fps lag?

Share this post


Link to post
Share on other sites

I have the same problem. Not an FPS problem, it's like it freezes for few milliseconds, like it's a high ping-spike. Imagine playing counter-strike with high ping. Running -> stopping for a millisec -> running etc. I have no clue what it is, and I'm playing on my own server, hosted on the same computer. Anyone know a fix for this? Would be appreciated! :)

Share this post


Link to post
Share on other sites

I had a similar problem which turned out to be McAfee virus scan.  I put an exception in it so it wouldn't scan the tekkit folder and the stutters went away.

Share this post


Link to post
Share on other sites

If the pause issue is while playing on a server, it most likely is due to the server and the client running at slightly different speeds.  The slight pause is on the client side is only the client trying to keep synchronized with the server.  I had that issue playing on a friends server.  Every few seconds the game would pause for about half a second.  We did a test, and my computer was running the game just a fraction of a second faster then his server, so my computer would have to pause operations every few seconds to synchronize with the server again.

Share this post


Link to post
Share on other sites

  • Similar Content

    • By DatMudkip873
      When I try to run minecraft sky (official) everything works fine but when it says: Finishing Up 6/7 it will close out of minecraft and put me back on the technic launcher. (I haven't gotten any crash reports) Please help!
      I think this may be a crash report?
       
      [16:57:37] [main/INFO]: Setting user: DatMudkip873
      [16:57:39] [Client thread/INFO]: LWJGL Version: 2.9.1
      [16:57:50] [Client thread/INFO]: Reloading ResourceManager: Default, FMLFileResourcePack:Forge Mod Loader, FMLFileResourcePack:Minecraft Forge, FMLFileResourcePack:Not Enough Items, FMLFileResourcePack:Aether II, FMLFileResourcePack:AgriCraft, FMLFileResourcePack:ArchitectureCraft, FMLFileResourcePack:BiblioCraft, FMLFileResourcePack:Botania, FMLFileResourcePack:BC Transport, FMLFileResourcePack:BC Silicon, FMLFileResourcePack:BuildCraft, FMLFileResourcePack:BC Energy, FMLFileResourcePack:BC Factory, FMLFileResourcePack:BC Builders, FMLFileResourcePack:BC Robotics, FMLFileResourcePack:BuildCraft Compat, FMLFileResourcePack:ChickenChunks, FMLFileResourcePack:Chisel, FMLFileResourcePack:CoFH Core, FMLFileResourcePack:PTRModelLib, FMLFileResourcePack:Decocraft, FMLFileResourcePack:EnderCore, FMLFileResourcePack:Ender IO, FMLFileResourcePack:Ex Nihilo, FMLFileResourcePack:Ex Compressum, FMLFileResourcePack:Gilded Games Utility, FMLFileResourcePack:Gliby's Voice Chat Mod, FMLFileResourcePack:Immersive Engineering, FMLFileResourcePack:Inventory Tweaks, FMLFileResourcePack:Iron Chest, FMLFileResourcePack:Logistics Pipes, FMLFileResourcePack:Mantle, FMLFileResourcePack:MinecraftSky, FMLFileResourcePack:MineFactory Reloaded, FMLFileResourcePack:MFR Compat: BuildCraft, FMLFileResourcePack:MFR Compat: ForgeMicroblock, FMLFileResourcePack:MFR Compat: Thaumcraft, FMLFileResourcePack:MFR Compat: Thermal Expansion, FMLFileResourcePack:MFR Compat: Tinkers' Construct, FMLFileResourcePack:MFR Compat: TwilightForest, FMLFileResourcePack:MFR Compat: Vanilla, FMLFileResourcePack:MineTweaker 3, FMLFileResourcePack:Mod Tweaker 2, FMLFileResourcePack:Rope Bridge, FMLFileResourcePack:RPGAdvMod, FMLFileResourcePack:Solar Expansion, FMLFileResourcePack:Tinkers' Construct, FMLFileResourcePack:Thaumcraft, FMLFileResourcePack:Thermal Expansion, FMLFileResourcePack:Thermal Foundation, FMLFileResourcePack:Tree Growing Simulator 2014, FMLFileResourcePack:The Twilight Forest, FMLFileResourcePack:Waila, FMLFileResourcePack:Yet Another Backup Mod, FMLFileResourcePack:YUNoMakeGoodMap, FMLFileResourcePack:Baubles, FMLFileResourcePack:Forge Microblocks, FMLFileResourcePack:Forge Multipart, FMLFileResourcePack:Minecraft Multipart Plugin
      [16:58:22] [Sound Library Loader/INFO]: Sound engine started
      [16:58:28] [Client thread/INFO]: Created: 16x16 textures/blocks-atlas
      [16:58:29] [Client thread/INFO]: Created: 16x16 textures/items-atlas
      [16:58:47] [Client thread/INFO]: Created: 16x16 textures/revolvers-atlas
      Hopefully this helps!
    • By Zamto
      So everytime i try to launch a mod pack it just restarts technic launcher if anyone has any ideas help please
      Logs: https://pastebin.com/yntVfBAA
    • By Not-Gideon
      So I've been on the technic platform a while right and I play a lot then all of a sudden I launch the launcher and it goes to "querying update system" then just stays on the logo.

      At first, I thought it was downloading something so I waited... a couple hours didn't change.

      I have no idea why this is happening it might just be my computer but I didn't change anything since I last played so i need help
    • By Lukato
      When I click on play the launcher starts to load, but after its done it just says again play.
      Can anybody tell me how to fix this?
    • By AdinaTheFurscist
      I was trying to setup a server for me and my friend to play on, but then I ran into a bug where my tekkit legends client always crashed upon joining, I looked into the logs and all I could find was this. Does anyone know a fix to this? I've been trying to fix it for several hours and I can't seem to figure it out, much appreciated if you help me.
       
      https://pastebin.com/AgxYDufw