Jump to content

Could anybody Create a Modpack for me?


Recommended Posts

I have come to realize I am unable to create a modpack due to lack of modpack-creating knowledge. I tried about three times and it still won't work. So if anybody out there is willing to create a modpack for me that'd be amazing!

Here is the list of mods - I made sure that all of them are compatible with 1.7.10 and although some of the mods don't have check marks on them, I still would like them in my modpack. Please post here or message me if you are willing to create this! Thank you!

Edited by mytoecold
I misspelled modpack.
Link to post
Share on other sites

There are plenty of useful tutorials out there for creating modpacks, the biggest things to remember  is that you must include a minecraft.jar and a forge.jar in the bin folder(it will be renamed to "modpack.jar") and when you link the modpack location url it must be an automatic download, usually with a "=1" at the very end of the url for dropbox. A modpack with this little mods would be a breeze to make, 5-10 minutes to gather the mods, maybe 5 minutes to make sure they all work with each other, and another 5-10 minutes for archiving the pack and uploading it.

Of course I forgot that you will need to spend a little time messing with configs, changing ids, balancing mods, generator configs and various tweaks so that its more a custom pack than a collection of default mods

Edited by TerdyTheTerd
Link to post
Share on other sites

@daytimepanther Okay, then here's what happens when I try to play my modpack - it installs perfectly, but when I press play this is what happens

@TerdyTheTerd Well actually I did collect all of the mods and added them all into the folder entitled "mods". The only problem with finding tutorials is that I have a mac and I prefer 2015 mods because of the newer version of technic launcher. So what I did is create a folder called "emcraft" and I put two folders within it - "bin" and "mods". In the bin folder is forge for 1.7.10 and I renamed it "modpack.jar". In the mods folder I added all of the mods listed in the link in my fist post. Then to make it into a zip file, I highlighted "bin" and "mods" and selected the "Compress 2 Items" option and therefor created a .zip file called "emcraft.zip". Then I dragged it into my public folder on dropbox. I copied the public link and pasted it next to the "Modpack Location" thing. 

@Munaus Oops! I'm moderately new to the technic platform forums. Sorry! I'll try to add my forum to the correct forum next time!

Link to post
Share on other sites

It might be that the pack is crashing when it starts up. Go to the technic launcher settings and enable the checkbox that says show console. Now when you launch the pack you can get an idea of what is happening. Also go to the modpack folder and look for a crash log. If you're not sure how to do any of this just search for it on google.

Link to post
Share on other sites

@daytimepanther Woah, I didn't even know you could do that! So I did what you said about enabling the console and this is what it said. I'm not sure what it means. My name is Emily by the way and that's why it says "/Users/emily/Library/Application". I also have no crash report folders...

Edited by mytoecold
Link to post
Share on other sites

I have a working version of the pack. You forgot to download CoFH Core, Mantle, a core mod required for the Camping Mod, and a core mod for Mariculture. Along with the missing mods, you had two versions of bpkrsCore and the shaders mod is just completely not working. All of the original mods are working except for the shaders mod. It could be that you are using the wrong version of the mod or it might be incompatible with you Optifine version. I will upload a fixed version of just the mods folder for you shortly.

Here is the updated mods folder: https://www.dropbox.com/s/dmdm9ihoaesngzz/modsfolder.zip?dl=0

Link to post
Share on other sites

@daytimepanther I can definitely try! It's a great learning experience! If I do in fact figure out how to make it work It'll be good to know how, especially for future modpacks! But if I somehow can't figure it out I'll contact you. Thanks for all of your help! I still will be posting here and asking questions too. The only big question I have is "what is the main problem?". Because if I can figure out what's wrong then I can google it or ask for help more efficiently.

Edited by mytoecold
Link to post
Share on other sites

It's definitely good to google and figure stuff out on your own so you can learn. What j usually do is look at the crash log and look for any mod names at the beginning or Google what is after where it says "Caused by:". Usually it will lead me to a solution. Like I said its shaders that is crashing for sure but it might be because it is conflicting with another mod.

Link to post
Share on other sites

 @mytoecold Working pack link somewhere in my post, sorry it might be a little hard to follow, did this right before I went to bed.

Shaders Mod Core doesn't work with forge past 1448, aslo note that you wanted TMI and WAWLA, but in order to run WAWLA you need WAILA, which in turn requires NEI, and NEI and TMI are incompatible, so I removed TMI. Also I recomend adding FastCraft, it helps more than optifine does, but it also doesn't help as much when shaders mod core is installed(its culling effects are turned off, where all the extra fps comes from). I have opted out of optifine for FastCraft and included a few Shaderpacks already in the pack as well a a very poorly made logo while its loading. If you want the files install this test pack found here or you can download the archive and do it manually here, it hasn't been greatly tested, I just confirmed that all the mods initialized and that creating worlds worked. Making modpacks can be tricky at times when you try to add all the mods all at once. You will have to do a vast amount of config editing to get the mods to behave how you want them to.

Edited by TerdyTheTerd
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Umbreon118
      For some reason my modpack won't load mods when I start it up, it just cuts to vanilla.
       
      I am hoping that one of you wonderful people can find issues that I have missed.

      Here is my dropbox for the modpack, https://www.dropbox.com/s/rnnzusyjyp8z2w8/Pokemon.zip?dl=0 
      Before anyone says it, I have double checked by reinstalling all the mods off of curseforge to insure they are from a reliable source.

      I hope to hear solutions or suggestions soon.

      Thanks
    • By Plowmanplowbro
      First of all, i apologize if this is the wrong place, i couldnt find a help section in the search. and im in desperate need of a solution. 

      So i followed a tutorial to publish a pack to technic, it downloads everything fine but minecraft itself doesnt load with the mods. 

      here is the link: http://dl.dropbox.com/s/6mes1106tcic227/Soffcraft.zip

      please tell me what i did wrong, i have people waiting on me to finish this. 
    • By Justous
      Hi everyone,
      Despite my best efforts and reading several previous posts from this very form, my modpack keeps launching as if forge isn't installed. The mods and config folders and filled out and the modpack.jar is present in the bin folder upon install, but something just isn't happening. It seems like there must be something really obvious I'm missing...
      Here's a link to my modpack's zip: https://www.dropbox.com/s/m9pxkwagken6o02/muscraft.zip?dl=1
      Anyone have any idea what is wrong?
    • By Sakitek12!2
      So. I tried making modpack for me and my friends, but apparently, it isn't working. It starts normaly, but mod's won't load. Minecraft version is 1.12.2Links:

      Dropbox: https://www.dropbox.com/s/4y12dgfo6aifg4d/Modpack yes.zip?dl=0

      Pack https://www.technicpack.net/modpack/modpack-yes.1730492

      Thanks for any help. I tried doing what you guys said in other thread, but it didn't work for me 
       
    • By JoiNeeR
      Hi!
      So, I'm making a modpack around Mathioks Naruto Mod, but I need a team.
      If you think you can script, hit me up please.
      If you think you can help me with anything else, hit me up please.

      We will discuss everything, so contact me, thanks!

      (I am willing to pay for your work.)

      Discord server link: https://discord.gg/sup7y3
      Discord name: JoiNeeR#4430
×
×
  • Create New...