Jump to content

need help adding more mods to tekkit


michael noel
 Share

Recommended Posts

Alright so me and a friend wanted to play Tekkit, but there's just one problem.

We don't have Foresrty, Thaumcraft or Thaumic Tinkerer on Tekkit anymore.

Forestry was removed a while ago, and I don't know when Thaumcraft was removed, but that's not the point.

What I want to know is: How can I install these mods on my game and on my server? Any help on this would be greatly appreciated.

Edit: Yeah, don't know how I forgot this, but figured I should specify. What I want is to know mostly which versions of which mods do I need for them to be compatible with Tekkit and where to put them (both in the client and the server).

(Also: I'm sorry if I'm slow on replies, we're having some weather problems in the area and the internet connection is a bit slow because of it.)

Link to comment
Share on other sites

Your best bet? Make a custom modpack. That would make it easy for all of you to stay at the same point for mod versions and such. Just start with Tekkit 1.1.5 and add what you need.

As for versions on mods, this may help: http://bot.notenoughmods.com/1.5.2.html

I'm kind of new to custom modpacks and I was actually planning on making one originally. But that didn't work out.

Although I'd be interested in knowing what you mean by "Start with tekkit". Do you mean that I should copy the Tekkitmain folder's content to make a modpack?

Also that link you gave me gives me the current mods version. Unless I'm not seeing something, what I meant was I wanted to know what version of forge Tekkit was using, and what versions of each mod were compatible with that version. Forestry specificaly doesn't keep track of what forge you need for the older versions of his mods.

Unless... can I install older versions of mods and it'll be fine even though I'm using a newer version of forge?

Link to comment
Share on other sites

You can add any mod you like to Minecraft. Tekkit is simply a Modpack (group of mods) The biggest issues with making mod packs is working through Item ID conflicts and making sure everything plays nice together.

There was a forum somewhere that I remember a guy named Luke made a nice post about how to make your own packs, if I can find it again will post the link for you.

Edit: found it

http://forums.technicpack.net/threads/luke%E2%80%99s-hopefully-comprehensive-modpack-making-guide.44197/

Link to comment
Share on other sites

You can add any mod you like to Minecraft. Tekkit is simply a Modpack (group of mods) The biggest issues with making mod packs is working through Item ID conflicts and making sure everything plays nice together.

There was a forum somewhere that I remember a guy named Luke made a nice post about how to make your own packs, if I can find it again will post the link for you.

Edit: found it

http://forums.technicpack.net/threads/luke%E2%80%99s-hopefully-comprehensive-modpack-making-guide.44197/

But can I install a mod that requires a previous version of forge on a newer version of forge?

Link to comment
Share on other sites

Sorry for the no-reply period. My parents decided to do a "Surprise camping trip" and, since it's raining we've come back for the time.

So I've successfully installed Forestry without any problems, now I'm going to try doing Thaumcraft and Thaumic tinkerer.

I'll let you guys know if there's a problem.

Link to comment
Share on other sites

I also tried to install flans mod to tekkit cuz I knew tekkit has already a fml, but It didn't work. I tried clay soldier mod and that worked perfectly, can any1 help me?

If you're using the "Recommended build" in the Tekkit options, you most likely won't have the Forge Mod Loader version required. Try using the 1.1.5 manual selection build from the options. If you're already using that version than I have no idea what may be causing your issue.

Link to comment
Share on other sites

And, of course, things couldn't just go easy on this one...

So, one of my friends can't connect to the server, he get's a gray/white screen upon logging in.

I've deleted his player.dat file but that doesn't work.

I also sent him my personal "Mods" folder to be sure he was using the same version of everything.

Any ideas on what my be causing this issue?

Link to comment
Share on other sites

Alright, we figured the problem out. Turned out that my friend's Java decided to do some weird stuff and wasn't recognized as 64-bit anymore so he ended up giving 1GB to Tekkit, which caused it to crash on our server because of the running machineries/power sources.

Got it installed and working for him.

Link to comment
Share on other sites

its pretty easy when it comes to adding mods to tekkit. make sure you put 1.1.5 on the launcher because it supports mods better than 1.0.6. i have added ICBM, Electric expansion, railcraft, train craft,and fluid mechanism. theres more you can and its pretty easy. go on the internet and look for your mods to add and make sure they are 1.5.2 if ur on thee 1.1.5 build on the launcher. once you download them put them on the desktop and open the tekkit launcher and under the pack is a little gear and open the the folder. drag your mods to the mod folder and close and press save. run the game and you should have your mods! enjoy! look on the forums for the 1.1.5 server link.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...