• 0
Kelanduo

RAM Problem

Question

I redownload tec, and keep crashing. The map was fine running with normal minecraft but not with tec. Why???

(SP: everything was fine one day ago, 2day I did nothing and this problem come out)

ZW]K2G{U8C`5IL[BABP1}L7.jpg

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

This snipped from the Technic Discord will fix you:

 

You're running a 32bit Java version on a 64bit Operating System. This will prevent you from allocating more than 1GB of ram to the Technic launcher. In order to update to Java 8 64-Bit, please follow these instructions: 1.) Close the Technic launcher. It should not be running! 2.) Open http://java.com/en/download/manual.jsp in your web browser 3.) Download the version that has 64-bit in it for you operating system. If you're using Windows download the one that says Windows Offline (64-Bit). 4.) After the download is complete. You must install it. You can do so by double clicking on the icon to run it. 5.) After it installs start up the Technic launcher again. 6.) Click on Launcher Options in the top right of the screen. 7.) Click on the tab called Java Settings 8.) Click on the dropdown called Minecraft Java Version and select the option that says 1.8_151 64-Bit. 9.) Click the dropdown called Memory and select an option that's between 2 GB and 4 GB. Do not select an option higher than 4 GB!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Quizer9O8
      Hello there,
      Since I haven't got any luck of finding a fix or someone mentioning this issue I'll place it down right here.
      A few months ago I have noticed that whenever you're launching a Minecraft modpack from the Technic Launcher Minecraft suddenly hijacks all of the available RAM which causes to freeze the entire computer for 10 - 15 minutes before I'm able to terminate the process manually in Task Manager (Windows 10). Since I have 16GB of RAM in my pc I allocated 8GB of RAM to Minecraft (which should be enough for many modpacks) in the settings shown here below but no matter what is set in the Launcher Options seems to have any effect, it straight up ignores it all together.

      I'm out of ideas and in desperate need for a solution because this issue makes every modpack I have (small or large) unplayable at this point.
    • By Ironicpown
      So I just installed stoneblock and when I launched it it uses around 1 gb of ram it also warned me that it needed at least 2 gb or else it had performance problems, after a little while of loading it just closes but I have 16 gb of ram and no clue how i give the modpack more ram. I hope i can get an answer ASAP
    • By Kehlani
      The bug:
      Type of bug: Launcher bug. Reproduction rate: 10/10. Technic launcher keeps crashing on me when I'm in-game due to low memory. It also does lag a decent amount.
      Shader/Resource pack:
      I use shaders and an x32 pixel resource pack. I have the same setup in vanilla Minecraft and it works fine there. Technic will still crash even without a resource pack and shader.
      The issue in detail:
      I can't allocate more than 1gb of memory in the java settings in the technic launcher. I have tried to go to advanced system settings in system and checking out the environment variables. I cannot find "_JAVA_OPTIONS" in there. I can find "C:\Program Files (x86)\Common Files\Oracle\Java\javapath" in the system variables but that's it when it comes to java. I just downloaded technic launcher again after a long time (around 2 years). It used to work fine and I used to be able to allocate way more ram (I believe I used 4GB back then). Technic launcher is updated. My draw distance within minecraft is set to 8. 
      OS and Java version:
      I have an x64 bit operating system. I also have java downloaded for an x64 bit operating system. I have confirmed this by running vanilla Minecraft (not technic) and putting my view distance to far. According to this post  https://goo.gl/bpK4qw , if I had x34 bit java installed it would just give me an error message but that does not happen with me. I have also made sure to download the x64 bit version of java and I have updated it.
      ALL INFORMATION ABOUT COMPUTER SPECS + OS + LOGS + MC 
      System specs:  https://imgur.com/a/ryE71LV
      250gb SSD (60gb free space) + 2TB HDD (650gb free space) (I run technic from my HDD). 750W PSU. Windows and my graphics card driver is updated.
      LOG: I tried pasting the log into paste.ubuntu and pastebin but the log is too large and my browser can't handle it (the file size is 25MB). I pasted quite a bit of the end of the log. Sorry but that's the best I can do here and hopefully, it will provide some information of importance: https://paste.ubuntu.com/p/ZFGmBvcqh2/
    • By hperd
      Edit: I just tested to only run Minecraft without the Server, going into a Single Player World and the RAM usage is going up contunously. I set the RAM usage in the Technic Launcher to 4GB, why is it then going higher than that?
      So I'm running a Server with the Mod Pack "After Humans" and I provided the start.bat with the Java Arguments "-Xmx 4G -Xms-1G" and in the Technic Launcher I set the maximum RAM usage to 4GB.
      When the Server is running it is taking around 2.5GB to 3GB of RAM in maximum but the strange thing is, when Minecraft itself is running it's starting at 2GB and is going continously up? Yesterday for example it went to around 8.6GB RAM? If I'm pressing inside Minecraft F3 to see the usage of RAM it says it's using 1.3 to 1.6GB of 4096MB but in the Task Manager it's going continuesly up... Why is that?
      Is Java just adding the Arguments from TL and Server.bat up to one (8GB)?
      Everytime Java is using all my RAM my computer starts to bug out (black monitors / explorer is crashing / can't see my desktop symbols anymore / ...).
      I hope someone can help me out.
      My System is as follows: 16GB RAM, i7-4770, GTX 1060, Win 10 64 bit
    • By Mast
      My computer says 8.00 GB (7.88 GB usable) for ram but when i go to allocate on the launcher then it wont allow me to allocate more than 1 GB help i have a 64 bit