Jump to content
  • 0

RAM Problem


Question

8 answers to this question

Recommended Posts

  • 1
  • Discord Moderator

This snipped from the Technic Discord will fix you:

 

You're running a 32bit Java version on a 64bit Operating System. This will prevent you from allocating more than 1GB of ram to the Technic launcher. In order to update to Java 8 64-Bit, please follow these instructions: 1.) Close the Technic launcher. It should not be running! 2.) Open http://java.com/en/download/manual.jsp in your web browser 3.) Download the version that has 64-bit in it for you operating system. If you're using Windows download the one that says Windows Offline (64-Bit). 4.) After the download is complete. You must install it. You can do so by double clicking on the icon to run it. 5.) After it installs start up the Technic launcher again. 6.) Click on Launcher Options in the top right of the screen. 7.) Click on the tab called Java Settings 8.) Click on the dropdown called Minecraft Java Version and select the option that says 1.8_151 64-Bit. 9.) Click the dropdown called Memory and select an option that's between 2 GB and 4 GB. Do not select an option higher than 4 GB!

Link to post
Share on other sites
  • 0
On 4/20/2018 at 7:31 PM, AetherPirate said:

This snipped from the Technic Discord will fix you:

 

You're running a 32bit Java version on a 64bit Operating System. This will prevent you from allocating more than 1GB of ram to the Technic launcher. In order to update to Java 8 64-Bit, please follow these instructions: 1.) Close the Technic launcher. It should not be running! 2.) Open http://java.com/en/download/manual.jsp in your web browser 3.) Download the version that has 64-bit in it for you operating system. If you're using Windows download the one that says Windows Offline (64-Bit). 4.) After the download is complete. You must install it. You can do so by double clicking on the icon to run it. 5.) After it installs start up the Technic launcher again. 6.) Click on Launcher Options in the top right of the screen. 7.) Click on the tab called Java Settings 8.) Click on the dropdown called Minecraft Java Version and select the option that says 1.8_151 64-Bit. 9.) Click the dropdown called Memory and select an option that's between 2 GB and 4 GB. Do not select an option higher than 4 GB!

dude. i F***ing love you for this! i have had so many issues with this 1 GB crap but it finally works now

 

Link to post
Share on other sites
  • 0
On 4/20/2018 at 7:31 PM, AetherPirate said:

This snipped from the Technic Discord will fix you:

 

You're running a 32bit Java version on a 64bit Operating System. This will prevent you from allocating more than 1GB of ram to the Technic launcher. In order to update to Java 8 64-Bit, please follow these instructions: 1.) Close the Technic launcher. It should not be running! 2.) Open http://java.com/en/download/manual.jsp in your web browser 3.) Download the version that has 64-bit in it for you operating system. If you're using Windows download the one that says Windows Offline (64-Bit). 4.) After the download is complete. You must install it. You can do so by double clicking on the icon to run it. 5.) After it installs start up the Technic launcher again. 6.) Click on Launcher Options in the top right of the screen. 7.) Click on the tab called Java Settings 8.) Click on the dropdown called Minecraft Java Version and select the option that says 1.8_151 64-Bit. 9.) Click the dropdown called Memory and select an option that's between 2 GB and 4 GB. Do not select an option higher than 4 GB!

Hey,

I saw your answer and yeah i hope you could help me.

I reinstalled the launcher downloadet the 64 bit version of java and so on.

So I have the problem that when i start thr launcher a file named hs_err_pid860 appears on my desktop and i cant do anything.

do you know a solution?

Greetings

Link to post
Share on other sites
  • 0
On 4/20/2018 at 6:31 PM, AetherPirate said:

This snipped from the Technic Discord will fix you:

 

You're running a 32bit Java version on a 64bit Operating System. This will prevent you from allocating more than 1GB of ram to the Technic launcher. In order to update to Java 8 64-Bit, please follow these instructions: 1.) Close the Technic launcher. It should not be running! 2.) Open http://java.com/en/download/manual.jsp in your web browser 3.) Download the version that has 64-bit in it for you operating system. If you're using Windows download the one that says Windows Offline (64-Bit). 4.) After the download is complete. You must install it. You can do so by double clicking on the icon to run it. 5.) After it installs start up the Technic launcher again. 6.) Click on Launcher Options in the top right of the screen. 7.) Click on the tab called Java Settings 8.) Click on the dropdown called Minecraft Java Version and select the option that says 1.8_151 64-Bit. 9.) Click the dropdown called Memory and select an option that's between 2 GB and 4 GB. Do not select an option higher than 4 GB!

This works!!! it has fixed my game and i can play without crashing constantly thank you!

 

Link to post
Share on other sites
  • 0
On 4/20/2018 at 7:31 PM, AetherPirate said:

This snipped from the Technic Discord will fix you:

 

You're running a 32bit Java version on a 64bit Operating System. This will prevent you from allocating more than 1GB of ram to the Technic launcher. In order to update to Java 8 64-Bit, please follow these instructions: 1.) Close the Technic launcher. It should not be running! 2.) Open http://java.com/en/download/manual.jsp in your web browser 3.) Download the version that has 64-bit in it for you operating system. If you're using Windows download the one that says Windows Offline (64-Bit). 4.) After the download is complete. You must install it. You can do so by double clicking on the icon to run it. 5.) After it installs start up the Technic launcher again. 6.) Click on Launcher Options in the top right of the screen. 7.) Click on the tab called Java Settings 8.) Click on the dropdown called Minecraft Java Version and select the option that says 1.8_151 64-Bit. 9.) Click the dropdown called Memory and select an option that's between 2 GB and 4 GB. Do not select an option higher than 4 GB!

Hey dude, it's 2020, Corona all over the place, my friends and me just wanna play minecrift and i was searching through guides and articles, tutorials etc. to fix the exact problem you just explained, and i just wanna say, im really thankfull for your explanation, i got it fixed, we can now play Tekkit in peace. THANK YOU! Legend!

Edited by FeyFey
Link to post
Share on other sites
  • 0

hi, i saw this and tried it out but it is still not working for me. I have a 64 bit system and i downloaded java for 64bit but it still doesnt seem to be picked up on the tekkit launcher. any ideas on as to why this is happening?

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Similar Content

    • By FokinLaserSights
      Ok so i got 16gb of ram. I set the launchers ram limit to 8gb. When i start the game the ram usage (as the task manager shows) is 2-3gb. After time it just gets higher and higher that the ram usage gets to like 12gb. And that causes discord to stop itself just to get more memory for the game
      And so i dont get why this happens
    • By CyberNinja98
      So I have the launcher options set so it can use 6GB-s of ram but whenever I try to play it caps out at 455MBs. I need some technical help with this
    • By Lazerhack
      When trying to play any modpack on the technic launcher, i have the options to choose anywhere from 1gb ram to 15gb ram, being that i have 16gb ram installed on my pc. The problem i run into is that if i choose any more than 6gb allocated, the modpacks wont load at all. the technic launcher will close as if it is starting the modpack then will immediately open back up without attempting to load the modpack, giving the error "Not enough memory installed to support this modpack" in the console. When i open my system properties it shows that i do indeed have 16gb ram installed. I've already tried uninstalling and reinstalling technic, each of the modpacks, java RTE, and even attempted replacing my RAM twice with 16gb Corsair Vengeance Pro with no luck. Any help would be much appreciated.
    • By NanoByte
      I can't allocate more than 1 GB of RAM to my technic launcer, and before you comment you need to know that I have a 64bit Win10 and 64 bit Java 8 latest version. I also have plenty of memory available (16 more precise) and a pretty nice pc, my only problem is that I can't load any pack because of the Ram restriction 
    • By Underscore
      I am attempting to launch the modpack, but every time I try, it tells me that I need 64 bit stuff, which I have installed, and it says "this modpack requires 2 GB Ram" and thinks I only have 1. I have almost 8 GBs of ram available on my computer, why won't it work?

×
×
  • Create New...