Jump to content

Am I an idiot or are the ME Fluid Level Emitters not working right?


Silmenume
 Share

Recommended Posts

Here we see the amount of Destabilized Redstone I have in store in the ME Network.

L6HdIaV.png

If I am reading this correct I have 32,000 mb of Destabilized Redstone.

 

Here are the settings in the Extra Cells Fluid Level Emitter GUI

c7WZA0D.png

The trigger amount is, if I understand this correctly, is 20,000 mb.  The monitored fluid is Destabilized Redstone.  The action is set so that a Redstone Signal is emitted when the ME storage system show LESS than 20,000 mb.  As shown in the first pic I have 32,000+ mb in storage.  By rights I should not be getting a Redstone signal becaue I am above the cut off value, yes?

 

But in this last pic we see that the emitter is giving off a Redstone signal.  I know this to be true because the export bus responds as if it receiving a Redstone signal.

iKXfJML.png

 

Am I misunderstanding something?  It would be good if I was because that would be easily corrected when someone here tells me where I am wrong!

 

HALP!!

 

Best,

 

Jay

 

Edit - oops!  I realized I made a mistake with the title line - I know its the Extra Cells mod!

Edited by Silmenume
Link to comment
Share on other sites

As AetherPirate said you need to have the emitter connected to an ME network that contains the fluid/item (standard emitter works the same way) you want to monitor. If it's not hooked to a network then it will just keep the signal active, which shouldn't hurt anything unless you're using the emitter to turn on a machine. I typically use them to switch export buses on/off but that's me. It doesn't have to be pointed at anything in order to function though, it just won't be sending a redstone signal to anything if it's not :)

Edited by Digdug83
Link to comment
Share on other sites

OK.  I am an idiot!

 

In ANY other direction the Fluid Level Emitter was attached to the Export Bus below.  But in the one direction I needed it, pointing down, it was not connected as you both pointed out.  I just assumed (and the bad joke applies) that since the FLE was connected in all 8 (as pointed out by HeatHunter below this value should be all 5) other directions it must be "considered connected" in the 9th (same mistake here - the correct phrase is "the 6th") (pointing down) direction.

 

Thanks for the heads up!

 

I got another problem that I'll be asking for help on in another thread!

 

Best,

 

Jay

 

edit - because as it turns out I am truly an idiot!  Corrections to the numerical values.

Edited by Silmenume
Link to comment
Share on other sites

OK.  I am an idiot!

 

In ANY other direction the Fluid Level Emitter was attached to the Export Bus below.  But in the one direction I needed it, pointing down, it was not connected as you both pointed out.  I just assumed (and the bad joke applies) that since the FLE was connected in all 8 other directions it must be "considered connected" in the 9th (pointing down) direction.

 

Thanks for the heads up!

 

I got another problem that I'll be asking for help on in another thread!

 

Best,

 

Jay

 

now you have to explain what directions you mean, as far as I know there are only 6 possible directions on a cube (of which minecraft consists)

 

Edit:

what you see in the fluid Terminal are rounded values (not sure if theres a tooltip on the fluid that tells you the exact value) on the cell itself, theres an exact value (works if you have formatted for one fluid per cell)

For the calculation, you're right (1B = 1000mB)

Edited by HeatHunter
Link to comment
Share on other sites

now you have to explain what directions you mean, as far as I know there are only 6 possible directions on a cube (of which minecraft consists)

You are correct sir.  There ARE only 6 possible directions, but as you will note above there are truly only 6 possible directions.  When one is tired and make mental calculations like - we start off with 3 dimensions and there are 2 directions per dimension and then in one's exhaustion do the calculation as 3^2 = 9 instead of the right way 3*2 = 6 we end up looking more like an idiot on a public forum!

 

I'll make the corrections in my post so as to not confuse others.

 

Thanks!

 

Best,

 

Jay

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...