Recommended Posts

So, Tekkit Classic, one of the most buggy but still popular modpacks out there, almost everyone knows that this pack will never be updated again, due to some of the major mods like RP2 being discontinued and EE2 completely redone. Which is fine, I don't have a problem with Pahimar restarting EE, its probably the best thing for it. But Tekkit Classic just worked as a modpack, if you excuse all the bugs and banned items.

As you can see from the title, I want Tekkit Classic to be updated, yes, right to 1.8 However, rather than it being 'updated' or even remaining as a modpack, I see it working incredibly well to turn this into a minecraft 1.8 plugin.

I personally have some exams coming up soon with school, so I will be getting busier within the next 2 months, however whats good about this is that once they are done I can focus more on bringing back Classic Tekkit for minecraft 1.8.

 

So, between me and some of my friends, we can host the server 24/7 fine, and sort out more or less everything that side, but we are missing at least a few staff but mainly the cost involved of hiring a professional developer to make this plugin.

 

We have no idea what its going to cost to get a developer to do this, but I have asked for some quotes so will find out soon and set a target! The developer will be the main cost, and after that should only be the monthly cost for a server host. Although I am going to use a dedicated computer until we have lag problems and/or we have the money for speedy internet hosts!

 

So let me know below if you can help out in any way (although it might be better to Skype me, we need some good builders, probably some staff, money, and any ideas you guys might have regarding changing features of items and adding new ones.

 

Feel free to add me on Skype, my Skype is ImaTimelord7, the one with the ImaTimelord7 Logo, I am on Skype almost everyday and my timezone is GMT+12.

 

I think that's everything! I cannot wait!

Share this post


Link to post
Share on other sites

Tekkit classic is impossible to recreate as a plugin as you cannot send anything like textures or models to the client. Also a good programmer is ~$60/hr

Well, it seems you know more than I do, however instead of saying "This won't work" and giving up, why don't we figure a way around it. This may not be my area of expertise, but if we have someone who knows how plugins work we can find ways around it. Since sending textures and models to the client cannot be done, lets think of other ways to achieve the same result. Are models another word for textures or do you mean something else like mob models?, correct me if I'm wrong. And for textures as far as I'm aware we can put every new block as a 'iron block' texture for example, but then have a 'custom server resource pack' for the textures. I'm pretty sure this works but again, correct me if I'm wrong.

Share this post


Link to post
Share on other sites

A few people have talked about re-creating EE2, but it seems nothing's come of it. If you're up for the challenge (think lots of Java) I'd recommend combining some of the existing open-source mods that each have part of EE2's functionality - AetherCraft has very full-featured transmutation, and EE3 and Reliquary each implement some of the trinkets in EE2. (I'd be wary of combining EE3 and AeC into one pack as-is, since both have transmutation of some sort - if their values differ, players will be able to exploit it by transmuting things back and forth infinitely.)

 

As for RedPower, you can probably go pretty far with BluePower, and for frames use >Remain in Motion.

 

Of course, none of this is likely to be available on Minecraft 1.8 until January or so, if you believe LexManos.

Share this post


Link to post
Share on other sites

Project red is also an option for RedPower.

True, but BluePower's tube system is much closer to RedPower's than PR's is. It's a matter of personal preference, TBH.

Share this post


Link to post
Share on other sites

For me Tekkit Classic's charm isn't so much just the mods, it was Minecraft 1.2.5 as well.  There were quite a lot of differences, some more subtle than others, which have simply been lost over the versions.  Things as simple as the way items landed when they fell, to actually staying where they landed rather than jumping elsewhere like in newer versions, to how they looked slowly floating up and down as billboard sprites, to not clumping into groups (I actually made a mod to stop this behavior in newer versions), the sound it made when you picked up several things at a time, etc.  To how physical collisions between mobs worked (including between players).  How mobs react to being hit (faster, more springy).  Lighting differences.  Terrain gen.  Subtle differences in sounds.  And surely many other things I'm forgetting to mention.  All of these subtleties combine to make a game that feels noticeably different to 1.8, and that's what gives it its nostalgic charm.

 

It's similar to how much different the game felt in the earlier alpha and beta stages compared to even 1.2.5, which are also fun to go back to occasionally.  Hell, 1.8 even feels different than 1.7.  Punch mobs and you'll see what I mean.  They broke something either with rabbits and/or the render timing changes.

 

But yeah, given the immense amount of work involved with trying to get all of the same mods into 1.8, it would seem far more feasible to get someone to focus on fixing the bugs with 1.2.5 and its mods.  And in the cases where modders might get upset about someone editing their work, you can implement modifications via reflection and class transformation, so that their content need not be redistributed.

If you just want similar mods in 1.8 though, there's also ProjectE which clones EE2.  Many of the others are already recreated, as mentioned in the thread.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Butters915
      I know that a few others have reported the problem, but I have not found any solution with me and my friend's world. When we started the world, there were almost no problems with falling through the world or lag or anything. As we progressed, though, this problem got worse and worse, starting with when I died I would fall though the world for 10-20 seconds, and I would spawn back in with little to no problems. This has now gotten to the point where I cannot play on the server because I would be falling through the world and into the void. Once I let it sit for a while and it took almost 30 mins for me to load in, but I was immediately killed, leaving me to fall through the world. We use hamachi to play together and both have pretty mediocre internet, both staying around 6 Mbps on an average day. Also, we both have around 6 gb of ram allocated to technic, so that is not the problem, as we have both tried lowering and increasing ram. Any help would be great!
    • By PrussianSM
      Here is the error log:
      [B#402] 2019/03/17 17:12:57 [INFO]  A detailed walkthrough of the error, its code path and all known details is as follows:
      [B#402] 2019/03/17 17:12:57 [INFO]  ---------------------------------------------------------------------------------------
      [B#402] 2019/03/17 17:12:57 [INFO]  
      [B#402] 2019/03/17 17:12:57 [INFO]  -- Head --
      [B#402] 2019/03/17 17:12:57 [INFO]  Thread: Client thread
      [B#402] 2019/03/17 17:12:57 [INFO]  Stacktrace:
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.createWindow(Display.java:306)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.create(Display.java:848)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.create(Display.java:757)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.create(Display.java:739)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.Minecraft.func_175609_am(Minecraft.java:645)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:458)
      [B#402] 2019/03/17 17:12:57 [INFO]  
      [B#402] 2019/03/17 17:12:57 [INFO]  -- Initialization --
      [B#402] 2019/03/17 17:12:57 [INFO]  Details:
      [B#402] 2019/03/17 17:12:57 [INFO]  Stacktrace:
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.main.Main.main(SourceFile:123)
      [B#402] 2019/03/17 17:12:57 [INFO]      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [B#402] 2019/03/17 17:12:57 [INFO]      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      [B#402] 2019/03/17 17:12:57 [INFO]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      [B#402] 2019/03/17 17:12:57 [INFO]      at java.lang.reflect.Method.invoke(Unknown Source)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
      [B#402] 2019/03/17 17:12:57 [INFO]  
      [B#402] 2019/03/17 17:12:57 [INFO]  -- System Details --
      [B#402] 2019/03/17 17:12:57 [INFO]  Details:
      [B#402] 2019/03/17 17:12:57 [INFO]      Minecraft Version: 1.12.2
      [B#402] 2019/03/17 17:12:57 [INFO]      Operating System: Windows 10 (amd64) version 10.0
      [B#402] 2019/03/17 17:12:57 [INFO]      Java Version: 1.8.0_201, Oracle Corporation
      [B#402] 2019/03/17 17:12:57 [INFO]      Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
      [B#402] 2019/03/17 17:12:57 [INFO]      Memory: 2664855160 bytes (2541 MB) / 3087007744 bytes (2944 MB) up to 3087007744 bytes (2944 MB)
      [B#402] 2019/03/17 17:12:57 [INFO]      JVM Flags: 3 total; -Xms3072m -Xmx3072m -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
      [B#402] 2019/03/17 17:12:57 [INFO]      IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
      [B#402] 2019/03/17 17:12:57 [INFO]      FML: 
      [B#402] 2019/03/17 17:12:57 [INFO]      Loaded coremods (and transformers): 
      [B#402] 2019/03/17 17:12:57 [INFO]      Launched Version: 1.12.2-forge1.12.2-14.23.5.2810
      [B#402] 2019/03/17 17:12:57 [INFO]      LWJGL: 2.9.4
      [B#402] 2019/03/17 17:12:57 [INFO]      OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
      [B#402] 2019/03/17 17:12:57 [INFO]      GL Caps: 
      [B#402] 2019/03/17 17:12:57 [INFO]      Using VBOs: Yes
      [B#402] 2019/03/17 17:12:57 [INFO]      Is Modded: Definitely; Client brand changed to 'fml,forge'
      [B#402] 2019/03/17 17:12:57 [INFO]      Type: Client (map_client.txt)
      [B#402] 2019/03/17 17:12:57 [INFO]      Resource Packs: 
      [B#402] 2019/03/17 17:12:57 [INFO]      Current Language: ~~ERROR~~ NullPointerException: null
      [B#402] 2019/03/17 17:12:57 [INFO]      Profiler Position: N/A (disabled)
      [B#402] 2019/03/17 17:12:57 [INFO]      CPU: <unknown>
      [B#402] 2019/03/17 17:12:57 [INFO]  [17:12:57] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:func_179870_a:553]: #@[email protected]# Game crashed! Crash report saved to: #@[email protected]# C:\Users\Administrator\AppData\Roaming\.technic\modpacks\1121-millenaire\crash-reports\crash-2019-03-17_17.12.57-client.txt
      [B#402] 2019/03/17 17:13:13 [INFO] Attempting to open C:\Users\Administrator\AppData\Roaming\.technic\logs
      [B#402] 2019/03/17 17:13:13 [INFO] Using file:/C:/Users/Administrator/AppData/Roaming/.technic/logs/
      [B#402] 2019/03/17 17:13:13 [INFO] Intermediary path file:///C:/Users/Administrator/AppData/Roaming/.technic/logs/
      I also have the latest x64 Java
    • By StarZ563
      This makes me salty https://pastebin.com/dsARRYtN
    • By StarZ563
      Why won't this Badmobs config work? https://pastebin.com/WfTJTm4z
    • By RobloxIsDead
      Read the title.
       I think it may have something to do with this line:
      liblwjgl64.so: failed to map segment from shared object   2019-03-01-2.log