Jump to content
  • 0
Sign in to follow this  
Cocanuta

Bugs found in Tekkit 2.0 **NOTICE 2.1 FIXES A LOT OF THESE BUGS**

Question

I couldn't see a main topic yet for bugs in the new release of Tekkit 2.0 so i thought i'd start a new one to share the bugs i've found and hopefully others will contribute. I'd like to point out now I can only imagine the work that goes into putting Tekkit together, this is just a bug list to help improve Tekkit, not a complaint.


  • [li]The computer from ComputerCraft does not seem to be present. I can see it in NEI but it does not allow me to create or spawn it.[/li]
    [li]Weapon Mod Entities not showing in-game.[/li]
    [li]The cannon and training dummy from WeaponMod do not display once placed.[/li]
    [li]Placing wireless redstone kills the world (as it kicks me from the game and I'm unable to log in to remove the item from the world).[/li]
    [li]Moving items around in your inventory in Creative Mode causes you to be kicked from the server. There is no known fix for this right now so please stop posting it.[/li]

ComputerCraft Fix thanks to DarthDavis.


  • [li]In your server mod files, find computercraft-server-1.21-bukkit-b1.1R4-r1.zip and extract the ComputerCraft folder so it's now ../mods/ComputerCraft/[/li]
    [li]Remove the computercraft-server-1.21-bukkit-b1.1R4-r1.zip file.[/li]
    [li]Run your server once to generate a new ComputerCraft config.[/li]
    [li]Go into your ComputerCraft settings file (../config/mod_ComputerCraft.cfg) and change the "diskItemID" to "4256".[/li]
    [li]Go into your forestry settings file (../config/forestry/base.conf) and change the "grower" ID from 208 to 255.[/li]

WeaponMod Fix thanks to DarthDavis.

RailCraft Tunnel Bore Fix thanks to teamplur.

If you are having issues with the Tunnel Bore in RailCraft follow this fix by teamplur.


  • [li]Open up the RailCraft config file.[/li]
    [li]Look for "net.gui.cart.bore".[/li]
    [li]Change this value from "120" to "124".[/li]
    [li]Do this for both server and client.[/li]

I'm not personally having this error, but if you are, teamplur's fix should sort you right out.

MOD NOTE: In lieu of an official bug thread we will use this one. Report bugs here!

BE THOROUGH. SAYING "IT IS BROKE" IS NOT GOOD ENOUGH AND YOU WILL GET HELEN KELLER'D FAST.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Re: Bugs found in Tekkit 2.0

since patch 1.2 blueprint wont stay recorded in the blueprint library when i restart the game

all blueprint recorded before patch are still there. anyone knows if its tekkit or bc bugging?

also anyone knows if the patch for blueprint to remember ic2 and rp2 is installed in tekkit?

because with the crash that corrupts my world that i get when i acces the teleport pipe GUI ( to many on same frequency) ,it freaks me out to not have my nice construction backed up

tks in advance

double checked. blueprint are still in technicssp/ buildcraft/blueprints folder. but there not showing in game. if i stay loged in i can change map and will still see it but not once i restart.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

somehow minecarts with chest in them can not be opened at all. i have no clue why this is happening and as far as i know there no errors

i have found out that this is not caused by the client because it works fine using tekkit in singleplayer

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

Just to note on these two.

The machinery noises have been like this since atleast last version. If you adjust your volume while near a running machine, it'll fix the sounds until the machine unloads from your client (go very far away or log out). There is also an option in the IC2.cfg file to turn off sounds.

Yes, rubber trees are rare, except when they aren't. Like your snow biome one, that's just part of worldgen. There is no code in place to guarantee you easy access to specific resources or biomes.

I've somewhat fixed this with some duct tape and string. Just use your OS sound control to turn down Tekkit.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

Seconding the exactly same error report.

[EDIT]Just got this one multiple times in a row with only 1 player on the server. It seems to always happen when a certain player joins the server. I think it might have more to do with the player being in a certain location though as we now have 3 players who are bugged. Maybe the said location has some blocks that when rendered cause bad things to happen.[/EDIT]

New info on this one. Before the corrupt chunk is formed the logs show a lot of "PlayerX moved wrongly" PlayerX being mainly the same person but also a few times someone else. Towards the end there's also a lot of "[iNFO] dropping item" but I don't know if either of those has anything to do with the bug. Someone suggested it has something to do with buildcraft pipes (connected to EE machines). Anyways, it has corrupted a chunk again and we will have to rollback the whole map or else anyone going to / spawning in the chunk will crash the whole server.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

HI,I found a bug,All I can say is that,Putting a second Item Teleportation Pipe on a alimented Quarry caused me to bug/crash,with a super fast screen of coding then all white screen.I close minecraft via Task Manager ,by termintating the processus,restart my client,and now I get the same bug I cant even stay logged long enough to see something,the black loading screen,then crash.My Quarry had 2 Teleportation pipe,one on the right,one on the top,conected to golden transportation pipe.Is there a way to temporaly desactivate a mod,so I can do something ?Or would it be unfixable(and need to make a new map?)

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

HI,I found a bug,All I can say is that,Putting a second Item Teleportation Pipe on a alimented Quarry caused me to bug/crash,with a super fast screen of coding then all white screen.I close minecraft via Task Manager ,by termintating the processus,restart my client,and now I get the same bug I cant even stay logged long enough to see something,the black loading screen,then crash.My Quarry had 2 Teleportation pipe,one on the right,one on the top,conected to golden transportation pipe.Is there a way to temporaly desactivate a mod,so I can do something ?Or would it be unfixable(and need to make a new map?)

use mcedit remove one of the offending pipes. or take the map to singleplayer mode and remove one of the pipes.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

i found a bug that will make the world unplayable

if you place a Energy Condenser and put a Wodden Transport Pipe on any side with an engine and start pumping items out of the Energy Condenser the server will crash and you cant play the map again without removing the Energy Condenser or the Wodden Transport Pipe with mcedit. This bug is only in SMP

2iodw8v8.png

17:36:19 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfEnergy Condenser

17:36:24 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfWooden Transport Pipe

17:36:28 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfRedstone Engine

17:36:31 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfRedstone Torch

17:37:10 [sCHWERWIEGEND] java.lang.NullPointerException

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.ItemStack.doMaterialsMatch(ItemStack.java:243)

17:37:10 [sCHWERWIEGEND]    at ee.TileCondenser.extractItem(TileCondenser.java:539)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.pipes.PipeItemsWood.checkExtract(PipeItemsWood.java:111)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.pipes.PipeItemsWood.doWork(PipeItemsWood.java:90)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.TileGenericPipe.doWork(TileGenericPipe.java:159)

17:37:10 [sCHWERWIEGEND]    at buildcraft.api.PowerProvider.update(PowerProvider.java:52)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.TileGenericPipe.l_(TileGenericPipe.java:108)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.World.tickEntities(World.java:1182)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:534)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

17:37:10 [sCHWERWIEGEND] Unexpected exceptionjava.lang.NullPointerException

    at net.minecraft.server.ItemStack.doMaterialsMatch(ItemStack.java:243)

    at ee.TileCondenser.extractItem(TileCondenser.java:539)

    at buildcraft.transport.pipes.PipeItemsWood.checkExtract(PipeItemsWood.java:111)

    at buildcraft.transport.pipes.PipeItemsWood.doWork(PipeItemsWood.java:90)

    at buildcraft.transport.TileGenericPipe.doWork(TileGenericPipe.java:159)



    at buildcraft.api.PowerProvider.update(PowerProvider.java:52)

    at buildcraft.transport.TileGenericPipe.l_(TileGenericPipe.java:108)

    at net.minecraft.server.World.tickEntities(World.java:1182)

    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:534)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

>

and ther is a bug with the advanced wodden transport pipe from Additional Pipes mod. if you try to open the menu (Right klick) you client will crash but i have this bug only in SMP.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

i found a bug that will make the world unplayable

if you place a Energy Condenser and put a Wodden Transport Pipe on any side with an engine and start pumping items out of the Energy Condenser the server will crash and you cant play the map again without removing the Energy Condenser or the Wodden Transport Pipe with mcedit. This bug is only in SMP

2iodw8v8.png

17:36:19 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfEnergy Condenser

17:36:24 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfWooden Transport Pipe

17:36:28 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfRedstone Engine

17:36:31 [iNFORMATION] Giving xXxMiniLinkxXx 64 of ºfRedstone Torch

17:37:10 [sCHWERWIEGEND] java.lang.NullPointerException

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.ItemStack.doMaterialsMatch(ItemStack.java:243)

17:37:10 [sCHWERWIEGEND]    at ee.TileCondenser.extractItem(TileCondenser.java:539)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.pipes.PipeItemsWood.checkExtract(PipeItemsWood.java:111)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.pipes.PipeItemsWood.doWork(PipeItemsWood.java:90)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.TileGenericPipe.doWork(TileGenericPipe.java:159)

17:37:10 [sCHWERWIEGEND]    at buildcraft.api.PowerProvider.update(PowerProvider.java:52)

17:37:10 [sCHWERWIEGEND]    at buildcraft.transport.TileGenericPipe.l_(TileGenericPipe.java:108)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.World.tickEntities(World.java:1182)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:534)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

17:37:10 [sCHWERWIEGEND]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

17:37:10 [sCHWERWIEGEND] Unexpected exceptionjava.lang.NullPointerException

    at net.minecraft.server.ItemStack.doMaterialsMatch(ItemStack.java:243)

    at ee.TileCondenser.extractItem(TileCondenser.java:539)

    at buildcraft.transport.pipes.PipeItemsWood.checkExtract(PipeItemsWood.java:111)

    at buildcraft.transport.pipes.PipeItemsWood.doWork(PipeItemsWood.java:90)

    at buildcraft.transport.TileGenericPipe.doWork(TileGenericPipe.java:159)



    at buildcraft.api.PowerProvider.update(PowerProvider.java:52)

    at buildcraft.transport.TileGenericPipe.l_(TileGenericPipe.java:108)

    at net.minecraft.server.World.tickEntities(World.java:1182)

    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:534)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

>

and ther is a bug with the advanced wodden transport pipe from Additional Pipes mod. if you try to open the menu (Right klick) you client will crash but i have this bug only in SMP.

If you are on a server thats running PEX, and modifyworld, this line should eliminate the problem (not testet or confirmed)

- -modifyworld.item.use.4301.on.block.130

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

Anyone found a bug with animals not breeding. We can give them wheat, and they get together (touch) but never produce any offspring. Won't work for any player on the server.

Another one, Forestry farm appears to be working for one player, another one build further away for another player does not seem to be working at all, any idea?

No error logs seem to generated on these though.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

The Floppy disk aint working as well (after you have correctly re-installed the computercraft mod)

i dont think there is any fix for this issue as of now.... (but it is likely an id problem and you will simply have to change some numbers and/or sacrifice another item id that you aint using)

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

Got a doozy--seen it peripherally referenced on this thread but in an incomplete manner.

Managed to kill my server by right-clicking on an Equivalent Exchange energy condensor while holding a buildcraft wrench.

Throws the server for a loop--stops everything. Throws an error like so:

11:22:27 [sEVERE] java.lang.NullPointerException

11:22:27 [sEVERE]    at net.minecraft.server.ItemStack.doMaterialsMatch(ItemStack.java:243)

11:22:27 [sEVERE]    at ee.TileCondenser.extractItem(TileCondenser.java:539)

11:22:27 [sEVERE]    at buildcraft.transport.pipes.PipeItemsWood.checkExtract(PipeItemsWood.java:111)

11:22:27 [sEVERE]    at buildcraft.transport.pipes.PipeItemsWood.doWork(PipeItemsWood.java:90)

11:22:27 [sEVERE]    at buildcraft.transport.TileGenericPipe.doWork(TileGenericPipe.java:159)

11:22:27 [sEVERE]    at buildcraft.api.PowerProvider.update(PowerProvider.java:52)

11:22:27 [sEVERE]    at buildcraft.transport.TileGenericPipe.l_(TileGenericPipe.java:108)

11:22:27 [sEVERE]    at net.minecraft.server.World.tickEntities(World.java:1182)

11:22:27 [sEVERE]    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:534)

11:22:27 [sEVERE]    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

11:22:27 [sEVERE]    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

11:22:27 [sEVERE] Unexpected exception

java.lang.NullPointerException

    at net.minecraft.server.ItemStack.doMaterialsMatch(ItemStack.java:243)

    at ee.TileCondenser.extractItem(TileCondenser.java:539)

    at buildcraft.transport.pipes.PipeItemsWood.checkExtract(PipeItemsWood.java:111)

    at buildcraft.transport.pipes.PipeItemsWood.doWork(PipeItemsWood.java:90)

    at buildcraft.transport.TileGenericPipe.doWork(TileGenericPipe.java:159)

    at buildcraft.api.PowerProvider.update(PowerProvider.java:52)

    at buildcraft.transport.TileGenericPipe.l_(TileGenericPipe.java:108)

    at net.minecraft.server.World.tickEntities(World.java:1182)

    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:534)

    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:441)

    at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)
Repeats this error every time the chunk loads--and completely stalls/stops the server.

Afterwards, server is still "running"--it will accept commands like 'help/stop/save-all' but it supplies no chunk data to users who attempt to connect.



Client throws this error:
[17:42:27] [sEVERE]	Exception in thread "main" 

[17:42:27] [sEVERE]	java.util.NoSuchElementException

[17:42:27] [sEVERE]		at java.util.Scanner.throwFor(Scanner.java:838)

[17:42:27] [sEVERE]		at java.util.Scanner.next(Scanner.java:1347)

[17:42:27] [sEVERE]		at org.spoutcraft.launcher.MD5Utils.parseChecksumFile(MD5Utils.java:80)

[17:42:27] [sEVERE]		at org.spoutcraft.launcher.MD5Utils.updateMD5Cache(MD5Utils.java:63)

[17:42:27] [sEVERE]		at org.spoutcraft.launcher.gui.LoginForm.loadLauncherData(LoginForm.java:347)

[17:42:27] [sEVERE]		at org.spoutcraft.launcher.gui.LoginForm.<init>(LoginForm.java:130)

[17:42:27] [sEVERE]		at org.spoutcraft.launcher.Main.main(Main.java:177)

Server can be restarted and runs fine--until somebody gets close enough that the (now flawed(?)) chunk is loaded, and then el crasho!

Tried running Chunkster (bad, I know) to resolve it, but to no avail.

Server is running on a headless Ubuntu Server Linux box, client is running a Lubuntu Linux computer.

Both server and client are running the latest (as of today) jar (et al) downloaded from technicpack.net, running in default configuration.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

If you are on a server thats running PEX, and modifyworld, this line should eliminate the problem (not testet or confirmed)

- -modifyworld.item.use.4301.on.block.130

can you explain to me this a little closer, I am not familiar with PEX

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

can you explain to me this a little closer, I am not familiar with PEX

PEX is a permissionsystem, like all other, based on nodes. It also comes with an addon called modifyworld. With modifyworld you can ban ppl from having items, you can dissable items to to interacted with (rightclick), dissable usage of 1 item onto a specific item, etc etc. Its pretty powerfull, and with it, you can controll almost anything.

One example of a node we are using in PEX with Modifyworld is

- -modifyworld.item.use.27526.on.block.*

This prevents all rightclicking with a philosoferstone in air. We did that becouse the stone has a longer range on transmuting block than a player can punch, so Towny (our main protectionsystem) wont stop that usage.

Beside item use, u have item have, item interact etc etc. I recommend it if you are aware of issues that you want to be able to stop, without ruin to much of the gameplay.

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

Got a doozy--seen it peripherally referenced on this thread but in an incomplete manner.

Managed to kill my server by right-clicking on an Equivalent Exchange energy condensor while holding a buildcraft wrench.

Throws the server for a loop--stops everything.

Tried to recreate the issue, wasnt able to. Did you try it again on a testmap or similar to see if it happend again?

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

There are two problems with Computercraft

1.It is installed incorrectly in the server. To fix this extract the computercraft-server-1.21-bukkit-b1.1R4-r1.zip then delete it the zip.

2.The block ids are wrong in this release too. To fix this change the grower block id from 208 to 255 in the forestry config. Now run the server to generate a new computercraft config and then change the disk id to 4256. This also fixes the problems with Forestry.

My server does nog make a new computercraft file :S or a new computercraft.zip in the /mods fols :/

Share this post


Link to post
Share on other sites
  • 0

Ohhh thank you. This helped so much! I've been trying to create the Forestry Automatic Tree Tap, and it just kept loading disk drives! This worked beautifully! HUZZAH!

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

Okay so I was suggest to post the bug here, Original Post: http://forums.technicpack.net/index.php/topic,2387.0.html

No matter what I do or try, and trust me, if you read the other topic, I have tried a lot, I cannot get the automatic farm making machines to work no matter how much power or what builds and engines and what kind of power I use. I have tried re-downloading and all the good stuff, dunno if this is a bug with the tekkit client or what. Just wanted to know if it is something I am actually doing wrong, which I don't think it is because I've tried things exactly like other people and it isn't working. It is only the automatic farm making machines not working like the Aroboretum and Peat Bog, etc. The logger and other harvester machines work perfect, and really fast with the factory of redstone engines I have set up attached to it. Any ideas please?

I have the same issue Farms and Arboretums start working, place a few blocks, maybe plant one tree or a couple of wheat seeds then nothing - for game days and days. Tried with several steam engines and no progress. Moved to a new locations 5+ times and same effect. Clears the space to place the trees / wheat then places a random number of blocks like it is going to work and then stops.

Share this post


Link to post
Share on other sites
  • 0

so basically, i'm having trouble here with the new 2.1.1 server on my mac, i have a startup program, but it doesn't make the right files, tell me what's wrong please.

>Failed to load mod from "mod_IC2AdvancedMachines.class"

>java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:172)

at net.minecraft.server.ModLoader.readFromModFolder(ModLoader.java:929)

at net.minecraft.server.ModLoader.init(ModLoader.java:683)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1357)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:102)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

21:20:52 [sEVERE] Unexpected exception

java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:172)

at net.minecraft.server.ModLoader.readFromModFolder(ModLoader.java:929)

at net.minecraft.server.ModLoader.init(ModLoader.java:683)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1357)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:102)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

>java.lang.RuntimeException: Exception occured in ModLoader

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1292)

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1297)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:193)

at net.minecraft.server.ModLoader.readFromModFolder(ModLoader.java:929)

at net.minecraft.server.ModLoader.init(ModLoader.java:683)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1357)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:102)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

Caused by: java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:172)

... 6 more

21:20:52 [sEVERE] Unexpected exception

java.lang.RuntimeException: Exception occured in ModLoader

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1292)

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1297)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:193)

at net.minecraft.server.ModLoader.readFromModFolder(ModLoader.java:929)

at net.minecraft.server.ModLoader.init(ModLoader.java:683)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1357)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:102)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

Caused by: java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:172)

... 6 more

>java.lang.RuntimeException: ModLoader has failed to initialize.

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1292)

at net.minecraft.server.ModLoader.init(ModLoader.java:715)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1357)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:102)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

Caused by: java.lang.RuntimeException: Exception occured in ModLoader

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1292)

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1297)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:193)

at net.minecraft.server.ModLoader.readFromModFolder(ModLoader.java:929)

at net.minecraft.server.ModLoader.init(ModLoader.java:683)

... 4 more

Caused by: java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:172)

... 6 more

21:20:52 [sEVERE] Unexpected exception

java.lang.RuntimeException: ModLoader has failed to initialize.

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1292)

at net.minecraft.server.ModLoader.init(ModLoader.java:715)

at net.minecraft.server.ModLoader.Init(ModLoader.java:1357)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:102)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:411)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:465)

Caused by: java.lang.RuntimeException: Exception occured in ModLoader

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1292)

at net.minecraft.server.ModLoader.ThrowException(ModLoader.java:1297)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:193)

at net.minecraft.server.ModLoader.readFromModFolder(ModLoader.java:929)

at net.minecraft.server.ModLoader.init(ModLoader.java:683)

... 4 more

Caused by: java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_IC2AdvancedMachines : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

at net.minecraft.server.ModLoader.addMod(ModLoader.java:172)

... 6 more

Share this post


Link to post
Share on other sites
  • 0

I'm running a server on windows7, tekkit 2.1.1 and whenever i try to connect to the server using my own machine i get an error saying

"Connection lost.

Internal Exception :java.lang.nullPointerException"

My friend can connect to the server fine, and it just randomly logged me off stating the error.

In server logs it says "end of stream"

Have tried reinstalling tekkit by deleting .techniclauncher

Have also reinstalled java to see if it fixed it but to no success.

Can post logs if needed.

Edit- Have just loaded up the world in sp and all the pipes that were in the world are invisible, could this be the cause. Tried to remove as many as possible, but they were invisible.

Edit2- okay i have narrowed it down to something in my inventory on the server(not pipes), swapped inventory files with another player on the server and can log on. Is there anyway to edit inventory files?

Final Edit- okay, found the problem. An item with the id 166 will cause a disconnect from the server and no chance of getting back on untill the item is removed from the inventory. Is it possible to somehow blacklist this item, ie not even letting people pick it up as you get disconnected before the command to get the item is executed?

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

A tentative fix to this is change the

net.gui.utility.feed.station=108

line in railcraft.cfg to

net.gui.utility.feed.station=125

I haven't noticed any other conflicts after doing this.

EDIT: This is necessary on both the server and client by the way

Thanks this helped with my Advanced wooden pipe Gui crashing my Client

Share this post


Link to post
Share on other sites
  • 0

Re: Bugs found in Tekkit 2.0

My world crashed when I tried pumping out blocks from an energy condenser, and when I load the world, it says 'saving chunks'. This was on SSP

Share this post


Link to post
Share on other sites
  • 0

Please lock this thread or something. Its like a honeypot to attract bad bug reports for every version, not just 2.0. If I post a properly formatted bug report and its been reported and buried in this thread somewhere with no version number, I apologize ahead of time.I am using 2.1.1 and I dont want to read the whole thread to sift between the 2.0 bugs that were fixed already, the 2.1 bugs that were fixed already, and valid still existing 2.1.1 bugs to read other peoples possible details about a bug I want to report and be as detailed and complete as possible. Just a suggestion.

Then again there may be value to allow people to just keep posting their "HalP meh Im Stuxxors" posts in this thread and totally ignoring it.

Edit--Its just hard to know what version the post talk about. Like the temporary fix with wood pipes mentioned few posts above this one, Is that for 2.1 and was implemented in 2.1.1 or is it still for 2.1.1 and I need to look into it and test it on my server to iron it out if it exists? please dont answer that, I am using it as an example to show waht I am talking about.

If this does not exist it makes people post a new thread where at least the version they are working with is posted somewhere.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...