Suolakeksi

BukkitForge - Getting Bukkit plugins on Tekkit Lite

Recommended Posts

You must allow flight in your server config and it might even not then work. On my tekkit classic server /fly doesn't work either so staff must either have swiftwolfs flying rings on or be i creative mode to fly.

HI, I am getting the same results that I did for Tekkit Classic on 1.2.5, flight is set to enabled in the properties, however when the user is in creative mode /fly works fine, disabling and enabling fly. Is it possible that there is some sort of check on the user's gamemode going on, so that flight will only work in creative mode? This would also happen in Tekkit Clasic.

Thanks

Share this post


Link to post
Share on other sites

Ok. Build #80 fixed PEX a little bit - if you're using ported it should load and some (if not all) plugins will obey its perms. You may also find lots of other little things are fixed.

Also, it changed world naming again.

The nether is now called 'The_nether'

The overworld 'Overworld', and the end 'End'.

First a big thx for your great work.

I start my Server with your new Version #80, then the server create the Folders, but there ist no world data. All Data's are in the old Folder World.

Must i copy the World-Data into the new Folders, or must i delete the folder World and create a new ?

Edit:

After installation, all my warps, my homepoint is not avaible, the message allways is: wrong world.

Share this post


Link to post
Share on other sites

First a big thx for your great work.

I start my Server with your new Version #80, then the server create the Folders, but there ist no world data. All Data's are in the old Folder World.

Must i copy the World-Data into the new Folders, or must i delete the folder World and create a new ?

Edit:

After installation, all my warps, my homepoint is not avaible, the message allways is: wrong world.

Use notepad++ and open all of the plugins/Essentials/userdata/ files eg. mine would be "nixsy.yml"

with all of your userdata files open in notepad++ go to 'search' then 'replace'.

In the search box look for

'0'


Make sure to include the '

and replace with


Overworld

Notepad++ has a feature to "Replace all in all opened documents" use this.

close and save each userdata file (this may take a while if you have quite a few)

This should fix /home for players.

Do the same for plugins/Essentials/warps/

This worked for me.

Share this post


Link to post
Share on other sites

just to contribute to this, Permissions bukkit works perfectly, so does simple prefix (small issue ingame but not a major, configs still works)

bugs i have to report is any teleport command kinda glitches out and teleports us around or below spawn

Share this post


Link to post
Share on other sites

I Just updated to the essentials plugin you just updated, and it doesn't work now, the commands are there they just don't work and you cant type in chat either. it comes up in the console with "essentials usermap not initialized(sorry about spelling)

Share this post


Link to post
Share on other sites

Build 81 & 82 are both causing several problems here.

With build #82 I'm getting the following :

2013-01-22 01:04:35 [sEVERE] [ForgeModLoader] Caught exception from factorization

java.lang.NoClassDefFoundError: qc

Getting the same error for several mods.

For mystcraft I'm getting :

Caught exception from Mystcraft

java.lang.NoClassDefFoundError: Could not initialize class yy

If you need full errors let me know but I'm guessing you've got enough with that?

Using build #81 I'm getting the following with iConomy :

2013-01-22 01:12:16 [sEVERE] [bukkitForge] Error occurred while enabling iConomy v7.0 (Is it up to date?)

java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/CraftServer

at com.iCo6.iConomy.onEnable(iConomy.java:102)

at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)

at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:431)

at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)

at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.loadPlugin(BukkitServer.java:936)

at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.enablePlugins(BukkitServer.java:920)

at keepcalm.mods.bukkit.bukkitAPI.BukkitServer.<init>(BukkitServer.java:256)

at keepcalm.mods.bukkit.asm.BukkitStarter.run(BukkitStarter.java:46)

at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.ClassNotFoundException: org.bukkit.craftbukkit.CraftServer

at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:44)

at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:39)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

... 9 more

Share this post


Link to post
Share on other sites

Pex Doesnt Work <- Essentials Group Manager Works. Update From me :)

Plugins that don't Work:

SimpleClans

Plugins that do Work

Towny Advanced [Latest One]

Will add more to the list still testing To help Suolakeksi out

How did you get Towny working? I've been trying to get it to work all day...

Share this post


Link to post
Share on other sites

sunday essentials works 100%, i disabled tnt, nuke, itnt, mininglaser and dynamite, now tekkit client is updated, and essentials is completely bypassed again :( :( :(

now its a grief fest again.........

and the plugins are some how doubled, into normal .jar and ported plugins........

whats goin on?

Share this post


Link to post
Share on other sites

Lockette not working.

Lockette is working for me mine, just quick protect is not working, and theres is a bug on doors allowing them to still open but not let you through.

Also to add to the list in the op , Command Book works, and Log Block partially works, it just only logs normal mc blocks and lb tool doesn't work so you have to use the command /lb lookup [area] also chest access logging doesn't appear to work.

edit.

More

Working -

iChat

uHome

Not Working

Teleport Suite

Share this post


Link to post
Share on other sites

Lockette is working for me mine, just quick protect is not working, and theres is a bug on doors allowing them to still open but not let you through.

Also to add to the list in the op , Command Book works, and Log Block partially works, it just only logs normal mc blocks and lb tool doesn't work so you have to use the command /lb lookup [area] also chest access logging doesn't appear to work.

edit.

More

Working -

iChat

uHome

Not Working

Teleport Suite

What version are you using? So do you sneak and right click on the chest and type [Private]?

Share this post


Link to post
Share on other sites

What version are you using? So do you sneak and right click on the chest and type [Private]?

I'm just using the latest version of lockette on bukkit dev and lattest bukkit forge.

You place the sign infont (or on any side) of the chest and type [private]

Share this post


Link to post
Share on other sites

Got mine to sortof work as well..

Essentials (Chat, Spawn, Core)

WorldEdit

WorldGuard

PEX

Can i request that someone take a look at a bukkit plugin called CommunityBridge. Its a plugin that whitelists based on a websites registration. And its currently bugging out for me. Mind you they have to login directly after the first attempt and they break the barrier. Please and Thank you!

Share this post


Link to post
Share on other sites

Got mine to sortof work as well..

Essentials (Chat, Spawn, Core)

WorldEdit

WorldGuard

PEX

Can i request that someone take a look at a bukkit plugin called CommunityBridge. Its a plugin that whitelists based on a websites registration. And its currently bugging out for me. Mind you they have to login directly after the first attempt and they break the barrier. Please and Thank you!

You have pex working with essentials? Have you tried it when you are not Op or admin?

Share this post


Link to post
Share on other sites

iConomy is working again with #89 but now I've got similar issues with signs and two plugins

Plugins causing errors :

- hyperconomy

- sign bank ( http://dev.bukkit.org/server-mods/sign-bank/)

When creating signs for either of these plugins both of them end up with !? on the signs instead of what was supposed to be on there and there are no errors in the console, any idea if this is a bukkitforge issue or plugin issue?

Share this post


Link to post
Share on other sites

Just make sure everything is up to date.

Forge is latest recommended,

BukkitForge up to 89

Essentials latest

WorldGuard latest

WorldEdit Latest

And dont forget to get his latest PEXv2 that keepcalm ported. http://files.electro-gaming.org/BukkitForge/

Noob error. Didn't delete the lib folder. Creeper disabling works well now.

Core protect ingame interface is not working at all now. And lockette isnt super. Just waiting on those til i can get my server running fresh.

Also WorldEdit Regen not working

Thanks Keepcalm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.