Jump to content

Hexxit discussion tread


FevolMine
 Share

Recommended Posts

I know right. The page on Technicpack.net is all I can find, and it doesn't say anything.

The Hexxit page on Technicpack.net lists what mods are in the pack and provides links to the mod's websites. Just check the bottom of the screen.

Link to comment
Share on other sites

Running a server for Hexxit, I've noticed that (at least in multiplayer) things are very unstable. I.e. the server crashes every few hours and there is a ton of lag even though I normally get none. Anyone else experiencing the same on multiplayer?

Link to comment
Share on other sites

Running a server for Hexxit, I've noticed that (at least in multiplayer) things are very unstable. I.e. the server crashes every few hours and there is a ton of lag even though I normally get none. Anyone else experiencing the same on multiplayer?

Yes. I also get these issues. (Hey! We have similar skins! :P)

It seems that there is very noticeable lag every now and then even with 6GB RAM allocated to my server. On top of this, I noticed that you get the crashing issue with the Turtle Boss from Chocolate what-have-you. These crashes are really rendering the modpack unplayable on multiplayer and I really don't get how they could of let this pass through... With as common as this happens. I understand they put a lot of work into this, but it seems to be a common issue thus far.

Link to comment
Share on other sites

Hidden

Running a server for Hexxit, I've noticed that (at least in multiplayer) things are very unstable. I.e. the server crashes every few hours and there is a ton of lag even though I normally get none. Anyone else experiencing the same on multiplayer?

Yes. I also get these issues. (Hey! We have similar skins! :P)

It seems that there is very noticeable lag every now and then even with 6GB RAM allocated to my server. On top of this, I noticed that you get the crashing issue with the Turtle Boss from Chocolate what-have-you. These crashes are really rendering the modpack unplayable on multiplayer and I really don't get how they could of let this pass through... With as common as this happens. I understand they put a lot of work into this, but it seems to be a common issue thus far.

Link to comment

We haven't run into any lag or crash issues on our Hexxit server so you'll understand that it's not something we just neglected to notice. There is something about your hardware or plugins that make it run different for you. That or it may be client side and not server. It's possible you're running out of memory. Make sure java is up to date if you're on a pc, and go to settings in the launcher and click "increase perm gen". Put your RAM allocation at 2 GB or so. And if that doesn't help, try other troubleshooting.

tl;dr actually try stuff before blaming us. If it's actually an issue on our end you can rest assured we will fix it. Until then, don't assume the cause and give up on a solution. That helps no one.

Link to comment
Share on other sites

We haven't run into any lag or crash issues on our Hexxit server so you'll understand that it's not something we just neglected to notice. There is something about your hardware or plugins that make it run different for you. That or it may be client side and not server. It's possible you're running out of memory. Make sure java is up to date if you're on a pc, and go to settings in the launcher and click "increase perm gen". Put your RAM allocation at 2 GB or so. And if that doesn't help, try other troubleshooting.

tl;dr actually try stuff before blaming us. If it's actually an issue on our end you can rest assured we will fix it. Until then, don't assume the cause and give up on a solution. That helps no one.

No extra plugins or mods, so it cannot be that. We've had multiple responses of this issue, so I instantly assume it's not hardware related as the chance more than 3 people have the same hardware configuration is very very unlikely. I have 6GB of RAM allocated to this server. It's not running out of memory and I know it. I've ran multiple instances and get the same response. I've tried multiple worlds. I've asked my friends to try the same things we did on our server in singleplayer and got similar responses. The only difference is that they can spawn him, the Turtle Boss, in but not do anything if he is in a dungeon/Castle.

I've actually TRIED stuff, before blaming you... And I'm not blaming anyone in specific. I'm not going to come in here and point fingers like some people do without first doing my own troubleshooting. I know how to run a server. The crash report specifically says these three lines(Not just them):

at chocolate.mods.BD.mobs.EntityTurtlePart.func_70097_a(EntityTurtlePart.java:37)

at net.minecraft.world.World.func_72866_a(World.java:2342)

at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:654)

First line says it's the Entity Turtle, tried finding a way to remove it, but could not.

Second line says Minecraft World, tried using multiple worlds in case that was the issue. Nope.

Third line says Minecraft Server, restarted the server several times, started fresh on both server files AND modpack files for both me and my users. Nothing.

Sorry if I sound like an ass, but I suppose that's how I'm getting my point across.

Link to comment
Share on other sites

No extra plugins or mods, so it cannot be that. We've had multiple responses of this issue, so I instantly assume it's not hardware related as the chance more than 3 people have the same hardware configuration is very very unlikely. I have 6GB of RAM allocated to this server. It's not running out of memory and I know it. I've ran multiple instances and get the same response. I've tried multiple worlds. I've asked my friends to try the same things we did on our server in singleplayer and got similar responses. The only difference is that they can spawn him, the Turtle Boss, in but not do anything if he is in a dungeon/Castle.

I've actually TRIED stuff, before blaming you... And I'm not blaming anyone in specific. I'm not going to come in here and point fingers like some people do without first doing my own troubleshooting. I know how to run a server. The crash report specifically says these three lines(Not just them):

at chocolate.mods.BD.mobs.EntityTurtlePart.func_70097_a(EntityTurtlePart.java:37)

at net.minecraft.world.World.func_72866_a(World.java:2342)

at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:654)

First line says it's the Entity Turtle, tried finding a way to remove it, but could not.

Second line says Minecraft World, tried using multiple worlds in case that was the issue. Nope.

Third line says Minecraft Server, restarted the server several times, started fresh on both server files AND modpack files for both me and my users. Nothing.

Sorry if I sound like an ass, but I suppose that's how I'm getting my point across.

Hi,

You'll notice that only a couple have reported this issue in these forums. Turtles are very rare spawns- I've never seen one. So while the turtle crashes are very common on your map, which has a turtle, it is nonexistant on our map, which has no turtle. I've reported the issue to chocolatin, so you haven't been forgotten.

As for the lag issues, based on feedback in this forum, this appears to be an MCPC+ thing. We don't support the mod and we certainly don't test using it. We don't do either of those things specifically because mod support is glitchy/not always functional. In this case, until we figure out where the friction between BD and MCPC is, I would consider using Forge Essentials. If you're playing with people you know, I'd consider using nothing even.

Link to comment
Share on other sites

Is there anything we can do to disable turtles alone? Looked in the config which didn't help much, but me and a few friends cannot load the server without starting a new world or deleting character files.

Hi, you can get rid of swampTurtleCave.prop to stop the turtle cave from spawning, or inside that file change the boss to a different boss than the turtle boss. I got the impression from some that there were turtles other than the boss, and that there were other places the turtles spawn. You can always give it a try, though.

Link to comment
Share on other sites

Hi,

You'll notice that only a couple have reported this issue in these forums. Turtles are very rare spawns- I've never seen one. So while the turtle crashes are very common on your map, which has a turtle, it is nonexistant on our map, which has no turtle. I've reported the issue to chocolatin, so you haven't been forgotten.

As for the lag issues, based on feedback in this forum, this appears to be an MCPC+ thing. We don't support the mod and we certainly don't test using it. We don't do either of those things specifically because mod support is glitchy/not always functional. In this case, until we figure out where the friction between BD and MCPC is, I would consider using Forge Essentials. If you're playing with people you know, I'd consider using nothing even.

I do not use MCPC. The lag is not a major issue on my server specifically, but if I do it's only because of the modpack's awesomeness I assure you. :)

As for your comment/solution below, I thought about removing that file, but I would have to start a new world and we have an amazing seed, but alas if that is what we must do to try to temporary fix the solution. I'll try that out and tell you what I come up with. Cheers! :)

Link to comment
Share on other sites

I do not use MCPC. The lag is not a major issue on my server specifically, but if I do it's only because of the modpack's awesomeness I assure you. :)

As for your comment/solution below, I thought about removing that file, but I would have to start a new world and we have an amazing seed, but alas if that is what we must do to try to temporary fix the solution. I'll try that out and tell you what I come up with. Cheers! :)

One thing you could try to do is have only one player log in and immediately switch to creative. Hopefully it won't crash (because it won't try to attack you) and you can fly around and deal with the issue from there. Let me know what happens.

Link to comment
Share on other sites

I do not use MCPC. The lag is not a major issue on my server specifically, but if I do it's only because of the modpack's awesomeness I assure you. :)

As for your comment/solution below, I thought about removing that file, but I would have to start a new world and we have an amazing seed, but alas if that is what we must do to try to temporary fix the solution. I'll try that out and tell you what I come up with. Cheers! :)

You can press F3, i believe, and view your seed.

Link to comment
Share on other sites

Well I played single player for about 30 minutes last night and encountered what behaved like a server lag spike. Was chopping a tree and nothing happening after block was destroyed, ran off and rubber banded back. So something is going on, was in survival and no plugins etc. All other Technic packs are fine.

Link to comment
Share on other sites

  • 4 months later...

I can't play multiplayer on Hexxit, starting a few days ago. I get an error message that says "Forge Mod Loader has found ID Mismatches," then lists ID numbers for Legend Gear mod (i.e. ID 6035 from Mod LegendGear is missing). I own a Mac OS X with Mountain Lion. Please help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...