GenPage

Administrators
  • Content Count

    128
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by GenPage

  1. The utility is now available through Python Packing system 'pip'. pip install TechnicServerCore --pre the "--pre" is because I have not released a stable build yet.  This is platform indepedent and should be able to run from any system with Python and pip https://pypi.python.org/pypi/TechnicServerCore
  2. Okay here is what you do: Next start the Java Preferences app from /Applications/Utilities drag Java 7 to the top of the list like in the screenshot. This will make locally run Java applications use Java 7 instead of Java 6. You can uncheck the Java 6 options if you do not want them to be allowed to run. This section is for the Java runtime for local applications, and has nothing to do with the web plugin.  
  3. What version of Mac OS X are you running?   and have you tired these steps: http://java.com/en/download/help/mac_uninstall_java.xml
  4. With the next upgrade in Minecraft and Minecraft mods progressing into 1.7.2, more and more mods are dropping support for Java 6.   Before upgrading Java make sure your computer supports it by checking here: http://java.com/en/download/help/sysreq.xml   Unlike Windows and Mac, major Linux distributions such as Ubuntu, Fedora or Red Hat Enterprise Linux offer OpenJDK as their default Java SE implementation.   32-bit vs 64-bit and what does it mean?   Long story short, you cannot run a computer with more memory than 4GB if you use 32-bit.   Technic recommends using 64-bit versions of Java (if supported). This allows more memory for Minecraft to use.    Questions or how to check your system can be found here:   Windows users: http://windows.microsoft.com/en-us/windows/32-bit-and-64-bit-windows   Mac users: http://support.apple.com/kb/ht3696    Linux users: http://stackoverflow.com/a/246014   If you are needing to upgrade your Java install, grab a copy from here http://java.com/en/download/manual.jsp and follow these guides:   Windows Users:   Check what version of Java your running by going here: http://java.com/en/download/uninstallapplet.jsp   Or checking your installed programs by going to: Control Panel -> Programs and Features   and following this guide: http://java.com/en/download/help/windows_offline_download.xml   Mac Users:   You have special requirements for installing/uninstalling Java on your computers   Please read CLOSELY here: http://java.com/en/download/faq/java_mac.xml   If you cannot uninstall Java 6, install Java 7 and then follow thses steps:   Next start the Java Preferences app from /Applications/Utilities Drag Java 7 to the top of the list like in the screenshot. This will make locally run Java applications use Java 7 instead of Java 6. You can uncheck the Java 6 options if you do not want them to be allowed to run. This section is for the Java runtime for local applications, and has nothing to do with the web plugin.     Linux Users:   Ubuntu and Fedora users: http://openjdk.java.net/install/   Red Hat, SUSE, Oracle, Oracle Enterprise, SLES users: http://java.com/en/download/help/linux_install.xml After you have installed Java 7, check to make sure it is installed here: http://java.com/en/download/installed.jsp   Hope this helps clear things up!   EDIT: Add Mac instructions.
  5. Currently, this only works with Technic Modpacks. However, I do wish to implement this with Platform/Solder. I started this project with that frame in mind. This will require changes to Solder which I have not had time to look into.
  6. Hey guys,   I've been working on a little project to make updating Technic Modpack Servers a little easier.    https://github.com/GenPage/ServerCore   This will allow server owners to directly download or "install" (unzip) modpacks to a specified directory on their servers.   Its currently in a beta state. I thought now would be a good time to release it and get some feedback on it.   Here are some examples of the program: Displaying Pack Info: Downloading all packs (default recommended builds) Downloading a specific pack Downloading latest build of a specific pack Downloading a specific version of a pack Checks if build exists in the list Checks if the modpack is still available Let me know what you think! If you have any issues with the program, please post them here: https://github.com/GenPage/ServerCore/issues
  7. Correct.   We appreciate the community trying to help us out in anyway. That being said this is not official or supported by us. Any indication that this is malicious/harmful will result in the removal of the topic and a ban.
  8.  While passing arguments works for -Dfml tag you need to append a new key:value pair for javaArguments
  9.   That is correct. The launcher uses java and is not a native linux program. 
  10. Hey guys,   I am sorry to hear you guys got hacked and your modpack deleted. This is a good example of using secure unique passwords for different accounts.   Bad news: @freakachu is right. It is impossible to retrieve stats/"+1" data. Your modpack was deleted. The data is gone. Zapped.   Good news: With the coming release of the new Platform, ranking/statistics will be radically changing. The stats for packs will be reset to adopt this new system. So in theory everyone will get a fresh new start with the new system. RIP "+1"s.   I'm sure you'll get your following back if you have dedicated players. If you guys have any questions or concerns, feel free to PM me.   -Gen
  11. You'll have better luck posting in Platform Pagoda: http://forums.technicpack.net/forum/65-platform-pagoda/
  12. It does not because at that point it is no longer our modpack but instead a custom modpack. We only support what you download from us.
  13. Use the links in my signature to post issues with the Technic Launcher.
  14. This is actually a viable fix. I have successfully tested this. Thanks for sharing! I tried scouring the web for something like this but it looks like I didnt look hard enough. 
  15. You need to post logs. Click on the Cog-wheel near the red X in the upper right. Then click on the logs button and post the latest log to a paste site like (http://pastebin.com or http://paste.ubuntu.com)
  16.   Canges dropbox made to the links now broke this. See: '?do=embed' frameborder='0' data-embedContent>>
  17. It has been reported on the Tracker that Dropbox recently made a change to their direct download links that breaks the Platform/Launcher link.   Tracker report: http://forums.technicpack.net/tracker/issue-2309-modpack-download-link-length/   New Dropbox Link: https://www.dropbox.com/meta_dl/eyJzdWJfcGF0aCI6ICIiLCAidGVzdF9saW5rIjogZmFsc2UsICJzZXJ2ZXIiOiAiZGwuZHJvcGJveHVzZXJjb250ZW50LmNvbSIsICJpdGVtX2lkIjogbnVsbCwgImlzX2RpciI6IGZhbHNlLCAidGtleSI6ICI3ejQ5Y20wNjdmbTFpcDQifQ/AALEAZwB_ipxYVobUzUgESgRP2H92s9cKZVaI2z-xEIauQ?dl=1 What the Technic Platform saves: https://www.dropbox.com/meta_dl/eyJzdWJfcGF0aCI6ICIiLCAidGVzdF9saW5rIjogZmFsc2UsICJzZXJ2ZXIiOiAiZGwuZHJvcGJveHVzZXJjb250ZW50LmNvbSIsICJpdGVtX2lkIjogbnVsbCwgImlzX2RpciI6IGZhbHNlLCAidGtleSI6ICI3ejQ5Y20wNjdmbTFpcDQifQ/AALEAZwB_ipxYVobUzUgESgRP2H92s9cKZVaI2z- This is due to the standard length of characters a normal test field/string saves (255 characters).   Since the new dropbox links are longer than 255 characters, it cuts off the rest of the new link.   We are working to fix this issue. Expect a hot fix within the next day or so.    Edit: http://copy.com has been suggested as an alternative.
  18.   You are not going to get any help with that kind of attitude
  19. This is a very common occurrence. To tell if its really frozen or not, you just leave the console open. That is a better indicator 
  20. Looks like the link is bad if you try it yourself.    Contact the modpack author.
  21. The latest vanilla version the launcher supports at this point is 1.7.5   Hence why you cannot connect to a 1.7.8 server. 
  22. There is a cog wheel in the bottom left corner of the modpack tile when selected in the launcher.    If you click on it it will present you with modpack options.    Select "Manually select a build" and you can choose any build of the modpack. This will allow you to choose an earlier build/update.   Cheers
  23. Yes it is quite possible.   try setting your config for blockCable to 4005   you will have to do some digging for the other issue with the missing id 3473. (Guessing this is IC2)