Jump to content

Pulverizer will not power up


Recommended Posts

I decided that I would give the new tekkit a try. I would always play classic because that was what I knew. I ran into problems when I tried to power  pulverizer with a sterling engine. The engine would not even connect but i have seen videos of them connecting. How to I power the pulverizer early game?

Link to comment
Share on other sites

The pulverizer in Tekkit 1.2.9e is from "Thermal Expansion 3" mod.

This mod is using RF (redstone flux) as power. The Stirling Engine is from Buildcraft and is producing MJ (and not RF).


In order to power thermal expansion blocks/machines you need to produce RF and that is (at the beginning at least) achieved by using dynamos. There are other means to do so, however, I am not getting into that.

RF is automatically converted into MJ once you connect a machine to the power grid using redstone or lead stone conduits. However, MJ can not converted to RF, however.

Link to comment
Share on other sites

What Roversword said, and I'll add that everything in Tekkit now produces and use RFs, except BuildCraft. Don't use BC' engines and transfer power with TE's conduits or MFR's Rednet Energy Cables (these are basically TE's redstone energy conduits coupled with a rednet cable). My advice is to just try stuff out in creative, and search the web for the mods' wikis or forum posts, you'll learn things you would have never found out playing

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...