Jump to content

Let's test Tekkit 1.1.5 (RC)!


CanVox
 Share

Recommended Posts

Hey, everyone,

I've just promoted Tekkit 1.1.5 to Latest. There are a ton of key mod updates, the update to Minecraft 1.5.2, along with several new mods! We've got Project Bench, a direct drop-in replacement for the RP2 project bench, a couple new generators, Logistics Pipes, and Simple Power Storage, by Technic's sct! SPS adds a "Makeshift Energy Cell" which can be used as an early-game alternative to the Redstone Energy Cell!

If you're interested in helping test, back up your worlds (SSP or server) and set your launcher up to use the "Latest" build, or manually select version 1.1.5. Play with us and report issues in this thread!

This is a clean slate, so even if you've already reported an issue elsewhere (including the 1.1.1-4 threads), if it's present in 1.1.5, be sure to report it in this thread.

The 1.1.5 server can be downloaded here:http://mirror.technicpack.net/Technic/servers/tekkitmain/Tekkit_Server_v1.1.5.zip

Changelog for Tekkit 1.1.5- this is a list of all changes since 1.0.6:

- Update Forge to build 734.

- Removed the Forge transparency fix (it was too memory-heavy to have as a default in Tekkit)

- Some redundant APIs were removed from the jars of the following mods, in order to reduce PermGen size: MFFS, MineFactory Reloaded, Atomic Science, and Modular Powersuits.

- Atomic Science has been tampered with using a hex editor to fix the thermometer and hazmat recipes.

- Modular Powersuits' glow effect was disabled by default

- Added Project Bench version 1.7.5

- Added Atomic Science version 0.5.3.51

- Added MFFS version 3.0.2.124

- Added Open Peripheral version 0.1.5

- Added Buildcraft: Logistic Pipes version 0.7.3.6

- Added Simple Power Storage version 1.0.10

- Equivalent Exchange 3 version pre1h has had a crash bug removed

- Balkon's Weapon Mod updated to version 1.12

- bspkrsCore updated to version 2.07

- Buildcraft updated to version 3.5.3

- Chicken Chunks updated to version 1.3.2.12

- Code Chicken Core updated to version 0.8.7

- Computer Craft updated to version 1.53

- CoFH Core updated to version 1.5.2.4

- Custom LAN Ports updated to version 1.5.2

- Dimensional Anchors updated to version 55.0.1

- Equivalent Exchange 3 updated to version pre1h

- Ender Storage updated to version 1.4.2.12

- Immibis Core updated to version 55.1.2

- Iron Chests updated to version 5.2.6.412

- MineFactory Reloaded updated to version 2.6.2.924

- Mystcraft updated to version 0.10.4.00

- Not Enough Items updated to version 1.5.2.28

- Nether Ores updated to version 2.1.5.75

- Omni Tools updated to version 3.1.5.0

- OpenCCSensors updated to version 1.5.2.0

- PowerCrystals Core updated to version 1.1.6.107

- Rei's Minimap updated to version 3.3_06

- Thermal Expansion updated to version 2.4.4.1

- Applied Energistics updated to version 10.n

- Steve's Carts updated to version 2.0.0.a117

- Dimensional Doors updated to version 1.3.6.73

- Modular Powersuits updated to version 0.7.0.534

- MPS Addons updated to version 0.2.3.144

- Immibis Microblocks updated to version 55.0.1

- Backpacks updated to version 1.9.11

- Treecapitator updated to version 1.5.2.r01

- Trade Booth updated to version 0.4

- Buildcraft: Additional Pipes updated to version 2.3.0

- Galacticraft updated to version a0.1.35.309

- NEI Plugins updated to version 1.0.9.3

Link to comment
Share on other sites

  • Replies 289
  • Created
  • Last Reply

Top Posters In This Topic

Okay, guys, if you've downloaded the 1.1.5 server before seeing this post, you might want to go into your server's config/cofh/World.cfg and make sure retroactive ore gen is set to true. I've fixed it in the live server, but the originally-uploaded one had it set to false. :\

Things fixed in this RC:

- MPS's glow is now set to OFF by default. You can reactivate it in the config. This was causing FPS issues for some.

- The Forge transparency fix has been removed- it was taking up a few hundred megs of RAM which isn't a lot for some of us, but for people who play with the default memory settings, it's problematic.

- A brand new version of MCPC+ went live this afternoon that is confirmed to fix the galacticraft dupe bug. I highly recommend you use that if you use MCPC+.

Link to comment
Share on other sites

I have found another issue.

When an assembly table completes an item and is adjacent to a thermal expansion machine with the input side facing the assembly table as shown in screen shot the server crashes with the following crash report

Screenshot: http://gyazo.com/5fd119bb71ac5045071af2944646ec89

Crash Log: http://pastebin.com/XgtKXvJS

Same thing happened to me on Recommended 1.0.6 - I don't remember the exact configuration, I just remember having Thermal Expansion machine beside the Assembly table and it accidentally the entire server.

Link to comment
Share on other sites

okay, I'm sorry to say that, but theres an incompatibility bug with the autocrafting bench and advaned wooden pipe:

you cant extract the product with the advanced wooden pipes. it works with normal wooden pipes. It doesnt work on ALL sides aswell, see screenshots. Tested also above and under, but that would have messed up the overview in the screenshots:

https://www.dropbox.com/s/24bcipy81gbi73m/autocraftingbench_adv.woodenpipe_bug_1.jpg

https://www.dropbox.com/s/h758b3kthi5yqpt/autocraftingbench_adv.woodenpipe_bug_2.jpg

https://www.dropbox.com/s/2lrg3a541ocwsye/autocraftingbench_adv.woodenpipe_bug_3.jpg

I'm away the next days, so dont wait for my reply ;) just try it on your machine and see if it doesn't work there aswell ;)

Thanks so long!

Link to comment
Share on other sites

well i do not know about everything else but one thing I am glad for is that the oxygen sealers finally work. However the server you provided in the link does not work it game me an error with the CodeChickenCore mod which i fixed and after that it could not find a download for the rest to support minecraft 1.5.2 so i guess i have to wait xD

Link to comment
Share on other sites

well i do not know about everything else but one thing I am glad for is that the oxygen sealers finally work. However the server you provided in the link does not work it game me an error with the CodeChickenCore mod which i fixed and after that it could not find a download for the rest to support minecraft 1.5.2 so i guess i have to wait xD

Wow this is really useful information I can totally act on.

okay, I'm sorry to say that, but theres an incompatibility bug with the autocrafting bench and advaned wooden pipe:

you cant extract the product with the advanced wooden pipes. it works with normal wooden pipes. It doesnt work on ALL sides aswell, see screenshots. Tested also above and under, but that would have messed up the overview in the screenshots:

https://www.dropbox.com/s/24bcipy81gbi73m/autocraftingbench_adv.woodenpipe_bug_1.jpg

https://www.dropbox.com/s/h758b3kthi5yqpt/autocraftingbench_adv.woodenpipe_bug_2.jpg

https://www.dropbox.com/s/2lrg3a541ocwsye/autocraftingbench_adv.woodenpipe_bug_3.jpg

I'm away the next days, so dont wait for my reply ;) just try it on your machine and see if it doesn't work there aswell ;)

Thanks so long!

That's because you can only extract completed product from the top of the autocrafter.

Link to comment
Share on other sites

Came back after leaving a large MFFS shield up to find the server completely unresponsive and console completely empty.

Full server restart got the console back and the following errors were spammed in console upon startup.

http://pastebin.com/PystgCbC

EDIT:

Managed to log in, delete the MFFS blocks, and rebooted.

Console was free of errors.

Server was free of errors (far as I could tell) until the chunk holding the MFFS blocks was loaded.

Link to comment
Share on other sites

Ok, tried the newest release. In single player, the game loaded MUCH faster then before. Took only about 1/3 the time to load past the Majong screen compaired to even 1.1.1 Created a creative superflat map, the map rendered a bit faster as well. Game loaded just fine, no issues what so ever. Let my computer catch up for a bit and it looked smooth as can be, until...

Gave the map time to fully render(older computer, can be a little slow sometimes) and everything seemed fine. Had nothing created yet so it was a fresh virgin landscape. But, there was no sound at all. Also, I did notice there was a lag tick, less then half a second, when I was moving around. Turning on the info options(F3 button) showed that while I was standing still there were 0 Chunk updates, but whenever I moved, I would get spikes of over 100 Chunk updates and my frame rate would drop to 10 fps for a fraction of a second. I have render set to normal so there can't be more then that many chunks loaded. With other mod packs it rarely goes above teens, until I have machines built. Not sure whats going on with this.

Link to comment
Share on other sites

Ok, tried the newest release. In single player, the game loaded MUCH faster then before. Took only about 1/3 the time to load past the Majong screen compaired to even 1.1.1 Created a creative superflat map, the map rendered a bit faster as well. Game loaded just fine, no issues what so ever. Let my computer catch up for a bit and it looked smooth as can be, until...

Gave the map time to fully render(older computer, can be a little slow sometimes) and everything seemed fine. Had nothing created yet so it was a fresh virgin landscape. But, there was no sound at all. Also, I did notice there was a lag tick, less then half a second, when I was moving around. Turning on the info options(F3 button) showed that while I was standing still there were 0 Chunk updates, but whenever I moved, I would get spikes of over 100 Chunk updates and my frame rate would drop to 10 fps for a fraction of a second. I have render set to normal so there can't be more then that many chunks loaded. With other mod packs it rarely goes above teens, until I have machines built. Not sure whats going on with this.

That does sound kinda weird- with the no sounds working, that's unfortunately out of our control. Minecraft downloads sounds during gameplay (for some reason) and we don't have control over it. Sometimes it fails and you end up with no sounds, and there's not much we can do on our end.

Link to comment
Share on other sites

Alright, thats good to know, about the sound. Any ideas on the oddly chunk updates? Or is that actually normal for tekkit?

Further playing around in the same map is giving me quite good results actually. Other then the lag ticks from chunk updates. In fact, the resource use hasn't gone above 56% memory use, and I only have about 1Gig allocated to Minecraft. 1.1.1 was sitting at at least 75% at this point.

thing to note: Ender tanks have twisted tops. Where the three colored blocks are placed, and where you have to click to interact with them are in different spots. So the (strike box?) you place the color on is turned 90 degrees clockwise from where the block actually is on the ender tank.

Link to comment
Share on other sites

I teleported to a unexplored section of my world and I am unable to find the Uraninite ore. I looked in the Cofh config and found the section responsible to generate this ore in the world. I notice the block id was different from what was showing up in NEI so i went and changed it. I also have RetroGen enabled to force generate the new ore in existing chunks.

custom {

####################

# uranite

####################

uranite {

I:BlockId=1402

I:BlockMeta=0

I:ClusterSize=3

I:MaxY=25

I:MinY=1

I:NumClusters=9

B:RetroGen=true

Even with the old block id and new block id the Uraninite ore is not generating at all.

Is this a bug or am I just doing something wrong?

Link to comment
Share on other sites

Hey, can't wait to try this out. I have a very new computer, i7, GTX660, 16GB RAM. However when running Tekkit on Far Render Distance after a little bit of time, the game will usually crash, and I am informed by Windows that Java has stopped running, this doesn't seem happen on Normal Render Distance. With the changes made in this update it may stop this from happening. Although it seems a little strange given that my computer should have no issues handling Tekkit on Far Render Distance. I am allocating usually between 12 to 14 GB of RAM in the launcher in case anyone is wondering that.

Anyway, I'll let you guys know if this update fixes this issue.

Link to comment
Share on other sites

You need to be running 64 bit java for it to not crash.

Uninstall all java and reinstall a 64 bit version.

Then the launcher should start in 64 bit mode, mine did, but I already added the java64 directory to my window path variable for other reasons, so I am not sure if that's required...You can find information on the web about this. Don't ask in this development thread.

Link to comment
Share on other sites

Soooo...did someone give all the skeletons enchanted bows or something? It seems like they're all rapid-fire.

That's vanilla minecraft. IIRC, the closer you get to some skeletons, the faster they fire.

Link to comment
Share on other sites

Downloaded the server. Files from files.minecraftforge.net couldn't download since the website seems to be down. Could the files be moved possibly or do I just wait for the website to re-surface?

Loving the update on singleplayer! :D

Scratch that^^^

minecraftforge.net back up

Link to comment
Share on other sites

Hey, can't wait to try this out. I have a very new computer, i7, GTX660, 16GB RAM. However when running Tekkit on Far Render Distance after a little bit of time, the game will usually crash, and I am informed by Windows that Java has stopped running, this doesn't seem happen on Normal Render Distance. With the changes made in this update it may stop this from happening. Although it seems a little strange given that my computer should have no issues handling Tekkit on Far Render Distance. I am allocating usually between 12 to 14 GB of RAM in the launcher in case anyone is wondering that.

Anyway, I'll let you guys know if this update fixes this issue.

Give it 1-2GB of RAM. There is no need to give it so much.

Programs won't work at all if they allocate too little RAM, and they don't get any faster if they allocate too much.
Link to comment
Share on other sites

Tin Decoration Blocks are uncraftable in Tekkit 1.1.5.

Try putting the stone in the middle space and the tin to the right. I wasn't able to craft the deco block the way you demonstrated either, but if you follow the recipe shown in the NEI it works.

Link to comment
Share on other sites

the server you provided in the link does not work it game me an error with the CodeChickenCore mod which i fixed and after that it could not find a download for the rest to support minecraft 1.5.2 so i guess i have to wait xD

Same here. Upon launching and downloading all the files up to CodeChickenCore everything works fine. Then a wild error message appears out of the black saying:

"This version of CodeChickenCore does not support minecraft version 1.5.2

Remove it from your coremods folder and check here for updates"

Checked the update link and downloaded the latest CodeChickenCore file and put it in my Coremods folder.

Still gave the same error message. No error code or log i'm afraid :(.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

Announcements

  • Anything claiming to be official Technic servers are not allowed here, for obvious reasons



×
×
  • Create New...