GenPage

Issue
Dropbox changes break Technic Platform links

31 posts in this topic

It has been reported on the Tracker that Dropbox recently made a change to their direct download links that breaks the Platform/Launcher link.

 

Tracker report: http://forums.technicpack.net/tracker/issue-2309-modpack-download-link-length/

 
New Dropbox Link:

https://www.dropbox.com/meta_dl/eyJzdWJfcGF0aCI6ICIiLCAidGVzdF9saW5rIjogZmFsc2UsICJzZXJ2ZXIiOiAiZGwuZHJvcGJveHVzZXJjb250ZW50LmNvbSIsICJpdGVtX2lkIjogbnVsbCwgImlzX2RpciI6IGZhbHNlLCAidGtleSI6ICI3ejQ5Y20wNjdmbTFpcDQifQ/AALEAZwB_ipxYVobUzUgESgRP2H92s9cKZVaI2z-xEIauQ?dl=1

What the Technic Platform saves:

https://www.dropbox.com/meta_dl/eyJzdWJfcGF0aCI6ICIiLCAidGVzdF9saW5rIjogZmFsc2UsICJzZXJ2ZXIiOiAiZGwuZHJvcGJveHVzZXJjb250ZW50LmNvbSIsICJpdGVtX2lkIjogbnVsbCwgImlzX2RpciI6IGZhbHNlLCAidGtleSI6ICI3ejQ5Y20wNjdmbTFpcDQifQ/AALEAZwB_ipxYVobUzUgESgRP2H92s9cKZVaI2z-

This is due to the standard length of characters a normal test field/string saves (255 characters).

 

Since the new dropbox links are longer than 255 characters, it cuts off the rest of the new link.

 

We are working to fix this issue. Expect a hot fix within the next day or so. 

 

Edit: http://copy.com has been suggested as an alternative.

Edited by GenPage
Extra info

Share this post


Link to post
Share on other sites

I've seen some packs on github, such as TPPI. But I don't know if that's just their source to work from for version control between their team or if they actually distribute from there. Interesting if they do.

Share this post


Link to post
Share on other sites

I've seen some packs on github, such as TPPI. But I don't know if that's just their source to work from for version control between their team or if they actually distribute from there. Interesting if they do.

You shouldn't be using GitHub to distribute packs directly, however it's version control system is awesome, so I personally use it to store the git repo, which I then mirror to a proper web server.

Share this post


Link to post
Share on other sites

Well that explains an aweful lot...

:/

 

 

Edit: http://copy.com has been suggested as an alternative.

How can I copy the download link adress?

It doesnt let me right click.

And I also tried copying the link adress from chrome's downloads, but I still get an error.

 

Edit: Yay never ming I fixed it  :D

Edited by omrizod

Share this post


Link to post
Share on other sites

Oops I didn't notice I bumped!

Sorry!

 

*EDITED*

Edited by omrizod

Share this post


Link to post
Share on other sites

I found a solution to the dropbox problem, 

replace www with dl and dropbox withdropboxusercontent in your URL. For example:

https://www.dropbox.com/s/xttkmuvu7hh72vu/MyFile.pdf

Becomes:

https://dl.dropboxusercontent.com/s/xttkmuvu7hh72vu/MyFile.pdf

To force a file download, append a direct link with ?dl=1. Example:

https://dl.dropboxusercontent.com/s/xttkmuvu7hh72vu/MyFile.pdf?dl=1

From http://tricksbuzz.com/get-direct-link-dropbox/

Edited by mymindstorm

Share this post


Link to post
Share on other sites

This is actually a viable fix. I have successfully tested this. Thanks for sharing! I tried scouring the web for something like this but it looks like I didnt look hard enough. 

Share this post


Link to post
Share on other sites

So does anyone know if the problem is fixed yet? (without having to change the www. into dl. and the dropbox.com to dropboxusercontent.com.)

Share this post


Link to post
Share on other sites

Hey guys,

 

I'm guessing this is having an issue with AoTB as this keeps ticking out the server.

 

04.07 14:59:23 [server] SEVERE java.io.IOException: Server returned HTTP response code: 500 for URL: https://dl.dropboxusercontent.com/u/87311923/Minecraft/Food%20Plus%20MOD/Updater/version.txt

 

Can you confirm if there is anything I can do or does this need to go to the foodplus devs?

Share this post


Link to post
Share on other sites

I found a solution to the dropbox problem, 

replace www with dl and dropbox withdropboxusercontent in your URL. For example:

https://www.dropbox.com/s/xttkmuvu7hh72vu/MyFile.pdf

Becomes:

https://dl.dropboxusercontent.com/s/xttkmuvu7hh72vu/MyFile.pdf

To force a file download, append a direct link with ?dl=1. Example:

https://dl.dropboxusercontent.com/s/xttkmuvu7hh72vu/MyFile.pdf?dl=1

From http://tricksbuzz.com/get-direct-link-dropbox/

 

Am I still missing something?  I've tried changing the URL and pasting it into the launcher where it asks for a URL when I add a new pack, but it tells me that the URL is not a valid one.  I've also tried downloading the modpack directly, but I still am unable to get a new modpack to work.  The only ones that do work are the ones that came "preloaded" when I downloaded Technic Launcher.

 

*edited* NEVERMIND, must have just been having bad luck with finding broken modpacks.  

Edited by MommyNurse2012

Share this post


Link to post
Share on other sites

Hey,

i have fixed this problem through this a few month ago and it worked fine. Since yesterday the problem was there again. I have done all the same changes as every update before but it won't work. :/

Please help me.

Share this post


Link to post
Share on other sites

Thanks for explaining. But the fix that I found is simple.

1-Right click the download button

2-Click "Copy Link Adress"

3-Now you have the right link for other programs to insta-download

Share this post


Link to post
Share on other sites

Thanks for your help.

I have tried your solution too and first without sucess. The problem i found was a character mistake in the version so the generated filename of the modpack was not compatible with the technic laucher or Dropbox(I don't know which one).

 

OT ON:

Another question about Dropbox: My modpack gets more popular and i have read that dropbox has a data traffic limit of 20Gb/day. Is it true and if yes what will happen after the traffic limit is reached?

OT OFF:

Edited by Honnebombel

Share this post


Link to post
Share on other sites

MommyNurse2012,

 

You didn't make it public, click the link button next to the file labeled: "
Share Link" after the page loads it should work.

 

 

Edited by mymindstorm

Share this post


Link to post
Share on other sites

ok, so i did what you suggested when i was creating my modpack, and now it can download correctly, so yay. but, now it just restarts the launcher every time i try to test-play it. im thinking its some kind of error on my part, but do you have any idea what it might be?

 

 

 

NVM I FIXED IT!!WHOOOO!!!!!

Edited by nuclearvillager

Share this post


Link to post
Share on other sites

ok, so i did what you suggested when i was creating my modpack, and now it can download correctly, so yay. but, now it just restarts the launcher every time i try to test-play it. im thinking its some kind of error on my part, but do you have any idea what it might be?

 

That is likely just an issue with the construction of your modpack and it would be best if you posted a new thread in the Platform Pagoda forum. Make sure to include a link to your Technic Platform modpack page.

Share this post


Link to post
Share on other sites

Just use copy.com. I've not had any issues with bandwidth restrictions or limits on the space they provide to free accounts.

Dropbox suspended my private links for going over traffic allocation or something like that so I'm trying to use copy.com problem being that the link is not valid. Do you know if there's something I need to do to change the link? I've tried looking elsewhere but I can only find instructions for older versions of the service that used a different link structure and those no longer work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By afchlam
      Hello!
      I have started a custom mod pack with these mods and whenever I load into the server I cannot craft or spawn non-vanilla objects and only vanilla mobs spawn. I have the gravestone mod installed, yet on death, I drop all items and no gravestones appear. Despite this, I can use NotEnoughItems for recipes and all items show up, vanilla and modded, when I use the /give command I cannot TAB and get other mod items through that. Whenever I attempt to spawn in a non-modded item it gives the error 'Item XXXX was not found.' I have looked up countless other places and all I can find is the configuration files are not the same, yet this error still occurs after an estimated 5 trials after copying the configuration files to the server. I have tested the exact same mod pack in survival and it works. Does anyone have any idea how this happens? This has to be an error with something server-side, maybe something is messed up in how I set up the files. I can also see the creative tabs and all of the item textures and even place the item in my inventory, but when I attempt to place it the item disappears from the inventory and does not place.
      I have the start-up batch file run off of the 'minecraft_server.1.7.10.jar ' file, but also tried running the forge file using my script file, which does not do anything, literally. I even attempted to run the 'minecraft_server.1.7.10.jar' file directly without a script file, same result.
      This is the script I have for my start-up script:
       
      Thank you in advance.
    • By Whitest
      My friend and I made a server for Tekxit, (Not Tekkit, I know, but it was the closest forum) and whenever I try to join the server, it gives me an error code telling me that two mods are incompatible. Upon looking at the mods page, it seems the versions of those mods are more recent than the ones the server expected. I do know, though, that the previous version of the modpack had the versions required for the server, so is there some way to play that older version instead of the newer one?



    • By ThatSourMelon
      Is this a bug? I don't know... feel free to move the forum. But I created a mudpack. I put it in drobox and I made it on the Technic Platform. When I search it on the technic launcher I install it, and click play. When Minecraft opens its just vanilla. It does not have a mods option, so its not running forge or something... I have a mods folder, I included modpack.jar, But I have done it a few times (a lot) and it still runs as vanilla. The Mod Pack is called Vanilla Revised and I just put a bunch of client mods in there for stuff. Here is the link to the dropbox: https://www.dropbox.com/s/afx5v05b7ymiahv/Vanilla Revised.zip?dl=1  Can someone look at it for me please and tell me what is wrong? Thx.
    • By zDorg4d0
      When I try to open a modpack the technic closes and after a while it opens again. Any solution?