Jump to content

Aci H
 Share

Recommended Posts

One of the biggest reasons to why I started this dicussion is because I don't want Technic pack, Tekkit classic (the actual tekkit) and voltz to become obscure references, as I have said before, they are the mod packs that made this launcher what it is today. Don't get me wrong, I enjoy the new launcher and packs but I find it a shame that the Technic pack, tekkit classic and voltz are now getting forgotten.

Link to comment
Share on other sites

  • Replies 112
  • Created
  • Last Reply

Top Posters In This Topic

They are being "forgotten" because they're obsolete and outdated.

The Ford T made the Ford company what it is today, but that car has been out of production for ages because... it's outdated and obsolete!

And just like the Ford T, there are still some Tekkit Classic and Technic SSP enthusiasts out there, but its makers don't want to officially support it because it's so outdated, so it isn't advertised on the front page.

Link to comment
Share on other sites

  • 2 weeks later...

I know but alot of people including me like EE2 best. I know that this whole thing with the changes isn't the modpack authors fault, choice, or will. The real culprits are the mod authors, for abandoning their mods and those who took some of those mods and messed them up, those who frose their mods in an old version trying to make a new mod with the same principal but not finishing it or not working hard enough on it or barely doing anything with it and the ones who put scripts to mess things up if the mod detects it's in a certain pack and those who won't forgive them despite their sincire apology and repair on the mod.

Link to comment
Share on other sites

the ones who put scripts to mess things up if the mod detects it's in a certain pack and those who won't forgive them despite their sincire apology and repair on the mod.

If you're talking about who I think you are, you need to understand that 'forgive' is a different thing to what is needed here, for me at least.  What would be needed for me would be for the person to prove that they weren't an unprofessional, primadonna dunderhead (not the original word I went with - it rhymed with "chuckletuck"), which unfortunately is much harder to do than it is the other way around.  I honestly hold that person in lower esteem than most black hats, at least they're after a challenge or money or something vaguely productive in its own destructive way.  It's not a matter of personal, it's not a matter of disliking the person, it's a matter of trusting a persons integrity.  If you take a person who's proven their lack of integrity before and then want trust that same integrity later when they offer a sincere apology then that's up to you, but that's risky, I don't blame Technic for avoiding that pack later (I would do the same, it's the only sensible option here).

 

You really should go onto platform pagoda and ask for some advice on how to build a pack using the mods you want, I'm sure that'll be more productive than arguing the point on this thread.

 

 

Seeing as I'm back in this thread after all this time, I'm going to mention that I'm hopeful that we'll get some section on the new launcher for a link to the server download (even if it's tucked away a bit so players don't hit it accidentally).  I know it's super-lazy, but it'd be a huge convenience when trying a lot of packs in fairly rapid succession not having to ferret out the server files every time.

Link to comment
Share on other sites

  • 4 weeks later...

If you're talking about who I think you are, you need to understand that 'forgive' is a different thing to what is needed here, for me at least.  What would be needed for me would be for the person to prove that they weren't an unprofessional, primadonna dunderhead (not the original word I went with - it rhymed with "chuckletuck"), which unfortunately is much harder to do than it is the other way around.  I honestly hold that person in lower esteem than most black hats, at least they're after a challenge or money or something vaguely productive in its own destructive way.  It's not a matter of personal, it's not a matter of disliking the person, it's a matter of trusting a persons integrity.  If you take a person who's proven their lack of integrity before and then want trust that same integrity later when they offer a sincere apology then that's up to you, but that's risky, I don't blame Technic for avoiding that pack later (I would do the same, it's the only sensible option here).

 

You really should go onto platform pagoda and ask for some advice on how to build a pack using the mods you want, I'm sure that'll be more productive than arguing the point on this thread.

 

 

Seeing as I'm back in this thread after all this time, I'm going to mention that I'm hopeful that we'll get some section on the new launcher for a link to the server download (even if it's tucked away a bit so players don't hit it accidentally).  I know it's super-lazy, but it'd be a huge convenience when trying a lot of packs in fairly rapid succession not having to ferret out the server files every time.

I was wondering, just out of curiosity, is it still possible to loggin and use The old Technic launcher.

Edited by Aci H
Link to comment
Share on other sites

Oh wow, I remember this - congratulations on eliciting that rant out of me, I'm usually more reserved than that :)

 

 

It's a no (login difficulties at the least) as people had said on the previous page, but the important thing is it doesn't matter - the new launcher can run old versions of minecraft with the old versions of mods, you'll just need to get a pack with what you want in it.

 

Either search here to try to find something that fits what you wanted: http://www.technicpack.net/modpack/list

Or go on here and request the kindness of strangers in assembling it for you: http://forums.technicpack.net/forum/65-platform-pagoda/ (if you do that, be specific and polite or people are unlikely to bother).

Link to comment
Share on other sites

Oh wow, I remember this - congratulations on eliciting that rant out of me, I'm usually more reserved than that :)

 

 

It's a no (login difficulties at the least) as people had said on the previous page, but the important thing is it doesn't matter - the new launcher can run old versions of minecraft with the old versions of mods, you'll just need to get a pack with what you want in it.

 

Either search here to try to find something that fits what you wanted: http://www.technicpack.net/modpack/list

Or go on here and request the kindness of strangers in assembling it for you: http://forums.technicpack.net/forum/65-platform-pagoda/ (if you do that, be specific and polite or people are unlikely to bother).

Yeah I just reinstalled the old launcher on my new harddrive and when I try installing a modpack or logging in it says: "Unable to Authenticate account with Minecraft.net" So now I just starre at that launcher nostalically and wish I could somehow fix it.

Link to comment
Share on other sites

  • 1 month later...

I thought about something, the Ford T, is a physical object that needs to be recreated a million times over for all the users to get it, Technic pack is software, which only needs to be created once and that's that, it gets put in whatever and people can just download a copy of it there, it doesn't need recreation like the Ford T, it's just like all the other modpacks, re-adding it is like having added TPPI or Attack of the B team. It's software that get's copied and downloaded. It doesn't really need support, just re-adding to make it work. I'm not trying to convince you to agree with me, this though came to me like days ago when I was playing unturned.

Link to comment
Share on other sites

When the Model A came out, Ford discontinued the Model T. I'm sure there were many people who wanted the Model T instead, but their only choice was the Model A. Ford decides what car they want to sell, regardless of what a select few people might want to buy.

Link to comment
Share on other sites

When the Model A came out, Ford discontinued the Model T. I'm sure there were many people who wanted the Model T instead, but their only choice was the Model A. Ford decides what car they want to sell, regardless of what a select few people might want to buy.

I know, this was just like an idea of mine. I understand what you're saying.

Link to comment
Share on other sites

  • 2 months later...

I have asked the guys behind technic before about updating tekkit classic. (I even made myself a 1.6.4 version of tekkit classic with ALL mods from the 1.2.5 version) They clearly said they are never going to update it :/ Dunno if its because of the past of tekkit classic or just because they gave up on it...

Link to comment
Share on other sites

All of the mods?  I didn't realize Equivalent Exchange 2 was updated and IC2 reverted the lame game design changes.

Not officially, but there is a recreation of EE2 called Project E and Immibis remade the original IC2 as an IC2 plugin (or independent mod, not sure since I've never actually used it (have no reason to when I have things like Thermal Expansion and MFR)) named "IC2 Classic".

 

I have seen two packs that have "recreated" Tekkit Classic in 1.7.10, but they both use the Gregesque IC2 Experimental rather than IC2 Classic.

Link to comment
Share on other sites

Hi, so, let's chat:

- The old launcher doesn't work. The big offender is that the news API (remember that small news box in the top right corner?) is now totally different and the old launcher doesn't handle that as well as it probably should. We actually get issues opened on github every day from people on cracked launchers (none of which have updated yet) complaining about the crash resulting from the news API change. I cackle as I close their issues.

- Tonight (Thursday), we're pushing some improvements that will break everything else, too.

- Both of these are fixable, incidentally, without too much work. And our work is open source. That said, the new platform has different pack image sizes, so nothing will look very good.

- We are never going to update the pack entitled Tekkit Classic. The purpose of Tekkit Classic and Tekkit Lite, Yogbox, Big Dig, etc. are to keep those packs around so enthusiasts can continue playing them. The problem with updating the pack is, we're never going to make a pack that's just Tekkit Classic, but up to date. It's not possible to do, and some Tekkit Classic enthusiasts will not want to play the new version because they won't like the liberties we'd have to take to bring it up to 1.7.10. By updating Tekkit Classic instead of making a new pack, we're making it more difficult for them to play the version they like. It's REALLY hard for a server to get players to play a pack version that isn't Recommended or Latest.

- That doesn't mean that there will never be a pack LIKE Tekkit Classic. But your opinion and my opinion about what is "like" Tekkit Classic might differ. I think Attack of the B-Team is "like" Big Dig. I think they scratch the same itch. If we do make a pack "like" Tekkit Classic, it would have resource exchange (Project E or something), very few mods, integrated redstone, quarries, and machines. That is the full list of similarities it would have with Tekkit Classic. It would almost certainly not have IC2.

- Likewise, we are not going to make a pack like Technic Pack. Mainly because I don't know what "like Technic Pack" even means. It was basically a pack with a lot of mods in it. That was a big deal at the time but now it's pretty overdone and boring. Sorry.

- There were some key issues with putting Technic Pack up on solder. We don't have the capability to put more than a version or two up, just due to the window of Minecraft versions we support, we don't have the mod files lying around, and plenty of folks on the platform have done a great job of doing it for us.

I don't know what I've missed. I do think you should give making your own pack a shot. Especially if you're particular about what you play. I think the new launcher's pretty rad.

Link to comment
Share on other sites

  • 2 months later...

Hi, so, let's chat:

 

- The old launcher doesn't work. The big offender is that the news API (remember that small news box in the top right corner?) is now totally different and the old launcher doesn't handle that as well as it probably should. We actually get issues opened on github every day from people on cracked launchers (none of which have updated yet) complaining about the crash resulting from the news API change. I cackle as I close their issues.

- Tonight (Thursday), we're pushing some improvements that will break everything else, too.

- Both of these are fixable, incidentally, without too much work. And our work is open source. That said, the new platform has different pack image sizes, so nothing will look very good.

 

- We are never going to update the pack entitled Tekkit Classic. The purpose of Tekkit Classic and Tekkit Lite, Yogbox, Big Dig, etc. are to keep those packs around so enthusiasts can continue playing them. The problem with updating the pack is, we're never going to make a pack that's just Tekkit Classic, but up to date. It's not possible to do, and some Tekkit Classic enthusiasts will not want to play the new version because they won't like the liberties we'd have to take to bring it up to 1.7.10. By updating Tekkit Classic instead of making a new pack, we're making it more difficult for them to play the version they like. It's REALLY hard for a server to get players to play a pack version that isn't Recommended or Latest.

- That doesn't mean that there will never be a pack LIKE Tekkit Classic. But your opinion and my opinion about what is "like" Tekkit Classic might differ. I think Attack of the B-Team is "like" Big Dig. I think they scratch the same itch. If we do make a pack "like" Tekkit Classic, it would have resource exchange (Project E or something), very few mods, integrated redstone, quarries, and machines. That is the full list of similarities it would have with Tekkit Classic. It would almost certainly not have IC2.

- Likewise, we are not going to make a pack like Technic Pack. Mainly because I don't know what "like Technic Pack" even means. It was basically a pack with a lot of mods in it. That was a big deal at the time but now it's pretty overdone and boring. Sorry.

- There were some key issues with putting Technic Pack up on solder. We don't have the capability to put more than a version or two up, just due to the window of Minecraft versions we support, we don't have the mod files lying around, and plenty of folks on the platform have done a great job of doing it for us.

 

I don't know what I've missed. I do think you should give making your own pack a shot. Especially if you're particular about what you play. I think the new launcher's pretty rad.

​When you say "Old launcher are you talking about the V2 launcher or the first one the V1, the classical one?

Link to comment
Share on other sites

Hi, so, let's chat:

 

- The old launcher doesn't work. The big offender is that the news API (remember that small news box in the top right corner?) is now totally different and the old launcher doesn't handle that as well as it probably should. We actually get issues opened on github every day from people on cracked launchers (none of which have updated yet) complaining about the crash resulting from the news API change. I cackle as I close their issues.

- Tonight (Thursday), we're pushing some improvements that will break everything else, too.

- Both of these are fixable, incidentally, without too much work. And our work is open source. That said, the new platform has different pack image sizes, so nothing will look very good.

 

- We are never going to update the pack entitled Tekkit Classic. The purpose of Tekkit Classic and Tekkit Lite, Yogbox, Big Dig, etc. are to keep those packs around so enthusiasts can continue playing them. The problem with updating the pack is, we're never going to make a pack that's just Tekkit Classic, but up to date. It's not possible to do, and some Tekkit Classic enthusiasts will not want to play the new version because they won't like the liberties we'd have to take to bring it up to 1.7.10. By updating Tekkit Classic instead of making a new pack, we're making it more difficult for them to play the version they like. It's REALLY hard for a server to get players to play a pack version that isn't Recommended or Latest.

- That doesn't mean that there will never be a pack LIKE Tekkit Classic. But your opinion and my opinion about what is "like" Tekkit Classic might differ. I think Attack of the B-Team is "like" Big Dig. I think they scratch the same itch. If we do make a pack "like" Tekkit Classic, it would have resource exchange (Project E or something), very few mods, integrated redstone, quarries, and machines. That is the full list of similarities it would have with Tekkit Classic. It would almost certainly not have IC2.

- Likewise, we are not going to make a pack like Technic Pack. Mainly because I don't know what "like Technic Pack" even means. It was basically a pack with a lot of mods in it. That was a big deal at the time but now it's pretty overdone and boring. Sorry.

- There were some key issues with putting Technic Pack up on solder. We don't have the capability to put more than a version or two up, just due to the window of Minecraft versions we support, we don't have the mod files lying around, and plenty of folks on the platform have done a great job of doing it for us.

 

I don't know what I've missed. I do think you should give making your own pack a shot. Especially if you're particular about what you play. I think the new launcher's pretty rad.

​Alright, thanks for the detailed explanation, I get what's going on for the most part. But a friend of mine was wondering, you said that you weren't updating Tekkit Classic, so that it could be left in it's original form, he was wondering, why can't the same be done with Technic SSP?  Why can't Technic SSP be added, but left in it's original form  in 1.2.5 as it was in the old launcher and just not be updated like you're doing with Tekkit Classic? And my personal question is, why is IC2 being left out of any new or updating modpacks?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Announcements

  • Anything claiming to be official Technic servers are not allowed here, for obvious reasons



×
×
  • Create New...