Jump to content
KakerMix

Technic Platform V2 and Technic Launcher V3

Recommended Posts

 

MDyTikO.png

 

We're getting ever closer to :siren: TECHNIC PLATFORM V2 :siren: and :siren:TECHNIC LAUNCHER V3 :siren:, and the time has come to let some people in and start actually using it. We've still got some things to do and with your guys' help we'll get there sooner rather than later.

 

The new Platform is here: http://beta.technicpack.net/

The new Launcher is available from here: LauncherV3


 

This is a major design and (especially) feature shift from the current system.

For those of you that make packs you get access to a wealth of social features, update-in-launcher aspects and a very clear line of communication to your users. Your Platform page is now a very robust platform (heh) from which to show off your creation and engage with your users directly.

For those of you that just play, now you'll have many more ways to interact with pack creators and a voice of your own to highlight packs you like, read what other users are doing, etc.

Everyone will benefit from the new system, and we hope you guys like it as much as we've loved creating it for you. Please remember that this is not complete and things will be broken. If you find something that doesn't work like you think it should post it here, or come to #platformbeta on SynIRC and let us know. 

 

If you already have a Platform account (not the same as your Forums account) just use the same info to log in, remember to use your email instead of your username.

 

List of new features:

  • Platform Features:
    • All NEW social features! :parrot:
      • Ability to follow users and modpacks
      • Ability to post statuses as a user or a modpack owner.
      • Dashboard feed of followed users/modpack posts
      • Community feed of fellow users modpacks
      • Like/Comment/Report posts
    • New search engine powered by elasticsearch
      • Makes it easier to find modpacks on the platform :woot:
      • New algorithm to calculate trending modpacks! DOWN WITH +1
      • New statistics system for calculating runs and installs
    • Improved back-end code
    • Redesigned Admin console (for us)
    • AND MUCH MORE
  • Launcher Features:
    • ALL NEW DESIGN!!!!! :parrot:
    • Modpacks
      • Abillity to search for modpacks!
      • Abillity to Install modpacks!
      • View modpack descriptions and status posts!
      • View modpack likes/runs/installs!
    • News
      • View news posts in a newly organized tab
    • Discover
      • View trending, HOT, and new modpacks
    • General Options
      • New selectable language support! (Translators wanted!)
      • Custom Java arguments

 

Share this post


Link to post
Share on other sites

Where I can delete my own modpacks on Technicplatform V2 ? I don't see the "Delete" button. And for API Key, I can't regenerate a new key, because I don't see teh button.

Edited by TheGeekdu74

Share this post


Link to post
Share on other sites

I cant log in to the v2 pack website and I know all my info is right.

I'm having the same problem...V1 info didn't carry over to V2.  Do I have to make a whole new account for V2?

Share this post


Link to post
Share on other sites

Sounds fantastic.  Just curious, looking through the features; is there anything planned for allowing incremental updates to modpacks (akin to using solder) built in?  Tried Solder a few times and could never get it set properly.  

Share this post


Link to post
Share on other sites

I'm having the same problem...V1 info didn't carry over to V2.  Do I have to make a whole new account for V2?

No.  That's just because the site is in Beta.  Your V1 will work fine with the real deal.

Share this post


Link to post
Share on other sites

This may sound a bit silly, but please reduce the width of the launcher.

half of it disappears off of the screen, making it difficult to use.

 

Ps. Nobody dare make the rude suggestion I should buy a new screen.

Share this post


Link to post
Share on other sites

Can you not... drag the launcher around the screen so it'll fit better?

He probably has a low resolution monitor so the launcher is too many pixels wide to fit.

Share this post


Link to post
Share on other sites

Hi,

 

I have just downloaded the last stable version of the launcher for Mac OS X, or the .app.zip file, and my Mac is not able to open the file. The .jar file works fine, but the .app file does not work at all. When I try to open it, it says that it cannot be opened, no explanation given.

 

Thanks,

 

HammerMan216

Share this post


Link to post
Share on other sites

As in what kind of mud would he like to have the launcher throw at him? Me, I recommend the kaolin blend.

Share this post


Link to post
Share on other sites

As in what kind of mud would he like to have the launcher throw at him? Me, I recommend the kaolin blend.

 

Fortunately Solder will let people include mud from all over the world.

Share this post


Link to post
Share on other sites

Fortunately Solder will let people include mud from all over the world.

And have varying throwing speeds as well as volume...

 

Okay, joke ran its course. I love misspellings, but let's focus.

Share this post


Link to post
Share on other sites

I've been having problems getting one of my Solder-enabled packs to link properly to the Platform beta. Of my three Solder packs, only one of them is failing to properly link (and of course it's the one I NEED to be linked properly right now...).

 

Despite having Solder configured and linked on my profile, and the pack in question claiming to have a successful link on the Edit Modpack page, the main modpack page still says that the modpack isn't properly configured (and needs a link to a zip or Solder configuration). I've tried unlinking and relinking Solder (both on live and beta platform). I wanted to try to generate a new API key for beta and relink, but there's no button to generate a new key at the moment. I'd rather not delete and re-create the pack on the platform to keep my users from having to reinstall.

 

When I try to run the pack from the launcher using the version installed by the live launcher, the launcher tries to update the pack (which is already up to date) but fails to download ("Invalid URL: "). If I delete the installed pack and try to add it in the new launcher, it fails to download the pack entirely.

Edited by DeviPotato

Share this post


Link to post
Share on other sites

guys how do i see what my teccnic password is. ive forgotten it. and the reset doesnt seem to work. i realy need help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Upikia123
      I really need some help please, it's making like 2 days I'm trying to figure out what's wrong with technic launcher, because everytime I click on play to launch a modpack, it's just closing the technic launcher sreen, load a littlebit and then it just pop-up the technic launcher screen again, I know that Java is not the problem because I tried the 8u25, the 8 251 and the 8 191 version and they all did the same error again and again. I was thinking that my graphic card driver was the problem, but I just updated it to the last version and it did the same. I also did every Windows Update and it did the same again... I would be glad to find a solution.. 
      Here are the last crash report (log) I had:crash-2020-04-19_20.41.04-client.txt
    • By Mikewood
      I was used to play modpacks on the technic launcher. But today i can't start the modpack.
      When i click on the play button, it closes the window like the modpack is normally loading. But after maybe 10 seconds it open the technic launcher window again.  Here is my crash report. I don't know why is it not working. Can anyone help or know the possible fixes ? 
       
      crash-2020-04-17_13.07.04-client.txt
    • By LonkaGaming
      Your world is save in %appdata% .technic>modpacks<select your modpack<saves
    • By FullMetalFerkel
      When I run the TechnicLauncher.exe the first time I can install it and every thing is fine. But when I try to run the TechnicLauncher.exe after the installation it won't open. It doesn't even pop up an error dialog. When I look into the latest log file it show following error:
          > java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities.
      I googled for a few weeks now and didn't find a solution. Sadly I didn't even found somebody with the same problem.
      I currently have a java JRE 8u211 installed. previously I had some java 10 JDK but thought that would be the problem and deleted it. Since I'm not developing java on this machine I simply installed the 8u211 JRE and hoped this would fix my problem.
      Since AWTUtilities is a standard java class I didn't expect technic launcher to have any issue with it, as long as the launcher can find my java installation. But as far as I know, my environment variables are correctly setup and java should be installed correctly.
      I add the technic launcher error log, and some screenshots about my java installation.
      I hope you guys can help me, and I hope I didn't miss one of the forum rules. Thanks in advance



      techniclauncher_2019-05-31.log
    • By Quizer9O8
      Hello there,
      Since I haven't got any luck of finding a fix or someone mentioning this issue I'll place it down right here.
      A few months ago I have noticed that whenever you're launching a Minecraft modpack from the Technic Launcher Minecraft suddenly hijacks all of the available RAM which causes to freeze the entire computer for 10 - 15 minutes before I'm able to terminate the process manually in Task Manager (Windows 10). Since I have 16GB of RAM in my pc I allocated 8GB of RAM to Minecraft (which should be enough for many modpacks) in the settings shown here below but no matter what is set in the Launcher Options seems to have any effect, it straight up ignores it all together.

      I'm out of ideas and in desperate need for a solution because this issue makes every modpack I have (small or large) unplayable at this point.
×
×
  • Create New...